-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans  .- Knowledge Base  . 

ClickSpotter

   0.1.1  

KDE Networking Tool

Score 81%
ClickSpotter
zoom


Link:  Link
Minimum required   Qt 3.x
Downloads:  1156
Submitted:  Jan 20 2006
Updated:  Jan 24 2006

Description:

ClickSpotter is a real-time web server logfile monitor with IP geolocation support. It has three main features that differentiate it from the rest of the log file analyzers.

* It processes your Apache access log file in real-time and produces consolidated live reports about your visitors and current page accesses.

* It can pinpoint your visitors and the path they used through the Internet on a worldmap using IP geolocation.

* It is a real desktop application, not just a bunch of generated web pages with a clumsy browser-based interface.




Changelog:

* Make sure that all threads are being terminated. This bug kept an instance of ruby hanging around even when the program exited.
* Normalize URLs. Remove the trailing / so foo/ and foo are counted as the same page.
* Fix crash when undefined HTML status code is found in log.
* Save settings of world map when program is exited while map is still open.
* Fix crash when selecting 30 minute monitor window.
* Added support for setup.rb
* Fix wrong resolver results after each purge.




LicenseGPL
Source(ClickSpotter-0.1.1.gem)
Source(ClickSpotter-0.1.1.tar.gz)
Send to a friend
Subscribe
Other  Apps  from cschlaeg
Report inappropriate content



-

 OK, looks cool...

 
 by rickvernam on: Jan 20 2006
 
Score 50%

but what in the world do I do with a .gem file?

How to install, or start...etc ?


Reply to this

-
.

 Re: OK, looks cool...

 
 by EliasP on: Jan 20 2006
 
Score 50%

http://clickspotter.ath.cx/

have a look at the homepage for a short explanation how to install a gem.

Greetings

Elias P.


Reply to this

-
.

 Re: Re: OK, looks cool...

 
 by billkendrick on: Jan 21 2006
 
Score 50%

Hrm, I've installed it (I needed to install "gem", and then get the "rdoc" package). It seemed to install happily. I'm pulling down my server logs with the "tail -f" example from the site, but ClickSpotter doesn't seem to actually work when I run it.

e.g., I type "clickspotter local_copy.log" and nothing happens... I just get another bash prompt. Running "clickspotter" with no arguments does the same thing.

Maybe I'm missing some Qt+Ruby stuff, and Gem didn't bother warning me?...


Reply to this

-
.

 Doesn't start

 
 by EliasP on: Jan 21 2006
 
Score 50%

clickspotter doesn't start ;/


elias@osgiliath ~ $ clickspotter
/usr/lib/ruby/site_ruby/1.8/Qt/qtruby.rb:649:in `initialize': unresolved constructor call Qt::SizePolicy (ArgumentError)
from /usr/lib/ruby/site_ruby/1.8/Qt/qtruby.rb:649:in `try_initialize'
from /usr/lib/ruby/site_ruby/1.8/Qt/qtruby.rb:648:in `try_initialize'
from /usr/lib/ruby/gems/1.8/gems/ClickSpotter-0.1.0/lib/MainWindowDlg.rb:403:in `initialize'
from /usr/lib/ruby/gems/1.8/gems/ClickSpotter-0.1.0/lib/MainWindow.rb:53:in `initialize'
from /usr/lib/ruby/gems/1.8/gems/ClickSpotter-0.1.0/lib/clickspotter.rb:33
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require'
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:182:in `activate'
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:181:in `activate'
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:37:in `require_gem_with_options'
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:31:in `require_gem'
from /usr/bin/clickspotter:17


Installed packages:
dev-lang/ruby-1.8.4-r1
dev-ruby/rubygems-0.8.11-r3
kde-base/qtruby-3.5.0-r1
kde-base/smoke-3.5.0
net-analyzer/traceroute-1.4_p12-r3

Does anybody know, how to fix this?

Thanks!!

Elias P.


Reply to this

-
.

 Re: Doesn't start

 
 by billkendrick on: Jan 21 2006
 
Score 50%

I installed "libqt0-ruby1.8" and now when I run "clickspotter", I get the same error as you -- I guess that's better than nothing happening at all, like before -- /usr/lib/ruby/1.8/Qt/qtruby.rb:605:in `initialize': unresolved constructor call Qt::Pixmap (ArgumentError) ... etc.

Oh well!


Reply to this

-

 Re: Doesn't start

 
 by cschlaeg on: Jan 22 2006
 
Score 50%

Your qtruby bindings are too old. You need at least 1.0.11 (or KDE bindings snapshot). Anything that is older than 3 weeks won't work due to a changed behaviour of Ruby 1.8.4.


Reply to this

-

 Doesn't start

 
 by ruurd on: Jan 24 2006
 
Score 50%

Oh. Goody. ruby-1.8.4. That will probably leave anybody that does not run a cutting edge ruby in the dust.


ruurd
Reply to this

-

 Good project, but...

 
 by alex77s on: Jan 24 2006
 
Score 50%

Good project, but at this time, I haven't still been able to try it.

I've updated my ruby to 1.8.4, the qtruby to 1.0.11 and the rubygems to 0.8.11 (korudum is necessary? In case I've tried to compile but the make process fail with some errors).

I've KDE 3.5.0, and a SuSE 9.3.
When I try to start clickspotter, I obtain this output:
/usr//lib/ruby/site_ruby/1.8/Qt/qtruby.rb:679:in `initialize': unresolved constructor call Qt::SizePolicy (ArgumentError)
from /usr//lib/ruby/site_ruby/1.8/Qt/qtruby.rb:679:in `try_initialize'
from /usr//lib/ruby/site_ruby/1.8/Qt/qtruby.rb:678:in `try_initialize'
from /usr//lib/ruby/site_ruby/1.8/MainWindowDlg.rb:403:in `initialize'
from /usr//lib/ruby/site_ruby/1.8/MainWindow.rb:53:in `initialize'
from /usr//lib/ruby/site_ruby/1.8/clickspotter.rb:36
from /usr/bin/clickspotter:3

and I don't understand what I would have do in order to resolve this problem.

Thanks.


Reply to this

-

 Re: Good project, but...

 
 by rdale on: Jan 24 2006
 
Score 50%

I'm afraid it will only be fixed in the next release of qtruby (1.0.12). You can apply this patch to qtruby.rb in the meantime:

Index: qtruby.rb
===================================================================
--- qtruby.rb (revision 486772)
+++ qtruby.rb (revision 496305)
@@ -721,7 +721,7 @@
if argtype == 'i'
if typename =~ /^int&?$|^signed int&?$|^signed$|^qint32&?$/
return 1
- elsif typename =~ /^(?:short|ushort|unsigned short int|uint|long|ulong|unsigned long int|unsigned|float|double)$/
+ elsif typename =~ /^(?:short|ushort|unsigned short int|uchar|uint|long|ulong|unsigned long int|unsigned|float|double)$/
return 0
elsif typename =~ /^(quint|qint|qulong|qlong|qreal)/
return 0


-- Richard
Reply to this

-
.

 Deadly Project ???

 
 by betamax on: Jul 1 2006
 
Score 50%

The Downloadlinks are broken.


Reply to this

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.