-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (4) .- Knowledge Base  . 

Kdenlive Builder Wizard

   0.9.90  

KDE Kommander Script

Score 76%
Kdenlive Builder Wizard
zoom


Kdenlive Builder Wizard
zoom


Kdenlive Builder Wizard
zoom


Minimum required   Kommander
Downloads:  5721
Submitted:  Jul 24 2008
Updated:  May 30 2009

Description:

Kdenlive Builder Wizard is a Kommander script that builds the
development version of the Kdenlive Non-Linear Video Editor.

Release notes for version 0.9.90

This release fits the new organization of MLT, the "extreme makeover",
that reorganized mlt to include mlt++ by default, and moved the
sources from svn to git. This also means that you will be able to
build the forthcoming Kdenlive 0.7.4 with this wizard.

IMPORTANT: If you have mlt and mlt++ sources checked out from before
the makeover, you MUST delete these sources before running this
wizard! Otherwise, the wizard will fail.

Also note, that git is new to me, and pulling specific versions may
not work well. I *think* it works, but currently I understand to
little of git to be sure.

This release still relies on Kommander for KDE 3. Sorry about that. I
really want to get off Kommander, but lack the time to port it to
something else.

And finally a plea: If you like this program, why not click good to
increase its rating? Thanks.

Release notes for version 0.9.10

Fix: ffmpeg now needs --enable-nonfree, if compiling with AAC support.

More thoroughly cleaning of ffmpeg. Pass proper PKG_CONFIG_PATH to
kdenlive to not have it do version check against wrong frei0r installation.

Outstanding issues

Apart from the known limitations, the wizard currently is only known
to run under the KDE3 version of Kommander. At least one distribution
(Mandriva 2009) installs the KDE4 version of Kommander by default. The
wizard does not appear to work with this version. So, you need to use
the KDE3 version of Kommander to use this wizard. The KDE3 version of
Kommander should work under both KDE3 and KDE4 however, so you can
still build Kdenlive for KDE4 while running and using KDE3, but if you
have only KDE4 libs on your system, you will have to install the KDE3
version of Kommander to use the wizard.

Kubuntu 8.10 and ubuntu 8.10 may have to enable backports and
upgrade all kde4 related packages to succesfully compile.

About the wizard

This Kommander script is meant to help you get the development (SVN)
version of kdenlive (A non-linear video editor for KDE, homepage at
http://www.kdenlive.org/), and build it.

A lot is happening with Kdenlive, but stable releases can be far in
between - therefore the motivation for building from the development
sources.

Building kdenlive from the development versions can be a bit of a
hassle, as it often also depends on development versions of ffmpeg,
mlt. This wizard removes a lot of the hassle, by checking a lot of
dependencies, downloading development sources for ffmpeg, mlt,
and kdenlive, and configuring and building them. Optionally it can
also get and compile the frei0r plugin suite for you.

Simply install a number of dev packages, answer a few questions, click
a few buttons, press "Go", and it will retrieve or update your
sources, configure, compile, and install them, as you have instructed.

If everything goes well, you will soon have a working version of the
kdenlive development version. If it fails, you will get access to a
full log of the commands run, and can try to fix the problem (missing
libs, most likely, but sometimes the developers also check stuff into
svn that just don't compile), before restarting the wizard.

The wizard has been tested for KDE3 on Kubuntu 7.10, using Kommander
1.2.2, for KDE4 on Kubuntu 8.04 using KDE 4.1.2, and on Kubuntu 8.10
using KDE 4.1.2. Several people have reported succes using it, and it
has been known to work for SUSE, Alt Linux and Mandriva.

Please send bugreports to my email (included in the about box, make
sure to include the log from the wizard). Feel free to send a
success report too - or click "good" on the homepage, if you like
it. If you click bad, please leave a comment as to why.

Features

  • Very easy to use Wizard interface, with extensive help, tooltips and "What's this" used throughout

  • Get or update all needed sources, optionally to specific versions

  • Optionally get and build the Frei0r plugin modules for Kdenlive

  • Stores "last-known-good" revision/commit numbers for packages, updated following success

  • Stores settings between uses

  • Checks for presence of many needed tools (svn, git, cmake, c++, pkg-config and some others)

  • Checks for the presence of many needed packages "up front"

  • Uses the http versions of the sourceforge repos, to avoid certificate "problems".

  • Adjust the make -j parameter after the number of cores

  • Explicit option for root install

  • Allow for automatic install into datestamped directory

  • Creates startup script for the custom installed kdenlive, that supports gdb logging and version information

  • Easy to follow feedback during get/configure/install, through progressbar and statusfield

  • Full log of all actions, inclusive settings available directly from the wizard (for e.g. bug reports/troubleshooting).

  • Hands free during operations: collects options initially (and, if needed, sudo password), then either run to it completes or fails.

  • Source package contains command line (non-GUI) program to do automatic update builds.


  • Known limitations

  • The wizard is currently only known to work with the KDE3 version of Kommander.

  • There is a known problem with sox on kubuntu - check the disclaimer button

  • This wizard can not handle svn through an http proxy - check the disclaimer button

  • The wizard has some limitations on distros that rename KDE4 binaries in non-standard ways - check the disclaimer button


  • Platform specific hints

    It is the intention that this wizard should work with most Linux
    distributions. Here are some hints and/or wellknown problems and solutions:

    Ubuntu

    A mini-howto has been added to the Ubuntu wiki at
    https://help.ubuntu.com/community/KdenliveSVN.

    Note, that many users of Ubuntu 8.10 has reported that in order to
    compile, it is neccesary to enable the "backports" repository in
    synaptic, and update/upgrade all kde4 related packages.

    Kubuntu 8.10:

    Issue the following commands:

    1) sudo apt-get update ; sudo apt-get upgrade

    2) on a single line: sudo apt-get install gettext kommander gawk
    x11proto-core-dev libxau-dev libxdmcp-dev x11proto-xext-dev
    libxext-dev libxi-dev x11proto-input-dev x11proto-kb-dev xtrans-dev
    libpthread-stubs0 libpthread-stubs0-dev libxcb1-dev libxcb-xlib0-dev
    libx11-dev mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev libice-dev
    libsm-dev x11proto-render-dev libxfixes-dev libxcursor-dev
    libexpat1-dev zlib1g-dev libfreetype6-dev pkg-config
    libfontconfig1-dev libxft-dev x11proto-xinerama-dev libxinerama-dev
    libxmu-headers x11proto-randr-dev libxrandr-dev libxt-dev
    x11proto-record-dev libxtst-dev cmake cvs libstdc++6-4.3-dev g++-4.3
    g++ libxmu-dev liblcms1-dev libjpeg62-dev libmng-dev libpng12-dev
    xlibmesa-gl-dev libglu1-xorg-dev libaudio-dev libssl-dev libkadm55
    comerr-dev libkrb5-dev libpq-dev libglib2.0-dev libsqlite0
    libsqlite0-dev libqt4-dev libsoprano-dev automoc libphonon-dev
    libasound2-dev libgpg-error-dev libgcrypt11-dev libtasn1-3-dev
    libgnutls-dev libcups2-dev libdbus-1-dev libkeyutils-dev
    libstreams-dev libstreamanalyzer-dev libxml2-dev libxml2-utils
    libxslt1-dev libgif-dev libavahi-common-dev libbz2-dev libenchant-dev
    libattr1-dev libacl1-dev libjasper-dev libilmbase-dev libopenexr-dev
    libpcrecpp0 libpcre3-dev libtiffxx0c2 libtiff4-dev hspell xsltproc
    kdesdk-scripts kdelibs5-dev libslang2-dev libncurses5-dev libaa1-dev
    libapr1 libaprutil1 libartsc0-dev libaudiofile-dev libcucul-dev
    libcaca-dev libdirectfb-extra libsysfs-dev libdirectfb-dev libesd0-dev
    libneon27-gnutls libqt4-opengl-dev libsdl1.2-dev libsvn1 subversion
    libglib1.2ldbl libgtk1.2-common libgtk1.2 libavc1394-0 libiec61883-0
    libfreebob0 libjack0 libsndfile1 jackd ladspa-sdk libavutil49 libgsm1
    libavcodec51 libdv4 libfaad0 libjack-dev libmad0 libmad0-dev
    libogg-dev libpopt-dev libqt4-gui libswscale0 libquicktime1
    libsamplerate0-dev libvorbis-dev qjackctl dvgrab libdv-bin libdv4-dev
    libfaac0 libfaac-dev libfaad-dev libmp3lame0 libmp3lame-dev
    libtheora-dev

    3) run 'kmdr-executor 85826-kdenlive_builder_wizard.kmdr', follow the
    instructions on-screen. Press "Cancel" after succes, press "open
    folder", click "kdenlive_start" and you are in bussiness.

    Note, that some users of Kubuntu 8.10 has reported that in order to
    compile, it is neccesary to enable the "backports" repository in
    synaptic, and update/upgrade all kde4 related packages.

    Older Kubuntu
    Kubuntu users can use the instructions for Ubuntu, or the instructions
    below, that get a baseline build going on Kubuntu 8.04 with KDE4.1:

    1) install Kubuntu 8.04 (you may be past this :-)
    2) sudo apt-get update ; sudo apt-get upgrade
    3) follow instructions at http://www.kubuntu.org/news/kde-4.1 to get kde 4.1 installed
    4) sudo apt-get install kommander subversion g++ cmake pkg-config kdelibs5-dev libsdl1.2-dev libxml2-dev
    (This potentially add many packages to the system)
    5) log out, log in using kde 4.1 OR alternatively, use 'export PATH=$PATH:/usr/lib/kde4/bin'
    6) run 'kmdr-executor 85826-kdenlive_builder_wizard.kmdr', follow the instructions on-screen. Press "Cancel" after succes, press "open folder", click "kdenlive_start" and you are in bussiness.

    Note, that this compiles mlt without the modules dv, frei0r, gtk2,
    jackrack, qimage, resample, sox, and vorbis. The logfile does contain
    instructions on getting support for these modules, but the above is a
    working baseline. Search for MLTDISABLED in the log file for more
    information. You basically just need to apt-get install some more
    packages to get support from the remaining modules:

    sudo apt-get install sox-dev libjack-dev libsamplerate0-dev
    libgtk2.0-dev libdv4-dev libvorbis-dev

    Note, that there still may be problems with sox support - but it may
    work for you. Depends, I guess.

    To enable fri0r modules, visit http://www.piksel.org/frei0r

    Mandriva

    For Mandriva, you need to urpmi the following packages:

    subversion cmake task-c-devel task-c++-devel qt4-devel libSDL-devel
    kdelibs4-devel gettext sox-devel libdv-dev jack-devel ladspa-devel

    You also need to install and use the Kommander for KDE 3 version when
    running this script.

    Suse

    Please consult the fine howto at http://forums.opensuse.org/how-faq-read-only/unreviewed-how-faq/400196-kdenlive7-svn-howto-opensuse-11-0-a.html#post1898583

    If not using the howto: OpenSUSE does at least a couple of things
    weirdly, which results in the wizard complaining about missing
    libmad-devel packages, when in fact they are there, and also thinking
    libkde4-devel is present when in fact it is not.

    Various

    There has been some complaints that ark for KDE4 has a hard time extracting the bz2 files, when they are not 'tarred'. If you have problems, try

    Quote:
    bzip2 -d 85826-kdenlive_builder_wizard.kmdr.bz2


    in a konsole after download, then run it (using kmdr-executor).




    Changelog:

    0.9.90
    - Support getting MLT from new git repository
    - Support automatic checking for new wizard version at startup

    0.9.10:
    - Fix: ffmpeg now needs --enable-nonfree for AAC support (Thanks Dan
    Dennedy)
    - Pass PKG_CONFIG_PATH to kdenlive check wizard, allowing it to pick
    correct version of frei0r for tests
    - Clean "more" in ffmpeg (distclean instead of clean) to resolve some
    rare compilation problems.

    0.9.9:
    - Honor users LANG setting from kdenlive_start
    - If present, cat /etc/lsb-release from kdenlive_start
    - Add MANPATH variable to kdenlive_env
    - Add MLT_* stuff to kdenlive_start log
    - Add kbw config file settings to kdenlive_start log
    - Allow mmx for mlt with x86-64
    - Support Frei0r through the wizard.
    - Support H.264 for ffmpeg
    - Pass additional options to ffmpeg

    0.7.3:
    - Fix: ffmpeg removed the --enable-swscale option
    - Improve information about wizard version check

    0.7.2:
    - Move to trunk from KDE4 branch

    0.7.1:
    - Fix failing MLTDISABLED check => weird message when *all* OK
    - Don't check MLTDISABLED for sox, if disabled in config.
    - Fix some spelling errors in GUI (Thanks, Cinephiliac).
    - Spelling errors fix from Dan Dennedy: ACC -> AAC
    - Use LANG=C for all external commands (especially svn).
    - Change hint about ogg-theora option: just for encoding.
    - Change gtk2 and fre0r mlt module description slightly
    - For kdesu hint, also add kdesudo
    - Fix issue with MLT environment and changed install path/append
    date installs, without a download/clean step. Set MLT envs
    explicitly and allow for already set LD_LIBRARY_PATH.
    (Thanks Dan Dennedy).
    - Kdenlive now uses recordmydesktop for screengrabs

    0.7.0:
    - CFLAGS=CFLAGS in log
    - Do not try to create a startup script, when only downloading
    - kdenlive_start, add --gdb/-g option and --normal/-n option
    - Do cpu detection with less overhead (from Morten Bøgeskov)
    - Pipe output from kill commands into /dev/null
    - Post install check for qimage link against qt3.
    - Show warning about non-compiled mlt modules.
    - Require qimage to work.
    - Add reference to mail adress upon fail
    - drop support for building Kdenlive for KDE 3
    - add kconfig_compiler to list of bins to check
    - add pkgconfig check for soprano
    - make the "make clean" step when updating sources optional.
    - Add kbw-action.sh & kdenlive_builder_wizard.kmdr to sources
    - Add README, KDE-APPS.txt and Changelog file to sources
    - Add check that not vfat filesystem for sources
    - Back button, also on cancel/on error.

    0.6.1:
    - Fix some kdesudo not supporting --comment.
    - Pass --enable-libvorbis to ffmpeg configure when theora is selected
    - Enable x11grab by default
    - Output version of KBW to kdenlive_start gdb log

    0.6.0:
    - Important bug fix re MLT install: now supports kdenlive's --mlt-path
    - Added auto-updating of non-newest revision numbers upon succesfull compile
    - Fixed argument passing to kdenlive_start
    - Disable "Advanced" button when only downloading
    - Do not show how to start kdenlive, if only downloading
    - Fix "visit url for update" under KDE4

    0.5.1:
    - Support newest ffmpeg svn option set
    - Fixed aac support
    - Added support for x11grab
    - Added several package checks
    - kdenlive_start script now mandatory

    0.5.0:
    - New image from Cinephiliac
    - Added support for passing qimage dirs to mlt compile
    - Added bt command to gdb in kdenlive_start before thread apply

    0.4.1:
    - use kdesu if kdesudo not available
    - no longer requires tempfile, uses mktemp instead
    - should work with OpenSuse 11 now
    - various minor bugfixes

    0.4.0:
    - Can now get specific versions of the sources.
    - Added --version option to kdenlive_start.
    - Added kdenlive_env script.
    - Fixed x86-64 test.
    - Disabled network support on ffmpeg.
    - Added checkboxes for sox and qimage support in mlt.
    - Added button to check source updates.
    - Removed dependency on kate/kwrite.
    - Minor interface changes.

    0.3.1:
    - Support building for KDE4 from KDE4 trunk of kdenlive
    - Check for new version of wizard
    - Abort long running process
    - Improved startup script - option for gdb
    - Check for common mlt problems
    - Lots of minor stuff

    0.1:
    First public version.




    LicenseGPL
    Ark(Kdenlive Builder Wizard)
    Ark(Kdenlive Builder Wizard sources)
    Send to a friend
    Subscribe
    Other  Apps  from madsdyd
    Report inappropriate content



    goto page: prev   1  2  3  4  5  6  7  8 

    -

     interesting

     
     by jouli on: May 13 2010
     
    Score 50%

    Thanks for your service to our Lord in this study.
    My heart was extremely blessed this morning! "A desperate man came away believing." Isn't that where we all are? Or should be? Desperate? And God turns our desperation into joyful faith! Praise God from whom all blessings flow (I'm singing!)!!!!!!!!!!!
    Thanks again


    jouli
    Reply to this

    goto page: prev   1  2  3  4  5  6  7  8 

    Add commentBack






    -
    -
    Do you like or dislike Ubuntu Unity?
     Yes, unity is alien technology!
     It is less confusing than Gnome 3 default, shell.
     Granny thinks it is much more usable than Gnome 2
     Canonical is embarrasing itself with this split project
     Gnome 3 default shell is much better
     I dislike Unity, Gnome 3 default shell is alien technology!
     None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

    resultmore
     
     
     Who we are
    Contact
    More about us
    Frequently Asked Questions
    Register
    Twitter
    Blog
    Explore
    Apps
    Jobs
    Knowledge
    Events
    People
    Updates on identi.ca
    Updates on Twitter
    Facebook App
    Content RSS   
    Events RSS   

    Participate
    Groups
    Forum
    Add App
    Public API
    About KDE-Apps.org
    Legal Notice
    Spreadshirt Shop
    CafePress Shop
    Advertising
    Sponsor us
    Report Abuse
     

    Copyright 2003-2014 KDE-Apps.org Team  
    All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
    All contributors are responsible for the lawfulness of their uploads.
    KDE and K Desktop Environment are trademarks of KDE e.V.