-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (18) .- Knowledge Base  . 

Solar system

   0.4.1  

Plasmoid Script

Score 90%
Solar system
zoom


Minimum required   PyKDE/PyQt
Downloads:  3024
Submitted:  Apr 16 2010
Updated:  Jun 18 2011

Description:

Displays position of planets in Solar system, applet icon credit: NASA/JPL.




Changelog:

0.4.1
- Italian translation added, big thanks to Giuseppe Calà for contribution :)
- Czech and German translations added (spell-checking and corrections appreciated!)

0.4:
- Greek and French i18n translations added, big thanks to Dimitrios Glentadakis
- For Russian translation big thanks goes to Alexander Potashev
- centering of names of planets and the Sun (due to different length in different languages)
- using translation context for the "Sun", now it should be translated correctly ("Fuzzy")
- changes in .po/.pot creation scripts to handle context function i18nc()
- .mo files automatically installed in ~/.kde4/share/locale directory
- removed "Form" from translation files (thanks to Alexander Potashev for suggestion)

0.3:
- i18n support added, big thanks to Edgardo Garcia Hoeffler for the code and Spanish translation :)
- Slovak i18n translation added
- added antialiasing of planet orbits, thanks goes to user nybble41 for suggestion and code :)
- resizing of the plasmoid added. The applet automatically switches to smaller size
planet images when resized below a certain scale

0.2.1:
- minor bugfix in the config dialog - font size fixed

0.2:
- it's now possible to show/hide Pluto (default: hide)
(Thanks to Kirilo for suggestion :)

0.1:
- basic funcionality.
- it is possible to configure:
- color of text information (legend)
- color of planets' orbits
- show/hide orbits (default: show)
- show/hide legend (default: hide)


Installation:

plasmapkg -i solar-system.plasmoid

or if you are upgrading then:

plasmapkg -u solar-system.plasmoid




LicenseGPL
(solar-system.plasmoid)
Send to a friend
Subscribe
Other  Apps  from jramen
Report inappropriate content



goto page: prev   1  2  3 

-

 Realistic orbits based on published planets' AU.

 
 by dotancohen on: Sep 2 2011
 
Score 50%

For more realistic orbits, you could move the Earth code to be the first in the code (it is currently the last) then multiply each other planet's coefficient by it's distance from the Sun in AU:

coef1 = coef3 * 0.4
coef2 = coef3 * 0.7
coef4 = coef3 * 1.5
coef5 = coef3 * 5.2
coef6 = coef3 * 9.5
coef7 = coef3 * 19.6
coef8 = coef3 * 30


Reply to this

-
.

 Error "Script initialization failed"

 
 by heinquoi on: Oct 22 2011
 
Score 50%

hello,

I like this plasmoid. thank for this.

But when I change the version of my Kubuntu with the latest ( kubuntu 11.10 ), I have this message:
Script initialization failed
And when I execute "plasmoidviewer solar-system"

Installing fr translations...
Command: msgfmt -f -o /home/franck12/.kde/share/locale/fr/LC_MESSAGES/solar-system.mo /home/franck12/.kde/share/app
Traceback (most recent call last):
File "/usr/share/kde4/apps/plasma_scriptengine_python/pyappletscript.py", line 75, in init
self.pyapplet.init()
File "/home/franck12/.kde/share/apps/plasma/plasmoids/solar-system/contents/code/main.py", line 442, in init
self.installTranslation(vers, unicode(KGlobal.locale().language()), kdehome)
File "/home/franck12/.kde/share/apps/plasma/plasmoids/solar-system/contents/code/main.py", line 719, in installTr
msg = "Error installing translation: "+out
TypeError: cannot concatenate 'str' and 'tuple' objects

should you help me ? I don't know python.


Reply to this

-
.

 Re: Error "Script initialization failed"

 
 by heinquoi on: Oct 22 2011
 
Score 50%

sorry for my English
Would you help me ? I'm a shit in English an d in Python.


Reply to this

-
.

 Re: Re: Error "Script initialization failed"

 
 by heinquoi on: Oct 22 2011
 
Score 50%

It good. I found the problem. 'gettext' was installed but not 'msgfmt'. I have reinstalled 'gettext' and it's OK.


Reply to this

-
.

 Re: Re: Re: Error "Script initialization failed"

 
 by jramen on: Oct 22 2011
 
Score 50%

Great! ^^

You solved the problem while I was typing my answer. :)


Reply to this

-
.

 Re: Re: Error "Script initialization failed"

 
 by jramen on: Oct 22 2011
 
Score 50%

Hi there, it's not a problem of Python, installation of language translations relies on the "Gettext" system package ("msgfmt" script is part of that).

Please install the "Gettext" package and everything should go fine. :)


Reply to this

-
.

 Re: Re: Re: Error "Script initialization failed"

 
 by heinquoi on: Oct 22 2011
 
Score 50%

thank you for your response. And your application really well. I love it. And to clarify the package gettext was not installed but I had a program installed with the name gettext. There are subtleties that I not yet understand in kubuntu.


Reply to this

-
.

 Installation trouble

 
 by fisasi on: May 14 2012
 
Score 50%

Hi:
First of all, say that the application is fantastic. I have enjoyed it until I actualized my Open Suse KDE from 11 to 12 version. From then I only get
"No se ha podido crear un motor de scripts para el elemento gráfico Sistema solar"
what means some like
It can not generate (create) a script engine for the graphic element Solar system.

What I am doing bad? As I told, I like very much the widget and I like to get it again.
Thank you


Reply to this

-
.

 Re: Installation trouble

 
 by jramen on: May 14 2012
 
Score 50%

Hi there, thank you very much for your kind words. :)

In regard of your problem, I think you have some python packages missing. Please try to install "kdebindings-python" package, it might solve your problem. :)


Reply to this

-
.

 Re: Installation trouble

 
 by jramen on: May 14 2012
 
Score 50%

Sorry, probably in OpenSuse 12.1 these packages are called:

python-kde4
python-kdebase4


Reply to this

-

 Re: Re: Installation trouble

 
 by fisasi on: May 14 2012
 
Score 50%

Thank you very much for your quick answer. I had already installed them. Anyway I have updated them but doesn't work yet. Could be anything else?
Thank you.


Reply to this

-

 Re: Re: Re: Installation trouble

 
 by jramen on: May 14 2012
 
Score 50%

Other than that plasmoid relies on PyQt4, so probably package "python-qt4" is missing. :-S


Reply to this

-

 Re: Re: Re: Re: Installation trouble

 
 by fisasi on: May 14 2012
 
Score 50%

No luck. Python-qt4 already installed and updated but it doesn't want work :-(. Thanks a lot again.


Reply to this

-
.

 Re: Re: Re: Re: Re: Installation trouble

 
 by jramen on: May 14 2012
 
Score 50%

I sent you a private message with some other possibilities.. :)

But we surely will find what's missing, because I'm using OpenSuse 12.1 myself and plasmoid works on my desktop. :)


Reply to this

-

 Re: Re: Re: Re: Re: Installation trouble

 
 by jramen on: May 14 2012
 
Score 50%

And one more thing, I found this at other plasmoid: "Note: If you get missing script-engine errors when loading the widget you need to install the plasma python script-engine (in openSUSE this requires the "python-kdebase4" and "python-devel" packages"

So please check whether python-devel package is installed. :)


Reply to this

-
.

 Re: Re: Re: Re: Re: Re: Installation trouble

 
 by fisasi on: May 15 2012
 
Score 50%

:-) :-) :-)
¡¡¡AT LAST!!!!
It works very well. When I installed python-devel it didn't work. I was writing again to you when I think it could be better to try again after restarting computer. And it works great. Thank you very much for your attention.
Best regards



-
.

 Re: Re: Re: Re: Re: Re: Installation trouble

 
 by jramen on: May 16 2012
 
Score 50%

I can't reply to your post, so I'm replying to mine. :))


GREAT!! I'm very happy that it finally works! ^_^
All the best,
John



-

 Re: Re: Re: Re: Re: Re: Installation trouble

 
 by bkant on: Jul 24 2013
 
Score 50%

I have run this fine plasmoid until today on my Opensuse 12.3 64bit system. Today I updated a bunch of software packages and now the sun refuses to shine for me. The error message is the same as reported before in Spanish, but for me in German: "Der python-Skript-Treiber für Sonnensystem kann nicht initialisiert werden." I have checked all the packages that have been mentioned here and they are all installed and updated.
What to do?



-
.

 Re: Re: Re: Re: Re: Re: Installation trouble

 
 by jramen on: Jul 24 2013
 
Score 50%

Sadly, sometimes updates break stuff. :-S
This time I really don't know what's wrong. I currently updated my OpenSuse 12.2 and it's working fine, so probaly guys at OpenSuse did break something for 12.3.

My best bet is for you to wait for the next update, hoping it will fix things, and in the meantime try to run plasmoid from command line with:

# plasmoidviewer solar-system

and hopefully it will report where the crash occurs.
And also, I saw gettext package being updated and it's needed for solar-system plasmoid.
Please try to reinstall and/or downgrade using YAST Installer and Versions tab on selected gettext package.



-

 Re: Re: Re: Re: Re: Re: Installation trouble

 
 by bkant on: Jul 24 2013
 
Score 50%

Thanks for this quick reply! Plasmoidviewer indeed is telling me some more details (not that I would understand anything of it):

plasmoidviewer(27916)/python (plugin): Failed to import module
Traceback (most recent call last):
File "/usr/share/kde4/apps/plasma_scriptengine_python/pyappletscript.py", line 22, in <module>
from PyKDE4.plasma import Plasma
RuntimeError: the sip module implements API v10.0 but the PyKDE4.plasma module requires API v9.2

At least that sounds to me that the system updates have lifted some files to a new API level which other files aren't capable to deal with, and it doesn't sound like related to gettext. Google shows the exact same runtime error message two times connected to other distros and other software, so apparently this is not a sole problem of Solar system, so to say, more like a Milky Way malady ...

I guess I just have to wait and see. The planets are not going to leave the system by then ...



-

 [SOLVED] Re: Installation trouble

 
 by bkant on: Jul 25 2013
 
Score 50%

I managed to get it up and running again. I downgraded the package python-sip from 4.14.7xxx to the last available version of 4.14.6xxx. While doing that some dependencies asked to downgrade other packages which I confirmed. After a reboot Solar system is working again.



-
.

 Re: Re: Re: Re: Re: Re: Installation trouble

 
 by jramen on: Jul 25 2013
 
Score 50%

Thanks for the update! Or should I say, downgrade? ;)) Well, it's strange though, cuz I'm not aware I had used any heavily API dependent stuff. But nowadays APIs change without further notice and what worked in old, doesn't need to do so in new one. :-/

And... thanx for using the plasmoid even as it means having da oldie kwappy API. ;)



-

 feature question

 
 by trinnyg on: Nov 7 2013
 
Score 50%

where is the information taken from?
how hard would it be to add the picture type like the following URL ??

http://www.theplanetstoday.com/
Containing also the astrology sign that the planets are in??


Reply to this

goto page: prev   1  2  3 

Add commentBack






-
-
Do you like or dislike Ubuntu Unity?
 Yes, unity is alien technology!
 It is less confusing than Gnome 3 default, shell.
 Granny thinks it is much more usable than Gnome 2
 Canonical is embarrasing itself with this split project
 Gnome 3 default shell is much better
 I dislike Unity, Gnome 3 default shell is alien technology!
 None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.