-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans  .- Knowledge Base  . 

goLinuxSMS - goWinSMS

   2.0  

KDE Other Utility

Score 81%
goLinuxSMS - goWinSMS
zoom


goLinuxSMS - goWinSMS
zoom


goLinuxSMS - goWinSMS
zoom


Link:  Link
Minimum required   Qt 3.x
Downloads:  7533
Submitted:  Oct 18 2005
Updated:  Jun 1 2011

Description:

Software based on contact's archive for sending SMS (short message system) versus italian vodafone phones and others (with virgilio/tin ADSL account).
Based on engineSMS, shared library for linux and win, to create own several programs with the most popular languages such as C,C++,php,ASP,python etc...
Contains API for simply requests similar to software's implementation above .




Changelog:

If you are an american or canadian user with a Nokia C7/N8 you can download for free TheCommuter
(http://qt-apps.org/content/show.php/TheCommuter+-+FREE+for+American+N8+%26+C7!?content=139960)

Virgilio ADSL is not supported more.
Vodafone also is not supported.

Using engineSMS.so/dll is possible to create owner SMS sender ADLS based service and than modify your goLinuxSMS/goWinSMS which are open.

New web-site link is added.



License:
software goXxxSMS is under GPL.
library engineSMS is freeware, but closed (without any QT objects).


Source(goSMS-2.0 source)
MS Windows(goWinSMS)
Debian(goLinuxSMS)
Red Hat(goLinuxSMS)
SUSE(goLinuxSMS)
Mandriva(goLinuxSMS)
Gentoo(goLinuxSMS)
Slackware(goLinuxSMS)
Send to a friend
Subscribe
Other  Apps  from AlterX
Report inappropriate content



goto page: prev   1  2 

-
.

 >

 
 by felipe on: Jan 14 2006
 
Score 50%

awful old school gui :-)


--
"just because you're paranoid, doesn't mean they're not after you"

Reply to this

-

 Re: > WHAT??!

 
 by AlterX on: Jan 16 2006
 
Score 50%

What do you saying?!?

P.S. che cosa significa?!? ti stupisce che sono un programmatore della vecchia scuola?!?


Reply to this

-

 Re: Re: > WHAT??!

 
 by ramiel on: Sep 17 2007
 
Score 50%

No,si stupisce che tu abbia fatto un'interfaccia grafica vecchia maniera e la ritiene orribile...ma i tuoi gusti sono i tuoi,fai quello che credo anche se mi va di consigliarti di usare le librerie qt4


Reply to this

-
.

 Compilation

 
 by kreen on: Jan 30 2006
 
Score 50%

Hi,
I can't build the program with kdevelop because a lack of headers...
OneShot.h and QTimerThread.h

Ciao.

Igor


Reply to this

-

 Re: Compilation

 
 by AlterX on: Jan 31 2006
 
Score 50%

Please contact through email

Ciao


Reply to this

-
.

 license

 
 by soulrebel on: Mar 28 2006
 
Score 50%

just out of curiosity:
you know that the gpl does not allow bundling with gpl-incompatible libraries?
even if you dont mingle the code, you must not link with non-gpl libraries if they arent system libraries (i.e. you may link against a closed source c-library but not against a module or other library). it explicitly states that anything you distribute with the free program must also be free.
QUOTE:
For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable.
However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.


so please release the source for the smslibrary or chose a different license.


# cd /usa/whitehouse
# rm -rf *

Reply to this

-

 Re: license

 
 by soulrebel on: Mar 29 2006
 
Score 50%

i have just seen that you already talked about this.
the previous poster is wrong though:
your library does definitely not fall under the "system-library-exception".
you would have to add a special extension to your license code, as described on the faq.
then again because the resulting license is less free than the regular gpl, this will render it incompatible with other gpl-code!
since it is incompatible with the gpl it cannot be used with qt.

but since you are the author, why dont you just opensource it?


# cd /usa/whitehouse
# rm -rf *

Reply to this

-
.

 LICENSE AGAIN

 
 by soulrebel on: Sep 14 2006
 
Score 50%

you seem to just don't care. in this case you and every user of your software is knowingly infringing the GNU GPL.

i will report this.


# cd /usa/whitehouse
# rm -rf *

Reply to this

-

 Re: LICENSE AGAIN

 
 by AlterX on: Sep 21 2006
 
Score 50%

I have gentoo linux with kde (QT library) on my laptop and for my nvidia graohic device I use a nvidia driver which is closed. So is KDE and nvidia closed driver incompatible?!?!
I don't think...


Reply to this

-

 Re: Re: LICENSE AGAIN

 
 by soulrebel on: Sep 21 2006
 
Score 50%

kde and the nvidia driver are not linked together your program is.

read the gpl, man!

you cannot link with not-gpl-compatible code! it is as easy as that.

if you dont know than dont use the gpl.


# cd /usa/whitehouse
# rm -rf *

Reply to this

-

 Re: Re: Re: LICENSE

 
 by AlterX on: Sep 22 2006
 
Score 50%

Uhm....are you sure!?
And than libGL.so (closed nvidia) how is used within Xorg and kde?!?
Than if it is so, I just convert linked library with dinamically linked?!?


Reply to this

-

 Re: Re: Re: LICENSE

 
 by AlterX on: Sep 22 2006
 
Score 50%

QT (or gnome) and nvidia closed driver are linked togheter...
Please see nvidia-settings tools (which is in QT or gnome), that use libGL.so (closed library)!


Reply to this

-

 Re: Re: Re: LICENSE AGAIN

 
 by soulrebel on: Sep 22 2006
 
Score 50%

nvidia-settings doesnt link with libGL.so, the xserver does, thats right, but the xserver is not licensed under the GPL, it is licensed under the X11-license which is not copyleft. also note that you can buy not-gpl-licenses of qt that allow non-free-linking or complete unfree works (like google-earth, the opera-browser a.s.o.)

i am absolutely 100% sure that you may never distribute a GPLed work that links (dynamically or statically) to gpl-incomptible libraries.

when two works are linked together they form one derived work. the terms of the gpl clearly state that derived works must be 100% gpl-compatible.

but really, why dont you just opensource it, if your are the copyright holder?


# cd /usa/whitehouse
# rm -rf *

Reply to this

-

 Re: Re: Re: Re: LICENSE AGAIN

 
 by AlterX on: Sep 23 2006
 
Score 50%

I think that i'll do it...little time to review code and than I release source code for gpl compatibility.
Bye


Reply to this

-
.

 What's new here?

 
 by bitcrazy on: Jun 5 2011
 
Score 50%

This app is ages old, as everybody can see and still uses QT3. So what is the point? No changes in licensing and old version of toolkit. QT4 version and source of the library, that would be news.

m0nk


If men could get pregnant, abortion would be a sacrament.
Reply to this

goto page: prev   1  2 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.