-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (6) .- Knowledge Base  . 

Kwave

   0.9.0  

KDE Sound Application

Score 84%
Kwave
zoom


Kwave
zoom


Kwave
zoom


Homepage:  http://kwave.sf.net
Minimum required   KDE 4.x
Downloads:  8189
Submitted:  Apr 4 2004
Updated:  May 25 2015

Description:

Kwave is a sound editor designed for the KDE Desktop Environment.

With Kwave you can edit many sorts of audio files including multi-channel files. Kwave also includes many plugins to transform the audio data in several ways and presents a graphical view with a complete zoom- and scroll capability.
Supports many sound formats, playback and recording via ALSA and OSS.




Changelog:

0.9.0 [2015-05-25]

* first version hosted on KDE (kdereview) and SourceForge
* added command line parameter for selecting the GUI type
* in MDI mode: new menu entry + function to arrange sub windows vertically
* handbook: added text command reference
* handbook: added plugin reference
* enabled the "Help" buttons of all plugins and let them open the corresponding
section in the handbook
* make system: new target "update-handbook" (updates command, file info
and plugin cross references)
* make system: fixed dependency problem in translation
* new commands: "window:sendkey", "window:screenshot", "window:close"
and "window:resize"
* built-in variable ${LANG} for kwave commands
* support for delayed command execution
* debug plugin: always compiled in, but only visible in debug build
* new command sync(): wait for commands scheduled with delayed
* bugfix: exporting a mono file as MP3 produced a stereo MP3 file
* MP3: emphasis, copyrighted, original got lost during save/load
* file info dialog: MPEG settings were not handled properly
* bugfix: assert/numeric overflow in selectnextlabels() at end of file
* new plugin: stringenter
* bugfix: minimized windows were not migrated properly when switching GUI type
* new command: window:minimize
* bugfix: missing range check in noise generator (when used per script)
* bugfix: saveblocks plugin did not work when omitting file extension
* saveblocks plugin: use escaped strings for storing settings instead of base64




LicenseGPL
Source(Source tar.bz2)
Gentoo(Ebuild for Gentoo Linux)
(Download Page)
openSUSE Tumbleweed
openSUSE 13.2
openSUSE Factory ARM
Fedora 21 (i686)
Fedora 21 (noarch)
Fedora 21 (noarch)
Fedora 21 (x86_64)
Fedora 21 (i686)
Fedora 21 (x86_64)
ScientificLinux 7 (noarch)
ScientificLinux 7 (noarch)
ScientificLinux 7 (x86_64)
ScientificLinux 7 (x86_64)
RedHat RHEL-7 (noarch)
RedHat RHEL-7 (noarch)
RedHat RHEL-7 (x86_64)
RedHat RHEL-7 (x86_64)
CentOS CentOS-7 (x86_64)
CentOS CentOS-7 (x86_64)
CentOS CentOS-7 (noarch)
CentOS CentOS-7 (noarch)
Send to a friend
Subscribe
Other  Apps  from dg6nee
Report inappropriate content



goto page: prev   1  2  3  4 

-

 Good Work!

 
 by bas89 on: Jun 22 2011
 
Score 50%

This app is just so great that it should belong to KDE! :)


Reply to this

-

 Re: Good Work!

 
 by acidrums4 on: Nov 27 2011
 
Score 50%

I agree, but the integration with it it's not good... for example, toolbars are not customizable :(


Reply to this

-
.

 Crashes

 
 by rthomsen on: Feb 15 2012
 
Score 50%

The app crashes no matter what I try to do...


Reply to this

-
.

 New MP3 export function

 
 by rthomsen on: Nov 9 2012
 
Score 50%

Thanks for creating this great app and good to finally have the MP3 export functionality.

I can't figure out how to specify options for lame though. In the MP3 encoder settings dialog, typing "--abr 192" in the bitrate avg field seems to have no effect. I still get MP3s at 32 kbps.


Reply to this

-

 Cannot build

 
 by dovidhalevi on: Jan 4 2015
 
Score 50%

Looking for xml2pot
Don't smoke


Reply to this

-

 Re: Cannot build

 
 by dg6nee on: Jan 4 2015
 
Score 50%

I would like to help you, but without knowing some circumstances this is quite hard. In most cases the package you need for poxml tools is named kde4-l10n-devel or similar.

Which distribution do you use?


Reply to this

-

 Re: Re: Cannot build

 
 by dovidhalevi on: Jan 4 2015
 
Score 50%

Those kde-110n packages are all localizations for specific languages. No -dev on Debian, probably part of another kde...-dev.

The cmake was, in fact, checking for the correct package poxml. The error text should have said so. I found the needed rsvg stuff and am compiling right now. If it had only mentioned "convert" (ImageMagik), would not have found the rsvg package so quickly.


Reply to this

-

 Re: Re: Re: Cannot build

 
 by dg6nee on: Jan 4 2015
 
Score 50%

ok, that means you are building for Debian. Did you then read the corresponding section in the manual? Or did you have difficulties with these instructions: http://kwave.sourceforge.net/doc/en/building_deb_from_src.html ? (normally "apt-get build-dep kwave" should be able to install all necessary packages for you.


Reply to this

-

 Re: Re: Re: Re: Cannot build

 
 by dovidhalevi on: Jan 4 2015
 
Score 50%

Ok. But, if cmake does not find a specific package, flag that package. Maybe the problem is in cmake.


Reply to this

-

 Re: Re: Re: Re: Cannot build

 
 by dovidhalevi on: Jan 4 2015
 
Score 50%

and ... it missed one :-)

In file included from /home/david/kwave-0.8.99/plugins/codec_flac/FlacCodecPlugin.cpp:25:0:
/home/david/kwave-0.8.99/plugins/codec_flac/FlacEncoder.h:27:28: fatal error: FLAC++/encoder.h: No such file or directory
#include <FLAC++/encoder.h>


Reply to this

-
.

 Re: Re: Re: Re: Re: Cannot build

 
 by dg6nee on: Jan 4 2015
 
Score 50%

once again:

=> did you read http://kwave.sourceforge.net/doc/en/building_deb_from_src.html ?

=> did you do call "apt-get build-dep kwave" ?


Reply to this

-
.

 May we have a .deb package?

 
 by EdenMar on: Jun 11 2015
 
Score 50%

I notice a Debian package for 0.9.0, the latest version, is missing from the list. I'm running Linux Mint Qiana. Much appreciated if it could be added ...


Reply to this

goto page: prev   1  2  3  4 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2015 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.