-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (1) .- Knowledge Base  . 

Ruber

   0.0.10  

KDE Development Environment

Score 56%
Ruber
zoom


Ruber
zoom


Ruber
zoom


Link:  Link
Version Control:  Link
Issue Tacker:  Link
Minimum required   KDE 4.x
Downloads:  107
Submitted:  Oct 30 2010
Updated:  Oct 21 2011

Description:

Ruber is an IDE for the Ruby programming language written in Ruby itself and using the KDE 4 ruby bindings.

It is plugin-based, so users can extend it adding the functionality they like. Being written in ruby, plugins are very easy to create.

Installation instructions

  • Install ruby (http://www.ruby-lang.com). Ruber works with both ruby 1.8.7 and ruby 1.9.x

  • Install rubygems (note that ruby 1.9 already includes it)

  • Install the kde ruby bindings (korundum) version 4.5.2 or greater

  • as superuser, issue the command `gem install ruber` to download Ruber directly from rubygems.org or `gem install ruber-0.0.x.gem` if you downloaded it from here (note that gem will need to download other dependencies from the net)



  • Changelog:

    Ruber 0.0.10

    Features

  • Added a RI plugin. You can now insert the class or method name in the RI tool widget
    and see the documentation in a nice HTML format inside the tool widget itself.
    This plugin requires RDoc version 3.x (it isn't tested with version 2.x)

  • Added an IRB plugin

  • The syntax checker plugin has been rewritten. Now other plugins can check the
    syntax of a document

  • Ruby and YAML syntax checker now are in their own plugin, rather than being part
    of the syntax checker plugin

  • The auto end plugin doesn't use indentation anymore to decide whether the end keyword
    should be inserted or not. Instead, it performs a syntax check and only inserts
    end if ruby reports a missing end keyword. This should improve the accuracy of
    the plugin

  • The Auto End plugin now inserts the end keyword after a case expression

  • Clicking on a file name in an output widget with the middle mouse button now
    prevents the tool widget from being hidden, as if the pin button were clicked

  • Changed the interface to specify patterns in the RSpec plugin

  • The RSpec plugin now supports specs inside subdirectories. You can also specify
    subdirectories inside the pattern to match code file and the respective spec
    file

  • When choosing the Run Specs for Current File action in the RSpec plugin, if the current
    document is associated with a code file, all the specs associated with it are
    run (previously, only one of them was run)

  • When choosing the Run Current Spec action in the RSpec plugin, if the current
    document is a code file, the plugin will look at the most recently activated
    editor containing a spec file for the current file to determine which is the
    current spec

  • The behaviour of output widgets when clicking on a file name which requires
    opening a new editor has changed. The choice made by the user to open the editor
    in the current tab by splitting the current editor is ignored if the current
    tab already contains more than one editor. The reason is that usually there
    won't be enough space on the sceen to comfortably accomodate more than two
    editors


  • Bug fixes

  • Do not crash when closing with unsaved files

  • Horizontal scrollbar in the RSpec tool widget will be displayed when the spec
    description is larger than the widget but the rest of the text isn't


  • Ruber 0.0.9

  • It is now possible to have more than one open project at the same time

  • When a project is active, only the editors associated with it are visibile

  • Editors not associated with a project are visible only when there's no active project

  • Made the Auto End plugin recognize some other keywords: unless, for, while,
    until (the last two were already recognized when followed by a do)

  • The RSpec plugin now correctly displays pending examples

  • Fixed a crash when creating a new document and saving it as a ruby file while using the Syntax Checker plugin


  • Ruber 0.0.8
    New features:

  • Added a new plugin: Auto End, which automatically inserts end keywords after
    module, class, if...

  • Added a button to prevent clicking on a file in a tool widget to close it
    while opening the file (replaces the use of the Meta key for the same scope)

  • Allow to open a new editor when clicking on a file name in a tool widget with
    the Meta key pressed

  • Added horizontal scrollbars to the RSpec tool widget

  • Unified Replaced Switch to File and Switch to Spec menu entries in the
    Ruby/Test menu

  • Added an option to have the Switch to Spec menu entry create the editorin
    the current tab (by splitting the current editor), so you can have code and
    spec side by side (mostly useful for people with widescreens)

  • The Command plugin is now able to show output sent to standard output and
    standard error

  • Added menu entries (with the corresponding shortcuts) to move between split
    views in the current pane

  • Disabled autoscrolling in tool widgets if the scroll bar is not at the end

  • Fixed a crash when attempting to customize shortcuts

  • Fixed a crash with nested views

  • Ruber 0.0.7
  • More than one view for each document allowed

  • More than one view in a single tab allowed

  • Close buttons on tabs (optional)

  • Terminal program is now configurable


  • Ruber 0.0.6
  • Allow Ruber to work with remote files

  • Fixed a bug causing a crash from the Choose Plugins dialog in case of an error

  • Fixed a bug causing Ruber to sometimes look for plugins in the directory installation of a previous version

  • Made the rake plugin depend on the autosave plugin


  • Ruber 0.0.5
    Fixed a but causing a crash when opening files

    Ruber 0.0.4
    Fixed another couple of critical bugs

    Ruber 0.0.3
    Skipped for technical reasons

    Ruber 0.0.2
    This releases fixes a single, but extremely important, bug which caused Ruber
    to fail start unless the directory $KDEHOME/share/apps/ruber (which is created
    by Ruber itself) already existed.




    LicenseGPL
    (ruber-0.0.10.gem)
    Send to a friend
    Subscribe
    Other  Apps  from stcrocco
    Report inappropriate content



    -
    .

     kio ?

     
     by mschnide on: Jan 12 2011
     
    Score 50%

    Why is 'kio' needed?
    Debian packages doesn't include this or I've made a mistake to install it.

    Is it possible to run ruber with all features without kio?


    Reply to this

    -

     Re: kio ?

     
     by stcrocco on: Jan 12 2011
     
    Score 50%

    kio is part of the KDE ruby bindings (korundum). I don't know how debian package korundum, but I think that it should contain it. On my system, I have kio.so and kio.rb installed in the same directory as korundum4.so and korundum4.rb, that is, respectively in /usr/lib/ruby/site_ruby/1.9.1/i686-linux/ and /usr/lib/ruby/site_ruby/1.9.1/KDE/.

    As far as why it is needed: it provides several widgets, including the file requester widget. And no, you can't use Ruber without it. Again, I'm fairly sure it should be included in the korundum package.

    Just for information, which is your version of the KDE ruby bindings?


    Reply to this

    -
    .

     Re: Re: kio ?

     
     by mschnide on: Jan 12 2011
     
    Score 50%

    Version: 4:4.4.5-3
    Package: libkde4-ruby1.8

    And following libraries and ruby-files are included:
    /usr/lib/kde4/krubypluginfactory.so
    /usr/lib/ruby/1.8/x86_64-linux/khtml.so
    /usr/lib/ruby/1.8/x86_64-linux/korundum4.so
    /usr/lib/ruby/1.8/x86_64-linux/ktexteditor.so
    /usr/lib/ruby/1.8/x86_64-linux/nepomuk.so
    /usr/lib/ruby/1.8/x86_64-linux/solid.so
    /usr/lib/ruby/1.8/KDE/korundum4.rb
    /usr/lib/ruby/1.8/khtml/khtml.rb
    /usr/lib/ruby/1.8/ktexteditor/ktexteditor.rb
    /usr/lib/ruby/1.8/nepomuk/nepomuk.rb
    /usr/lib/ruby/1.8/solid/solid.rb

    Then I have to create my own debian package ;-)
    if I need the plugins.
    I've commented the line with 'kio' and it works without the plugins.

    Perhaps the packages will be extended after the release of debian 6.0 (squeeze)
    I hope so ...


    Reply to this

    -

     Re: Re: Re: kio ?

     
     by stcrocco on: Jan 12 2011
     
    Score 50%

    I forgot that the KIO library was put in a separate file in KDE 4.5, so if you're using 4.4, you don't need it.

    Since Ruber is also supposed to work with KDE 4.4, I'll fix the issue.

    Thanks for reporting the problem.


    Reply to this

    -
    .

     Re: Re: Re: Re: kio ?

     
     by mschnide on: Jan 12 2011
     
    Score 50%

    Debian packages could be very divided ...

    ... and it is version 4.4, exactly 4.4.5.

    Thanks


    Reply to this

    Add commentBack






    -
    -
    How do you like Plasma 5?
     The best KDE Desktop ever.
     Definitely a nice improvement.
     Not decided yet. Haven't tried it yet.
     I do not like some of the changes.
     KDE is taking the wrong way.
     I am still sticking with KDE 3.5.
     I have no opinion, but wanted to vote anyway.

    resultmore
     
     
     Who we are
    Contact
    More about us
    Frequently Asked Questions
    Register
    Twitter
    Blog
    Explore
    Apps
    Jobs
    Knowledge
    Events
    People
    Updates on identi.ca
    Updates on Twitter
    Facebook App
    Content RSS   
    Events RSS   

    Participate
    Groups
    Forum
    Add App
    Public API
    About KDE-Apps.org
    Legal Notice
    Spreadshirt Shop
    CafePress Shop
    Advertising
    Sponsor us
    Report Abuse
     

    Copyright 2003-2014 KDE-Apps.org Team  
    All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
    All contributors are responsible for the lawfulness of their uploads.
    KDE and K Desktop Environment are trademarks of KDE e.V.