-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (1) .- Knowledge Base  . 

KNDISWrapper

   0.4.0  

KDE System Tool

Score 86%
KNDISWrapper
zoom


KNDISWrapper
zoom


KNDISWrapper
zoom


Link:  Link
Minimum required   KDE 4.x
Downloads:  3569
Submitted:  Aug 10 2008
Updated:  Mar 6 2012

Description:

A GUI for ndiswrapper. Inspired by ndisgtk (thanks for it!)
There are repositories now for Mandriva at http://rpmlinux.org/kndiswrapper
(thanks to mapi)
and rpm packages for SuSE Linux at
http://packman.links2linux.de/package/kndiswrapper
(tanks to Andrea Florio)

I have uploaded a blank language file for 0.3.9.

Regarding 0.4.0 - I myself do not use ndiswrapper anymore though I need some help for testing. If there are some people out there using ndiswrapper - please try out my tool and gimme some feedback. Thanks.




Changelog:

0.4.0 Complete port to KDE/Qt 4.x

0.3.9 Now an installation Wizard was added to the application. This wizard helps you to find the correct inf-file and the associated sys-file. Espacially helpful if you try to find the already installed driver within a windows partition.

0.3.8 I've made a few changes to the dhcp setup script. Thanks to
Troy S. McRoodberg the application now has a russian translation file. I also made the ndiswrapper "cards known to work" wiki available. The application checks now at the installation process if there are enties in the wiki (offline) for the hardware present in the computer (hardware id). So you may get helpfull hints for the installation process (where to get an appropriate driver, did it work on someone else PC and so on ...). You can even browse the wiki-file and search within it. I'll try to update the wikifile frequently.

0.3.7 KNDISWrapper can now speak brasilian. A language file for brasilian was provided by Márcio P. Moraes. Thank you very much.

0.3.6 Did some more tweaks at the wifi setup. By invoking the app with --disablerootcheck you can disable the internal root check. The app still needs root right to run properly. With --disablenetconf you remove the net config button. I was asked by someone to add this feature ....
Now you can also connect to network with encryption set to off (no encryption).

0.3.5 Improvment of the wifi setup. Language files are now included into the source and the rpm package. You can now select the language with the first startup of the app or by invocing the prog with --setup as root.

0.3.4 Language Files for German and Simplified Chinese are availabel. The Language File for Simplified Chinese is a courtesy of Ni Hui. (Thanks)
A Language File for Italian is in the making.

0.3.4 Added language support. A blank language file is provided an I will upload a german translation soon. The language file must be named: kndiswrapper_xx.qm where xx stands for the country code. For example for Italy the filename must be: kndiswrapper_it.qm. The file must be placed at /root/.kndiswrapper/translations. The gui loads the language file depending on the language setting for the desktop.

0.3.3 Added profiles to the network configuration. Now you can save different network configuration for a interface. With a click of the mouse you change the configuration of the network. A feature for user with a notebook who use different configuration at different locations.

0.3.2 Fixing some bugs (dhcp-config) and other minor flaws. I did some testing with a Fritz-Box and a Speedport W700V

0.3.1 Adding a setup feature so you can now setup your wireless network (inc. encryption, dhcp or static ip)

0.2.5 Doing a bit more to help a user to install a driver and checking for problems and fix them.

0.2.0 Just generic support to install windows driver




LicenseGPL
SUSE(KNDISWrapper (SuSE 12.1 RPM))
SUSE(KNDISWrapper (Source))
other(Blank Language File)
Send to a friend
Subscribe
Other  Apps  from wusel1007
Report inappropriate content



goto page: prev   1  2 

-

 nice idea

 
 by shevegen on: Sep 7 2008
 
Score 50%

Very nice. Small, does what it is supposed to do.

I think it belongs in top 20 of KDE apps :D


Reply to this

-

 Failes for me - gcc 4.3

 
 by Hwoarang on: Sep 21 2008
 
Score 50%

The program doesnt compile to me

Seems it is gcc 4.3 problem

What gcc are you using?


--------------------------------
Makefile:863: warning: overriding commands for target `clean-bcheck'
Makefile:826: warning: ignoring old commands for target `clean-bcheck'
Makefile:868: warning: overriding commands for target `bcheck-am'
Makefile:831: warning: ignoring old commands for target `bcheck-am'
make[2]: Nothing to be done for `all-am'.
make[2]: Leaving directory `/var/tmp/portage/kde-misc/kndiswrapper-0.3.4/work/kndiswrapper-0.3.4'
make[1]: Leaving directory `/var/tmp/portage/kde-misc/kndiswrapper-0.3.4/work/kndiswrapper-0.3.4'
------------------------------------
Can you provide a patch? Thanks


Reply to this

-

 Re: Failes for me - gcc 4.3

 
 by wusel1007 on: Sep 22 2008
 
Score 50%

This are just warnings. The application should have compiled and can be installed with make install. I got this warnings as well and the application compiles / runs.
After compilation you can check whether the program compiles by checking the folder kndiswrapper-0.3.4/src/ . Here you should find the binary.
Best regards.
Joerg.


Reply to this

-

 Re: Re: Failes for me - gcc 4.3

 
 by Hwoarang on: Sep 22 2008
 
Score 50%

Yeah, sorry my mistake. Compiles fine. Great application :)


Reply to this

-
.

 one error, one suggestion

 
 by SkyQuakes on: Nov 8 2008
 
Score 50%

Really nice applications, thx.

Just tried to compile 0.3.6. one error about installing translations. In translations/Makefile:

lrelease -compress $$language; line gives en error. I think it must like -uncompress or just lrelease.

Otherwise, the locale files are going under /usr/local/translations where is no application really using. It's better to move them under /usr/share/kndiswrapper/i18n/ or /usr/share/locale

Best Regards...


Reply to this

-

 Re: one error, one suggestion

 
 by wusel1007 on: Nov 8 2008
 
Score 50%

I still use SuSE 10.3 and there you have to use the --compress switch to make it work. But I think there are other distros who use a newer version of lrelease and there the --compress switch cause an error. Don't now how to fix this. Maybe I will change the path for the translation files with the next version. Thanks for your suggestions.


Reply to this

-

 Make error

 
 by YAFU on: Jan 12 2009
 
Score 50%

Hello. I have kubuntu 8.04 and I have had the following error:

Making all in translations
make[2]: se ingresa al directorio `/home/yafulinux/kndiswrapper-0.3.8/translations'
for language in `ls *.ts`; do \
lrelease -compress $language; \
done
Usage:
lrelease [options] project-file
lrelease [options] ts-files [-qm qm-file]
Options:
-help Display this information and exit
-nocompress
Do not compress the .qm files
-verbose
Explain what is being done
-version
Display the version of lrelease and exit
Usage:
lrelease [options] project-file
lrelease [options] ts-files [-qm qm-file]
Options:
-help Display this information and exit
-nocompress
Do not compress the .qm files
-verbose
Explain what is being done
-version
Display the version of lrelease and exit
..................
..................
make[2]: *** [all] Error 1
make[2]: se sale del directorio `/home/yafulinux/kndiswrapper-0.3.8/translations'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/home/yafulinux/kndiswrapper-0.3.8'
make: *** [all] Error 2

I solved it editing the file "Makefile" in the "Translations" folder and replacing "lrelease-language compress $ $ \" with "language lrelease $ $ \", In the same way it had been indicated to the user Thomashausa in:
www.kde-apps.org/content/show.php/netgo_ng?content=88232
Thank you for the app.


Reply to this

-

 Re: Make error

 
 by YAFU on: Jan 12 2009
 
Score 50%

I'm sorry, the Google translator has changed the order of what he had written.
The correct way is:

I solved it editing the file "Makefile" in the "translations" folder and replacing "lrelease -compress $$language; \" with "lrelease $$language; \"


Reply to this

-

 Re: Re: Make error

 
 by wusel1007 on: Jan 13 2009
 
Score 50%

Yes, the problem ist still the same. Some versions of "lrelease" still need the --compress switch and the newer one dont know this switch and produce an error. Hope the app will help you to setup ndiswrapper.
Best regards
Joerg


Reply to this

goto page: prev   1  2 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.