-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans  .- Knowledge Base  . 

kdar

   2.0.7  

KDE Archiving/Backup

Score 75%
kdar
zoom


kdar
zoom


kdar
zoom


Link:  Link
Minimum required   KDE 3.4.x
Downloads:  14026
Submitted:  Jan 25 2004
Updated:  Sep 30 2005

Description:

The "KDE Disk archiver" (KDar) is a disk-based archiving and backup utility.

This is the eighth release in the KDar-2.0 series. KDar-2.0.7 fixes a bug in the command export -A option where archive extensions were not trimmed.

Peter Landgren has provided an update of the Swedish translation which corrects some misspellings.

Enjoy,
JB

If you have problems opening an archive, go to the encryption module of the main configuration dialog and make sure that the encryption type matches the one used to create the archive (i.e. "none", or "blowfish").

Encryption detection will be automated in a future KDar release.

See the Changelog for details.

KDar-2.0.7 requires dar-2.2.x or greater (libdar 3.0.x)(2.2.3 recommended) and at least kde-3.4.x (kde-3.3.x might work).

If you experience problems compiling, please check out the kdar-users mailing list archives first.
(kdar-users@lists.sourceforge.net).

The KDar-2.0.7 source is available at
http://sourceforge.net/projects/kdar

Cheers,
JB

Detailed description:

KDar is built around the "disk archive library" by Denis Corbin, and is analogous to the tape archiver shell command "tar", but is more suited for backups onto disk-based media, such as CD-R, DVD, Jazz, Zip, other hard-drives, etc.

KDar can perform full and differential backups with or without compression. Archives can be split to fit various media types.

A filtering mechanism allows you to select which files and directories to backup or restore, and which files to compress.

See http://kdar.sourceforge.net for screenshots, online documentation, and more info.




Changelog:

KDar-2.0.7:
-Fixed the command export -A option bug (#1293717)
-Swedish translation update (spelling fixes).

KDar-2.0.6:
- Fixed export command bug#1235759 (missing quotes on -c and -R switches)

KDar-2.0.5:
- Fixed bug#1190416, where progress window shows CDR for media type even when splitting archives is turned off.
- Updated Swedish translation courtesy of Peter Landgren.




LicenseGPL
(source)
(KDar FC3 RPM (2.0.4))
(Dar FC3 RPM (2.2.1))
(Dar-devel (2.2.1))
(SUSE 9.3 Package KDar-2.0.6)
Send to a friend
Subscribe
Other  Apps  from jkerrb
Report inappropriate content



goto page: prev   1  2  3  4  5 

-

 Backup Sets

 
 by HabIB on: Jun 9 2004
 
Score 50%

Please add the ability to create and save/load backup sets which can be used for regular backups.

The "Create-Archive-Assistant" is quite good but it's annoying to recreate the backup sets each time I want to do my system backups.


Thanks,
HabIB


Reply to this

-

 Re: Backup Sets

 
 by jkerrb on: Jun 9 2004
 
Score 50%

Indeed, a set of user-defined backup profiles would be helpful. This is planned for a future release. See the TODO.


Reply to this

-

 Re: Backup Sets

 
 by jkerrb on: Jul 14 2004
 
Score 50%

Backup profiles are now a feature of KDar in release 1.2.0-beta1.

This is a beta version, so don't run it as your primary backup utility on production systems. Use KDar-1.1.1, or dar-2.1.3, or something else.

More info at http://kdar.sf.net, and http://sf.net/projects/kdar

Expect to see the official 1.2.0 release within a few weeks.

Cheers,
JB


Reply to this

-

 Re: Re: Backup Sets

 
 by HabIB on: Jul 15 2004
 
Score 50%

Thanks,

that was pretty fast.
I'll have a look at this beta.

Greets,
HabIB


Reply to this

-

 Error in make

 
 by papanero52 on: Jun 20 2004
 
Score 50%

After ./configure launch e make but give this error and stopped:

arcadia1:/local/kdar-1.1.1 # make
cd . && make -f admin/Makefile.common configure.in ;
make[1]: Entering directory `/local/kdar-1.1.1'
make[1]: *** No rule to make target `kdar-1.1.0/configure.in.in', needed by `configure.in'. Stop.
make[1]: Leaving directory `/local/kdar-1.1.1'
make: *** [configure.in] Error 2
arcadia1:/local/kdar-1.1.1 # make compile
cd . && make -f admin/Makefile.common configure.in ;
make[1]: Entering directory `/local/kdar-1.1.1'
make[1]: *** No rule to make target `kdar-1.1.0/configure.in.in', needed by `configure.in'. Stop.
make[1]: Leaving directory `/local/kdar-1.1.1'
make: *** [configure.in] Error 2
whats is a problem?
Thanks


Reply to this

-

 Re: Error in make

 
 by jkerrb on: Jun 20 2004
 
Score 50%

Please send your config.log to jkerrb@users.sourceforge.net

JB


Reply to this

-

 Re: Error in make

 
 by jkerrb on: Jun 20 2004
 
Score 50%

Try running
make -f admin/Makefile.common

then ./configure --enable-mode=64 --enable-largefile --disable-debug

(or user whatever configure arguments you need).

Then
make clean
make

I'll get this autotools system figured out yet... ;)

JB


Reply to this

-

 Re: Error in make

 
 by jkerrb on: Jun 20 2004
 
Score 50%

If the above trick does not work, try downloading kdar-1.1.1.tar.bz2 again. I've updated the source to resolve this compilation problem.


Reply to this

-

 configure error

 
 by chrisjones051073 on: Jul 5 2004
 
Score 50%

I am trying to compile kdar on an FC2 system. I have installed dar-2.1.3 and that seemed to go OK. I then try to configure kdar but all I get is

checking for libdar... configure: error: required library not found. Please install libdar.

I have tried various options, including --with-extra-libs to add explicitly the dir with the dar library, but nothing seems to work. What am I doing wrong ?


Chris J
Reply to this

-

 Re: configure error

 
 by jkerrb on: Jul 6 2004
 
Score 50%

Chris,

Pass the same configuration options to kdar as you did for dar.

In particular, the integer versions must be the same.
The main options to look for are
./configure --enable-mode=64 --enable-largefile --disable-debug

Change the 64 to a 32 if you are using the 32-bit integer version. Leave the --enable-mode out if you're using the infinite integer version.

Check which version you are running with "dar -V".

JB


Reply to this

-

 Re: Re: configure error

 
 by chrisjones051073 on: Jul 8 2004
 
Score 50%

Hi,

Thanks, but it doesn't help. I used the line

./configure --enable-mode=64 --enable-largefile --disable-debug

with both dat and kdar, but I still get the same error

checking for libdar64... configure: error: required library not found. Please install libdar64.

The output from dar -V is


dar version 2.1.3, Copyright (C) 2002-2052 Denis Corbin

Using libdar 2.3 built with compilation time options:
Extended Attributes support: NO
Large files support (> 2GB): YES
ext2fs NODUMP flag support : YES
Special allocation scheme : YES
Integer size used : 64 bits

Jul 8 2004 with GNUC version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)
dar is part of the Disk ARchive suite (Release 2.1.3)
dar comes with ABSOLUTELY NO WARRANTY; for details
type `dar -W'. This is free software, and you are welcome
to redistribute it under certain conditions; type `dar -L | more'
for details.


Reply to this

-

 Re: Re: Re: configure error

 
 by jkerrb on: Jul 13 2004
 
Score 50%

Have a look at your config.log, and search for libdar64. The error messages should indicate why the configure script failed to find the required library.

You can send the config.log to jerrb@sourceforge.net if you want me to have a look at it.

JB


Reply to this

-

 Re: Re: Re: Re: configure error

 
 by jkerrb on: Jul 13 2004
 
Score 50%

Excuse me, send log to
jkerrb@users.sourceforge.net

Cheers,
JB


Reply to this

-

 Re: Re: Re: Re: Re: configure error

 
 by chrisjones051073 on: Jul 15 2004
 
Score 50%

Hi,

Thanks - with you hints I have found the problem. dar was being installed into /usr/local. During the kdar configuration the conftest application for libdar built OK - but when it was run it failed to find libdar. So /usr/local wasn't in the library search path

I've fixed things and now have kdar running fine.

cheers Chris


Reply to this

-

 configure error

 
 by pfdobbs on: Jul 23 2004
 
Score 50%

on redhat 8.0 cant get configure to find ldar:
checking for libdar... configure: error: required library not found. Please install libdar.

kdar-1.1.1
dar-2.1.3

Tried every which way with the options:
--enable-largefile --disable-debug etc.

Dar Looks like this:
---------------
dar version 2.1.3, Copyright (C) 2002-2052 Denis Corbin

Using libdar 2.4 built with compilation time options:
Extended Attributes support: NO
Large files support (> 2GB): YES
ext2fs NODUMP flag support : YES
Special allocation scheme : YES
Integer size used : unlimited


/usr/local/lib looks like this:
--------------------
rwxr-xr-x 1 root root 5550094 Jul 20 20:53 libdar.so.2.0.4
drwxr-xr-x 26 root root 4096 Jul 21 16:31 ..
-rwxr-xr-x 1 root root 5545068 Jul 22 20:28 libdar.so.2.0.3
lrwxrwxrwx 1 root root 15 Jul 22 20:28 libdar.so.2 -> libdar.so.2.0.4
lrwxrwxrwx 1 root root 15 Jul 22 20:28 libdar.so -> libdar.so.2.0.3
-rwxr-xr-x 1 root root 791 Jul 22 20:28 libdar.la
-rw-r--r-- 1 root root 9628778 Jul 22 20:28 libdar.a

config.log looks like this:
--------------------
configure:28458: checking for libdar
configure:28486: g++ -o conftest -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -DNDEBUG -DNO_DEBUG -O2 -fno-exceptions -fno-check-new -fexceptions -fexceptions -DQT_THREAD_SUPPORT -D_REENTRANT -ldar conftest.cc >&5
configure:28489: $? = 0
configure:28491: ./conftest
./conftest: error while loading shared libraries: libdar.so.2: cannot open shared object file: No such file or directory
configure:28494: $? = 127
configure: program exited with status 127

make -f admin/Makefile.common cvs
looks like this:
--------------------
*** Creating acinclude.m4
*** Creating list of subdirectories
*** Creating configure.in
*** Creating aclocal.m4
*** Creating configure
configure.in:44: warning: do not use m4_patsubst: use patsubst or m4_bpatsubst
configure.in:141: warning: do not use m4_regexp: use regexp or m4_bregexp
*** Creating config.h template
autoheader-2.53: `config.h.in' is unchanged
*** Creating Makefile templates
src/Makefile.am:16: invalid unused variable name: `libkdar_la_LIBADD'
src/Makefile.am:17: invalid unused variable name: `libkdar_la_LDFLAGS'
make: *** [cvs] Error 1


Regards,
Peter.

Reply to this

-

 Re: configure error

 
 by jkerrb on: Jul 23 2004
 
Score 50%

All I can think is that you haven't run ldconfig as root, or "/usr/local/lib" is not in your ld.conf. Otherwise you'll have to track down some help (Google, the mailing list).

Sorry I can't be of more help.
JB


Reply to this

-

 Re: configure error

 
 by jkerrb on: Jul 23 2004
 
Score 50%

I just noticed that you're running libdar 2.4. My version of dar shows libdar 2.3:

dar version 2.1.3, Copyright (C) 2002-2052 Denis Corbin

Using libdar 2.3 built with compilation time options:
Extended Attributes support: NO
Large files support (> 2GB): YES
ext2fs NODUMP flag support : YES
Special allocation scheme : YES
Integer size used : 64 bits

Get libdar version 2.3.

JB


Reply to this

-

 Re: configure error

 
 by pfdobbs on: Jul 25 2004
 
Score 50%

ok, ldconfig was the answer. Thanks!


Reply to this

-
.

 make error

 
 by TMG on: Jul 26 2004
 
Score 50%

I got the following error when I tried to compile 1.2.0beta3 :

kdarConfigureDlg.cpp: In constructor `
kdarConfigureDlg::kdarConfigureDlg(QWidget*, const char*, bool, unsigned
int)':
kdarConfigureDlg.cpp:80: error: `spacer62' undeclared (first use this function)

I am using KDE CVS > 3.3 Beta 2.
I also got a similar error for 1.1.0.

Please help me to solve this problem!


Reply to this

-

 KDar-1.2.0-beta4 out

 
 by jkerrb on: Aug 2 2004
 
Score 50%

KDar-1.2.0-beta4 is out at sourceforge:
http://sf.net/projects/kdar

DO NOT USE THIS RELEASE FOR PRODUCTION-SYSTEM BACKUPS.

It is still beta software. Instead,
use kdar-1.1.1 or dar-2.1.4 for backups.

Includes many bugfixes from beta3, and
many new features, including a progress
bar for archive creation.

Please report bugs to the sourceforge bugtracker.

Enjoy,
JB


Reply to this

goto page: prev   1  2  3  4  5 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.