-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (1) .- Knowledge Base  . 

Babeleo translator

   0.5.2  

Plasmoid Binary

Score 79%
Babeleo translator
zoom


Babeleo translator
zoom


Babeleo translator
zoom


Minimum required   KDE 4.x
Downloads:  1093
Submitted:  Aug 18 2009
Updated:  May 7 2013

Description:

A fast translator and web query plasmoid for KDE

Features:

- translates the clipboard contents or submits it to a search engine of your choice simply by clicking on the icon or pressing the keyboard shortcut. The corresponding page gets opened in the standard web-browser. The query can also be entered manually in a text field instead of using the clipboard.

- many search engines preconfigured: leo.org, pons.de, google, wikipedia, duden.de, open dictionary, etc... The plasmoid can be used for many other things than just translations.

- new search engines can easily be added.

- fast switching between different translation languages or search engines.


Requirements:

KDE4 >= 4.2

installation from source

You will need the utility cmake and some development packages. To install them:

Ubuntu: sudo apt-get install cmake kdebase-workspace-dev kdelibs5-dev

SUSE: sudo zypper install cmake libkde4-devel kdebase4-workspace-devel

To install the plasmoid, unpack the archive, go to it's main directory and execute this commands:

mkdir build
cd build
cmake ../ -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
make
sudo make install
kbuildsycoca4

After that, the plasmoid should show up in the add widgets dialog.

If not, you can try to execute:

killall plasma-desktop && plasma-desktop

optional: import GPG-Key:

for those who download Babeleo through the Ubuntu PPA (see download links below), the GPG key of the PPA can be imported this way:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 7AB1A390

notes

The fish icons are modified versions of an icon in the Crystal Clear icon set by Everaldo Coelho. File Crystal_Clear_app_babelfish_vector.svg (LGPL)

Comments are always appreciated, positive or negative!

If you don't like the app, feel free to tell me why, so that I can maybe improve it.

Thanks for voting! :)

todo

- more sorting possibilities for the search engines.
- easy-to-use install script.
- more default search engines.
- add offline dictionaries, for example integration of ding (http://www-user.tu-chemnitz.de/~fri/ding/)




Changelog:

if you update Babeleo from a version older than 0.4, please remove the plasmoid from the panel and add it again before use.

update 06.05.2013: New packages for Ubuntu 12.10 (Quantal Quetzal) and 13.04 (Raring Ringtail)
update 01.05.2013: New package for Ubuntu 12.04 (Precise Pangolin)

0.5.2 (13.10.2011)
- new AUTHORS file and updated credits
- new packages for SUSE and Ubuntu

0.5.1 (30.09.2009)
- global shortcut for triggering a query works again
- added a possibility for a global shortcut to open the manual query dialog
- added some more search engines to the default list

0.5 (10.09.2009)
- automatic download of icons for the search engines. Babeleo fetches the favicon from the web page of the engine.

0.4.2 (31.08.2009)
- fixed bug which caused plasma to crash

0.4.1 (31.08.2009)
- alphabetical sorting of search engines in the menus.
- added a few more search engines to the default list.
- some of the search engines are now hidden by default.
- source code cosmetics.

0.4 (30.08.2009)
- added a cool new configuration interface fo search engines:
- possibility to add, remove and edit search engines.
- possibility to hide some of the configured search engines.
- possibility to define for each search engine if it should appear in the main context menu or in the "other engines" menu.
- changed plasmoid name as displayed in the "add widgets..." dialog to "Babeleo translator" for easier finding after installation.

0.3.2 (25.08.2009)
- Babeleo now doesn't use the global clipboard content anymore, but the
currently highlighted text. There is no need to type Ctrl+C anymore,
regardless of the klipper-settings.

0.3.1 (24.08.2009)
- removed a bug which could cause plasma to crash directly after a fresh install or an update from an older version of Babeleo.

0.3 (22.08.2009):
- code restructured to easily add more search engines.
- added a few engines to show what's possible. I will add a configuration window to manage the engines in a later version. For now, new engines can be added easily by those who want by editing the sources (babeleo.cpp, after line 137).
- Tooltip shows the current engine.

0.2.1 (20.08.2009):
- improved the behaviour of the text field for manual entry of the query when it gets opened and when it loses focus.
- cleaned up the code.

0.2 (20.08.2009):
- added the possibility to enter a query manually in a small textfield, instead of taking it from the clipboard.

0.1 (18.08.2009):
- initial release.




LicenseGPL
Source(babeleo-0.5.2.tar.gz)
Ubuntu(Packages on Ubuntu PPA)
SUSE(RPMs & 1-Click-Install for SUSE)
Send to a friend
Subscribe
Other  Apps  from bongoMan
Report inappropriate content



goto page: prev   1  2  3 

-
.

 error while installing

 
 by Herz-von-Hessen on: Sep 11 2009
 
Score 50%

Deutsche Version
Hallo,
Ich glaube ich bin zu neu unter Linux um diese Software zu installieren.
Wenn ich die Installation starte dann erhalte ich eine Fehlermeldung:
----------------------------------------
joerg@suse:~/Download/babeleo-0.5> cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
-- The CXX compiler identification is unknown
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:84 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/joerg/.kde4/share/apps;/usr/share/kde4/apps;/etc/kde4/share/apps
----------------------------------------
Ich bin aber ganz sicher das ich sowohl cmake und auch gcc installiert habe. In YAST kann ich kein Programm mit dem Namen cxx-compiler finden?!

english Version
Hello,
i think i was to fresh on Linux to install this Software.
When i do the Installing i become an error:
----------------------------------------
joerg@suse:~/Download/babeleo-0.5> cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
-- The CXX compiler identification is unknown
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:84 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/joerg/.kde4/share/apps;/usr/share/kde4/apps;/etc/kde4/share/apps
----------------------------------------
I was shure that i have installes cmake and also gcc. In YAST i cannot found any Programfile named cxx-compiler?!
greetings from Darmstadt


Reply to this

-

 Re: error while installing

 
 by bongoMan on: Sep 11 2009
 
Score 50%

Hi,

I think you are missing the package libkde4-devel (that's for SuSE, in Kubuntu it would be kdelibs5-dev).

Install it with Yast or with the command:

sudo zypper install libkde4-devel.


Reply to this

-

 Re: error while installing

 
 by bongoMan on: Sep 11 2009
 
Score 50%

you may need the package kdebase4-workspace-devel too...

sudo zypper install kdebase4-workspace-devel


Reply to this

-

 Re: error while installing

 
 by bongoMan on: Sep 12 2009
 
Score 50%

I saw that SuSE 11.1 still ships KDE 4.1.3 as standard KDE-version, but Babeleo needs at least KDE 4.2 to compile correctly There have been lots of changes in the Qt API between KDE 4.1 and KDE 4.2.

If you want to use Babeleo with SuSE 11.1, you will have to update the KDE before. I don't know how difficult it is with SuSE...


Reply to this

-

 Re: error while installing

 
 by bongoMan on: Sep 12 2009
 
Score 50%

I continue my monologue ;)

I just installed KDE 4.3 on SuSE 11.1, following this howto without problems:

[ur]http://en.opensuse.org/KDE/Upgrade[/url]

The installation of Babeleo then worked flawlessly. And KDE 4.3 is much cooler than KDE 4.1 ;)

cheers
Pascal


Reply to this

-

 Re: error while installing

 
 by bongoMan on: Sep 15 2009
 
Score 50%

I just published RPMs for Babeleo, this should make the installation on SuSE much easier.

cheers
Pascal


Reply to this

-

 RPMs for SuSE

 
 by bongoMan on: Sep 15 2009
 
Score 50%

I just added 2 RPMs for SUSE Linux, made with SUSEs build service. I did not test the 64-bit RPM, but it should be ok. Please give me feedback if you encounter any problems with the RPMs.

The RPMs are built against the openSUSE Factory repository, so they are only guaranteed to work with KDE >= 4.3.

cheers
Pascal


Reply to this

-

 Great!

 
 by raoul on: Sep 21 2009
 
Score 50%

Yeah, exactly what I needed for my work! Thanks a lot dude!


Reply to this

-

 shortcut for manual query

 
 by raoul on: Sep 25 2009
 
Score 50%

just a suggest: a shortcut for manual query would be Kool. Thank ya!


Reply to this

-

 Re: shortcut for manual query

 
 by bongoMan on: Sep 28 2009
 
Score 50%

I'll look for this, thank you for the proposal!

cheers
Pascal


Reply to this

-

 Re: Re: shortcut for manual query

 
 by bongoMan on: Sep 30 2009
 
Score 50%

done :)


Reply to this

-
.

 Lucid

 
 by MonikaK on: Jun 20 2010
 
Score 50%

Are you going to add it to the Lucid ppa? It was still working after the upgrade to Lucid, but I had to re-install and now I desperately miss my LEO plasmoid. :'(


Reply to this

-
.

 Re: Lucid

 
 by MonikaK on: Jun 20 2010
 
Score 50%

From source didn't work either:

monika@lola:~/downloads/babeleo-0.5.1/build$ cmake ../ -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/monika/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde
Call Stack (most recent call first):
CMakeLists.txt:1 (find_package)


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.8)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!


Reply to this

-
.

 You use the icon from someone

 
 by bulldog98 on: Jun 23 2010
 
Score 50%

You use the icon without giving credit to the artist and mentioning it


„If you want to stop smoking, stop with windows in the same time, it can help you.“

-- tipped with http://neo-layout.org

Reply to this

-

 Re: You use the icon from someone

 
 by bongoMan on: Oct 4 2011
 
Score 50%

Oh I'm really sorry that I didn't notice this message before and didn't answer more early... And that I didn't give the credits to the artist... Never meant to offend the GPL! The original file comes from the Crystal Clear icon set by Everaldo Coelho.
It's released under the LGPL. Sorry that I didn't mention it...

I will put a notice into the description text on this page and will include the credits into the next build.

Thank you for pointing it out!


Reply to this

-

 Re: You use the icon from someone

 
 by bongoMan on: Oct 4 2011
 
Score 50%

Oh I'm really sorry that I didn't notice this message before and didn't answer more early... And that I didn't give the credits to the artist... Never meant to offend the GPL! The original file comes from the Crystal Clear icon set by Everaldo Coelho.
It's released under the LGPL. Sorry that I didn't mention it...

I will put a notice into the description text on this page and will include the credits into the next build.

Thank you for pointing it out!


Reply to this

goto page: prev   1  2  3 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.