-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (5) .- Knowledge Base  . 

Analog Meter

   0.7  

Plasmoid Script

Score 86%
Analog Meter
zoom


Minimum required   KDE 4.x
Downloads:  2214
Submitted:  Sep 8 2009
Updated:  Jan 13 2012

Description:

Displays various data sources in analog meter

Please send longer messages like patches, bug reports with outputs, etc. to my email.

Plasmoid depends on: plasma-scriptengine-python
Contact: http://bit.ly/damu-email
Browse Source: http://www.gitorious.org/pdamsten/plasmoids/trees/master
Installing: http://userbase.kde.org/Plasma/Installing_Plasmoids




Changelog:

2012-01-13 Version 0.7
* Remove support for KDE 4.3 and lower
* In KDE 4.8 we can\'t have config.ui if want showConfigurationInterface to be called.

2009-10-08 Version 0.6
* Handle system monitor source remove and add

2009-10-07 Version 0.5
* Use only string defaults
* Update data on login

2009-09-11 Version 0.4
* Allow bigger values than 99 to interval
* Update data on start on big intervals

2009-09-10 Version 0.3
* Fix QString/QVariant issues

2009-09-09 Version 0.2
* Show example text in config dialog
* Fix default font

2009-09-08 Version 0.1
* Initial release




LicenseGPL
(Plasmoid)
Send to a friend
Subscribe
Other  Apps  from pdamsten
Report inappropriate content



goto page:  1  2  3 

-
.

 "error" is displayed

 
 by greg0ire on: Sep 8 2009
 
Score 50%

Great plasmoïd. Yet there is a small problem : the text displayed reads "error"... any clue? I installed it by using the "Add a plasmoïd">"Install new plasmoïd" menu (My KDE is french, so I am not sure of these labels).


Reply to this

-

 Re: "error" is displayed

 
 by gilmarmts on: Sep 8 2009
 
Score 50%

Same error with me.


Reply to this

-

 Re: "error" is displayed

 
 by rickz on: Sep 9 2009
 
Score 50%

same here


Reply to this

-

 Re: "error" is displayed

 
 by pdamsten on: Sep 9 2009
 
Score 50%

It's error in text formatting. Try putting {value} or just some text in it and see if that helps. That 'error' is not very intuitive, I try to do something to that later.


Reply to this

-

 Re: "error" is displayed

 
 by pdamsten on: Sep 9 2009
 
Score 50%

Now it shows example text / error text in config dialog. Please post this error text (here or email) if you have more trouble.


Reply to this

-

 Re: Re: "error" is displayed

 
 by hash87 on: Sep 9 2009
 
Score 50%

I got the same error. I updated to 0.2 version and have {value:1.1f} {unit} and example looks like this:

e.g. 31.2 C

But plasmoid still displays "error".


Reply to this

-

 Re: Re: Re: "error" is displayed

 
 by greg0ire on: Sep 9 2009
 
Score 50%

I updated, removed the applets from my desktop, executed killall plasma-desktop && sleep1 && plasma-desktop &, but I still get the "error" message, even when putting "CPU" in the text field.
What do you mean by Quote:
Now it shows example text / error text in config dialog
? I don't see any additional fields in the config dialog...


Reply to this

-

 Re: Re: Re: Re: "error" is displayed

 
 by hash87 on: Sep 9 2009
 
Score 50%

http://omploader.org/vMmJncA/screenshot1.png

check the e.g. field


Reply to this

-

 Re: Re: Re: Re: Re: "error" is displayed

 
 by greg0ire on: Sep 10 2009
 
Score 50%

I do not have this field, even after updating, or uninstalling/reinstalling. I did the install/uninstall with the GUI, I'll try tomorrow with the CLI...


Reply to this

-

 Re: "error" is displayed

 
 by pdamsten on: Sep 10 2009
 
Score 50%

Should be fixed now


Reply to this

-
.

 Re: Re: "error" is displayed

 
 by greg0ire on: Sep 10 2009
 
Score 50%

It works great (I had to log out/log back in for it to work)!
Thanks for this bugfix!
A few more questions :
-How do I make the widgets start automatically at log in? I had to "configure" them for them to start again.
-How do I set update frequency to something between 100 and 999 ms? The input field won't let me write something over 99 or something like 0.1...


Reply to this

-

 Re: Re: Re: "error" is displayed

 
 by pdamsten on: Sep 11 2009
 
Score 50%

> 99 are possible now. Working on startup problem...


Reply to this

-

 Re: Re: Re: Re: "error" is displayed

 
 by greg0ire on: Sep 12 2009
 
Score 50%

I tested the values bigger than 99, it works well, thank you very much for your reactivity. I see the other point in the changelog, does it mean that you fixed it in the meantime?


Reply to this

-

 error

 
 by Havoc65 on: Sep 8 2009
 
Score 50%

im getting the same error message it is reading the cpu but the text says error


Reply to this

-
.

 Great plasmoid

 
 by mirzaD on: Sep 9 2009
 
Score 50%

Great plasmoid, many configuration options, exactly the KDE way.
Thnx very much for making it :D


Reply to this

-

 I have a problem

 
 by Xardax on: Oct 6 2009
 
Score 50%

The plasmoid is looking good, but i have this error:

Quote:
:$ plasmoidviewer analog-meter
findServiceByDesktopPath: not found
Traceback (most recent call last):
File "/usr/share/kde4/apps/plasma_scriptengine_python/pyappletscript.py", line 55, in init
self.pyapplet.init()
File "/home/****/.kde/share/apps/plasma/plasmoids/analog-meter/contents/code/main.py", line 50, in init
self.cfg['interval'] = I(cg.readEntry('interval', 60000))
TypeError: argument 2 of KConfigGroup.readEntry() has an invalid type


Please help, and sorry for my bad english


Reply to this

-

 Re: I have a problem

 
 by pdamsten on: Oct 7 2009
 
Score 50%

Try version 0.5


Reply to this

-

 Re: I have a problem

 
 by Xardax on: Oct 8 2009
 
Score 50%

Thanks for respond so faster, now run, but the plasmoid display "error", and the meter not work, and in the option "Text" say "error: 'uncode' object has no atrtibute 'format'".

Sorry for molest, and thanks,you work is greater.


Reply to this

-

 Re: I have a problem

 
 by Xardax on: Oct 8 2009
 
Score 50%

Thanks for respond so faster, now run, but the plasmoid display "error", and the meter not work, and in the option "Text" say "error: 'uncode' object has no atrtibute 'format'".

Sorry for molest, and thanks,you work is greater.


Reply to this

-

 Re: Re: I have a problem

 
 by pdamsten on: Oct 9 2009
 
Score 50%

Seems to be another python incompability error. What distro and kde/python version do you have?


Reply to this

-

 Re: Re: Re: I have a problem

 
 by Xardax on: Oct 9 2009
 
Score 50%

After to update to KDE 4.3.2, for test if this is the problem, the meter displayed a error "Could not create a python ScriptEngine for the Analog Meter widget", and, in console displayed: "RuntimeError: the sip module implements API v6.0 but the PyKDE4.plasma module requires API v5.0".
Mi sistem:
Debian Lenny
KDE 4.3.2
Python 2.5.4


Reply to this

-

 Re: Re: Re: Re: I have a problem

 
 by pdamsten on: Oct 9 2009
 
Score 50%

Seems like distro has updated sip/pyqt4 but not pykde4 packages and apis don't match.


Reply to this

-

 Plasmoid dosen't auto start

 
 by kent57 on: Oct 18 2009
 
Score 50%

The plasmoid doesn't register anything on reboot. I have to open the plasmoid settings panel and click "OK" to get the meter to work. Is there any way to I can make it auto start on boot?


Reply to this

-

 Re: Plasmoid dosen't auto start

 
 by pdamsten on: Oct 19 2009
 
Score 50%

Do you have version 0.6. It at least tries to fix this.


Reply to this

-

 Re: Plasmoid dosen't auto star

 
 by kent57 on: Oct 20 2009
 
Score 50%

Thanks for the reply pdamstem. I find I am using version 0.4. So I'll upgrade and see how that works.
Nice versatile plasmoid.

Thanks


Reply to this

goto page:  1  2  3 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.