-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (23) .- Knowledge Base  . 

wacom tablet

   2.1.0 beta1  

KDE System Tool

Score 85%
wacom tablet
zoom


wacom tablet
zoom


wacom tablet
zoom


Issue Tacker:  Link
Homepage:  Link
Version Control:  Link
Minimum required   KDE 4.x
Downloads:  3785
Submitted:  Nov 4 2009
Updated:  Aug 21 2014

Description:

KDE 4 KCModule

This module implements a GUI for the Wacom Linux Drivers and extends it
with profile support to handle different button / pen layouts per profile.

For hardware support have a look at http://www.linuxwacom.sourceforge.net

Project Repository:
https://projects.kde.org/projects/extragear/base/wacomtablet

get the source with
git clone git://anongit.kde.org/wacomtablet

(K)Ubuntu 12.x & 13.04:
https://launchpad.net/~maret/+archive/wacom

OpenSUSE 12.2, 12.3 & Factory:
http://software.opensuse.org/download.html?project=home:Temar:wacom&package=kcm_tablet




Changelog:

+++++++++++++++++++++++++++
# v2.1.0-0.1.beta1

* Implement support for multible tablets at once
* Add simple dialog app to ease tablet detection and databse adding
* Add global shortcut for profile rotation
* Add status LED support for profile rotation (Intous/Chintiq)
* Fix profile not found error on tablet connect

+++++++++++++++++++++++++++
# v2.0.2
* Fix compile error on older Qt versions (remove iconset="theme" stuff)
* Add Raw Sample and Suppress to ui

+++++++++++++++++++++++++++
# v2.0.1
* More translations
* Add Wacom Intuos Pro S / PTH-451/S
* Add WacomIntuos Pen Small / CTL-480S tablet
* Add definition of Wacom Intuos PT S / CTH-680S-RUPL
* Add Wacom Intuos PT M / CTH-680S-ENES
* Add support for Wacom Intuos Pro M / PTH-651
* cmake: remove extra kio linking
* adjusted control point and draw below curve area colors to be less websafe looking
* Added Wacom Cintiq 13HD
* Added Samsung Series 7 Slate
+++++++++++++++++++++++++++
# v2.0
* Fixed bug which would prevent the default profile from being created
properly.
* Fixed bug which made it impossible to use some special keys as express
button shortcut.
* Fixed bug where the plasma applet would not rotate the stylus controls.
* Fixed bug which displayed the tablet in an inverted rotation if auto-rotate
was selected.
* Fixed bug which prevented the screen mappings from being applied correctly
when the tablet was rotated.
* Fixed bug which would not allow to set a screen mapping on the touch device.
* Fixed bug where invalid area mappings would make the stylus stick in the
upper left corner.
* Changed way how tablets are reset to their full tablet mapping to fix
problems with Intuos 5 tablets.
* Added some more tablets to the tablet database.
* Updated button hardware mappings for the Intuos 5 Touch.
* Disabled Waltop devices in the database as they are in conflict with some
Wacom devices.
* Improved button shortcut handling.
* Improved handling of auto-rotation.
* Tablet areas can now be selected for each screen independently.
* All screen mapping can now be handled with one dialog.
* Global shortcut to switch between Fullscreen and a single Monitor.
* Tablet and touch area selection now takes the rotation settings into account.
* Added feature which allows the user to invert the scroll direction of the touch device.
* Many bugfixes in the background.


Note:
you must install a wacom-driver 0.20 or higher
See:
http://linuxwacom.git.sourceforge.net/git/gitweb.cgi?p=linuxwacom/xf86-input-wacom;a=summary




LicenseGPL
Source(source code 2.0.2)
openSUSE Factory
openSUSE 12.3
openSUSE 12.2
Send to a friend
Subscribe
Other  Apps  from Etric
Report inappropriate content



goto page: prev  ... 3  4  5  6  7  8  9  10  11  12  13  14  15 

-
.

 Issues

 
 by anderslund on: Nov 24 2012
 
Score 50%

Hi,

I bought a wacom bamboo tablet, and started using the kcm. First, thanks for developing this, it contains all the options I can think of, maybe except a testing area ;)


I have the following issues:

* I can set a shortcut for toggling the touch feature of my device, but I have to reapply the kcm when I reconnect the tablet.

* I can not get buttons to work. I tried to assign a shortcut and a modifier, to no avail. I do not understand what the "button" option does. Assigning a modifier, the text below the buggon reads "activate widget 21", and the choice is not remembered. Assigning a keystroke (eg "ctrl + z") looks fine, but it does not work, the keystroke is not sent.

If you would rather receive bug reports on bugs.kde.org, let me know :)


Reply to this

-

 Re: Issues

 
 by Etric on: Nov 25 2012
 
Score 50%

Hi,

yes please add this bug to bugs.kde.org. This helps to sort this kind of stuff out for the upcomming 2.0 release.

Both bugs should not happen.
Please also add to the bugreport which version you are running (1.3.6/1.3.7 or the newest 2.0 beta1)

For the "button" stuff.
If you set one of the Expresskeys to emit a "Button 1" signals thats exactly the kind of signals which is send via X11.

For a mouse Button 1 is a left click, button 2 is middle, button 3 is right click. You could this way around also set "Button 1" from teh tablet assign to any other program you wanna use.

Using keystrokes is on the other hand the mor natural choice to do. So we rather try to fix this :)


Reply to this

-
.

 Re: Re: Issues

 
 by anderslund on: Nov 25 2012
 
Score 50%

Thanks for answering :)

The shortcut for toggling the touch functionality now works (after restarting kde), except the setting does not stick after replugging the device.

I filed https://bugs.kde.org/show_bug.cgi?id=310670 for the button actions.


Reply to this

-
.

 Re: Re: Re: Issues

 
 by anderslund on: Nov 25 2012
 
Score 50%

Hm, bummer - the shortcut issues actually does exist.Filed another bug report.


Reply to this

-

 not recognize funtion to set expresskey

 
 by rugama on: Nov 27 2012
 
Score 50%

Hi, I have a Wacom tablet BambooPT 2FG 4x5. The driver recognizes the device and its buttons, while setting buttons, the driver records the actions for example "a" or "b", shitf, etc. and apply the changes. But when I set krita or gimp or pencil to use the keys, nothing happens, I build multiple profiles, but do not work, do not work the settings default buttons, ie button 1, button 2, button 3 until the last them.
The function of the area to turn them touch works well, assigning excellent work functions pencil, eraser on the pen tip and excellent work, but ultimately you can not configure the buttons to assign actions or functions.


Reply to this

-

 Re: not recognize funtion to set expresskey

 
 by Etric on: Jan 22 2013
 
Score 50%

Hi,
sorry for the late answer.

Can you please
* deinstall the wacom kcm stuff
* start "xev" on the console
* point the mouse over the opened window
* press the button 1 on the tablet
* check which button gets reported in the console
* do the same with all other buttons

Now with the list of buttons

* now install the latest version again
Than you can change the file
/usr/share/kde4/apps/wacomtablet/data/wacom_devicelist

find you tablet in this list and change the lines

hwbutton1=1
hwbutton2=2
hwbutton3=3
hwbutton4=8

according to your observations.

Afterwards reconnect the tablet and everything should work again.
Please send me your changed lines so I can put it into git again


Reply to this

-

 x.y.z-foo doesn't help downstreamers

 
 by perezmeyer on: Dec 10 2012
 
Score 50%

Hi! As a maintainer of this app in Debian, I find that naming it x.y.z-something is bad for us downstreamers (ie, distros), as we keep the package version with -something.

The change you made has enough merit to release 1.3.8, as it's a minor change.

Thanks, Lisandro.


Reply to this

-
.

 Two tablets, settings apply to only one

 
 by urlwolf on: Jan 9 2013
 
Score 50%

First, great job!

Second. I have two tablets, settings apply to only one. Wacom bamboo 2nd and 3rd gen, plugged together.

♪ xsetwacom --list
Wacom Bamboo 16FG 4x5 Pen stylus id: 13 type: STYLUS
Wacom Bamboo 16FG 4x5 Pen eraser id: 14 type: ERASER
Wacom Bamboo 16FG 4x5 Finger touch id: 15 type: TOUCH
Wacom Bamboo 16FG 4x5 Finger pad id: 20 type: PAD
Wacom Bamboo Pen Finger touch id: 21 type: TOUCH
Wacom Bamboo Pen Finger pad id: 26 type: PAD
Wacom Bamboo Pen Pen stylus id: 27 type: STYLUS
Wacom Bamboo Pen Pen eraser id: 28 type: ERASER

I'd love to fix this, but in the mean time, I'm very happy.

The only thing I want for the 2nd gen is to get 'hover click'. I can set it with xsetwacom, if I know what parameter that is... Do you know?


Reply to this

-

 Can't start

 
 by aku506 on: Jan 11 2013
 
Score 50%

I've installed this in Ubuntu 12.04 with Unity. I couldn't find out how can I start this. Or is there some problem with Unity?


Reply to this

-

 Re: Can't start

 
 by Etric on: Jan 11 2013
 
Score 50%

This is unlikely to work with Unity ever.

In order to work properly it needs the kde deamon, so this won't work outside of the KDE enviroment.


Reply to this

-

 Thank you!

 
 by JenyaYQ on: Mar 5 2013
 
Score 50%

Thank you for your work!


Reply to this

goto page: prev  ... 3  4  5  6  7  8  9  10  11  12  13  14  15 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.