-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (20) .- Knowledge Base  . 

wacom tablet

   2.0.2  

KDE System Tool

Score 85%
wacom tablet
zoom


wacom tablet
zoom


wacom tablet
zoom


Issue Tacker:  Link
Homepage:  Link
Version Control:  Link
Minimum required   KDE 4.x
Downloads:  3678
Submitted:  Nov 4 2009
Updated:  Jul 10 2014

Description:

KDE 4 KCModule

This module implements a GUI for the Wacom Linux Drivers and extends it
with profile support to handle different button / pen layouts per profile.

For hardware support have a look at http://www.linuxwacom.sourceforge.net

Project Repository:
https://projects.kde.org/projects/extragear/base/wacomtablet

get the source with
git clone git://anongit.kde.org/wacomtablet

(K)Ubuntu 12.x & 13.04:
https://launchpad.net/~maret/+archive/wacom

OpenSUSE 12.2, 12.3 & Factory:
http://software.opensuse.org/download.html?project=home:Temar:wacom&package=kcm_tablet




Changelog:

+++++++++++++++++++++++++++
# v2.0.2
* Fix compile error on older Qt versions (remove iconset="theme" stuff)
* Add Raw Sample and Suppress to ui

+++++++++++++++++++++++++++
# v2.0.1
* More translations
* Add Wacom Intuos Pro S / PTH-451/S
* Add WacomIntuos Pen Small / CTL-480S tablet
* Add definition of Wacom Intuos PT S / CTH-680S-RUPL
* Add Wacom Intuos PT M / CTH-680S-ENES
* Add support for Wacom Intuos Pro M / PTH-651
* cmake: remove extra kio linking
* adjusted control point and draw below curve area colors to be less websafe looking
* Added Wacom Cintiq 13HD
* Added Samsung Series 7 Slate
+++++++++++++++++++++++++++
# v2.0
* Fixed bug which would prevent the default profile from being created
properly.
* Fixed bug which made it impossible to use some special keys as express
button shortcut.
* Fixed bug where the plasma applet would not rotate the stylus controls.
* Fixed bug which displayed the tablet in an inverted rotation if auto-rotate
was selected.
* Fixed bug which prevented the screen mappings from being applied correctly
when the tablet was rotated.
* Fixed bug which would not allow to set a screen mapping on the touch device.
* Fixed bug where invalid area mappings would make the stylus stick in the
upper left corner.
* Changed way how tablets are reset to their full tablet mapping to fix
problems with Intuos 5 tablets.
* Added some more tablets to the tablet database.
* Updated button hardware mappings for the Intuos 5 Touch.
* Disabled Waltop devices in the database as they are in conflict with some
Wacom devices.
* Improved button shortcut handling.
* Improved handling of auto-rotation.
* Tablet areas can now be selected for each screen independently.
* All screen mapping can now be handled with one dialog.
* Global shortcut to switch between Fullscreen and a single Monitor.
* Tablet and touch area selection now takes the rotation settings into account.
* Added feature which allows the user to invert the scroll direction of the touch device.
* Many bugfixes in the background.


Note:
you must install a wacom-driver 0.20 or higher
See:
http://linuxwacom.git.sourceforge.net/git/gitweb.cgi?p=linuxwacom/xf86-input-wacom;a=summary




LicenseGPL
Source(source code 2.0.2)
openSUSE Factory
openSUSE 12.3
openSUSE 12.2
Send to a friend
Subscribe
Other  Apps  from Etric
Report inappropriate content



goto page: prev  ... 4  5  6  7  8  9  10  11  12  13  14 

-

 compile error

 
 by kalmar on: Mar 21 2013
 
Score 50%

I can't compile it...

here is the log:
https://dl.dropbox.com/u/2158899/wacomtablte-1.99.7_build.log

Gentoo (mostly) stable


Reply to this

-

 Re: compile error

 
 by Etric on: Mar 21 2013
 
Score 50%

Not sure why this happens, but could you try to remove

-DKDE4_BUILD_TESTS=OFF

We check only if the variable is set and this results ina static library instead of a shared one for some parts. This might cause the problem.

without -DKDE4_BUILD_TESTS=OFF the unit tests are not build as well, so there is no need to specify this directly


Reply to this

-

 Re: Re: compile error

 
 by kalmar on: Mar 21 2013
 
Score 50%

I tried, the same error occured...

I tried also compile with "-j1", the same happened...


Reply to this

-

 Re: compile error

 
 by oldium on: Mar 22 2013
 
Score 50%

I also have Gentoo and I have Googled DT_TEXTREL problem - some of the linked files use -fPIC and some don't. I fixed the problem by removing the conditional around adding -fPIC in src/common/CMakeLists.txt and src/kded/CMakeLists.txt - so that it will use -fPIC always. This did the trick for me.


Reply to this

-

 Re: Re: compile error

 
 by kalmar on: Mar 22 2013
 
Score 50%

Great! It worked!

How did You found it out?


Reply to this

-

 Re: Re: Re: compile error

 
 by oldium on: Mar 23 2013
 
Score 50%

Error message is "warning: creating a DT_TEXTREL in a shared object" and Google told me (in the first search result) that this is a problem with missing -fPIC. So I searched the sources for -fPIC and removed the conditional. Simple :-)


Reply to this

-

 Re: Re: compile error

 
 by Etric on: Mar 23 2013
 
Score 50%

Great! Thanks for the hint. I'll ask Alex why he added the condition around it.


Reply to this

-

 top left corner

 
 by kalmar on: Mar 23 2013
 
Score 50%

Hi,
I'm experiencing a very strange bug:

Starting kde service Wacom Tablet causes cursor controlled by stylus to stay in top left corner (it does moves, but

xinput test
says differences ca. 30 [points];

restarting X makes it behave correctly

I downgrade wacomtablet (to 1.3.7) to see if the issue occurs only in the new one.

[tablet is Intuos4]


Reply to this

-

 Re: top left corner

 
 by Etric on: Mar 23 2013
 
Score 50%

Weird.

What happens if you "calibrate" the tablet. So in the "Tablet" tab open "Map Tablet Area to Screen" make the tablet are fit to the screen area.

Also did you try to create a new profile or just reused the old one? And did you restart the kded after installing this?


Reply to this

-

 Re: Re: top left corner

 
 by kalmar on: Mar 23 2013
 
Score 50%

fitting to screen area changes nothing in behavior of cursor.

deleted all old profiles, and deleted
.kde4/share/config/wacomtablet-kderc

I logged out and in, restarted X, and did reboot; still the same.

currently I'm using
xf86-input-wacom-0.20.0
libwacom-0.7
wacomtablet-1.99.7
kernel-3.7.4


Reply to this

-

 Re: Re: top left corner

 
 by kalmar on: Mar 23 2013
 
Score 50%

Next findings:

only stylus position is wrong. clicks, eraser do work correctly;

xsetwacom ResetArea makes things right (with factory calibration)


Reply to this

-

 Re: Re: Re: top left corner

 
 by Temar on: Mar 23 2013
 
Score 50%

Thanks for your testing.

I have an idea what the problem might be. Can you check your tablet profiles configuration file and tell me what the properties "Area" and "ScreenMap" are set to (when it's not working)?

Do you see a "-1 -1 -1 -1" entry anywhere in your configuration file?


Reply to this

-

 Re: Re: Re: Re: top left corner

 
 by kalmar on: Mar 23 2013
 
Score 50%

which file should I check?

find .kde4/|grep wacom
returns only
.kde4/share/config/wacomtablet-kderc
(which only contains name of the last profile)

neither search in ./.config nor by profile name reveals something...


Reply to this

-

 Re: Re: Re: Re: Re: top left corner

 
 by Temar on: Mar 23 2013
 
Score 50%

Ah sorry, it's "$HOME/.kde/share/config/tabletprofilesrc".

But you can also try the latest version from GIT. I committed a patch which might fix your problem.


Reply to this

-

 Re: Re: Re: Re: top left corner

 
 by kalmar on: Mar 23 2013
 
Score 50%

I can see such an entry indeed;-)

[Wacom Intuos4 6x9][default][eraser]
Area=-1 -1 -2 -2
Button2=2
Button3=3
Mode=absolute
PressureCurve=0 0 100 100
Rotate=auto
ScreenMap=-1 -1 -1 -1
ScreenSpace=desktop
Threshold=27

[Wacom Intuos4 6x9][default][pad]
AbsWheel2Down=5
AbsWheel2Up=4
AbsWheelDown=5
AbsWheelUp=4
Button1=0
Button2=0
Button3=0
Button4=0
Button5=0
Button6=0
Button7=0
Button8=0
Button9=0

[Wacom Intuos4 6x9][default][stylus]
Area=-1 -1 -2 -2
Button2=2
Button3=3
Mode=absolute
PressureCurve=0 0 100 100
Rotate=auto
ScreenMap=-1 -1 -1 -1
ScreenSpace=desktop
TabletPcButton=off
Threshold=27

unfortunately I get 404 error on git access...

[btw.If I do ResetArea and then calibrate/Set Screen Proportions, then everything works as intended even after replugging the tablet.]


Reply to this

-

 Re: Re: Re: Re: Re: top left corner

 
 by Temar on: Mar 23 2013
 
Score 50%

Thank you, your configuration explains a lot.

My patch won't work for you but I now know what to fix.

However you still got a strange "ScreenMap" entry. It doesn't matter because the entry gets auto-corrected but still I have to check how such an entry could get into your configuration file.

It should always be something like...

ScreenMap=desktop:-1 -1 -1 -1

... or ...

ScreenMap=desktop:-1 -1 -1 -1|map0:0 0 800 600

... but never a single area map.

You have only one monitor, do you?

KDE GIT is currently down but I will commit a fix for that problem later.


Reply to this

-

 Re: Re: Re: Re: Re: top left corner

 
 by Temar on: Mar 23 2013
 
Score 50%

I committed a fix which should properly reset your tablet when full desktop mapping is selected. Let me know if the patch works for you.

However, Git access might be a bit jumpy today as they had a corrupt filesystem on the server.

Also, could you please try and map your tablet to half of your screen and tell me what your ScreenMap property gets set to?

Thanks again for testing.


Reply to this

-

 Re: Re: Re: Re: Re: Re: top left corner

 
 by kalmar on: Mar 23 2013
 
Score 50%

I tried the git version, it works perfectly now;

(installing, restarting kded4, deleting tabletprofilerc, plugging tablet, and finally creating default profile resutls in
https://dl.dropbox.com/u/2158899/tabletprofilesrc-clean-install

here:
https://dl.dropbox.com/u/2158899/tabletprofilesrc-map-tablet-area

is after mapping screen to right ~half of the tablet



-

 Re: Re: Re: Re: Re: top left corner

 
 by Temar on: Mar 24 2013
 
Score 50%

Great to hear that everything works perfectly now. Your configuration files look fine now, too.

Thanks for all your testing. We only have a very limited selection of tablets available to test our software with. So we really depend on people like you, who are willing to test beta software and spend some time on giving feedback. Thanks again for all your efforts!


Reply to this

-

 Re: Re: Re: Re: Re: Re: top left corner

 
 by kalmar on: Mar 24 2013
 
Score 50%

Well, we should thank You for Your work on wacomtablet instead!

It was a pleasure to test!

Cheers!



-

 Device not found

 
 by BrendanScott on: Apr 27 2013
 
Score 50%

I have a wacom intuos 5 tablet, opensuse 12.3
kcm_tablet was installed from the 12.3 repo. It cannot find the tablet ("No tablet device was found")
However, the tablet is there, and visible to x and xsetwacom:
Quote:

>xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ HID 04b3:310d id=8 [slave pointer (2)]
⎜ ↳ Wacom Intuos5 touch M Pen stylus id=9 [slave pointer (2)]
⎜ ↳ Wacom Intuos5 touch M Finger touch id=10 [slave pointer (2)]
⎜ ↳ Wacom Intuos5 touch M Pen eraser id=12 [slave pointer (2)]
⎜ ↳ Wacom Intuos5 touch M Pen cursor id=13 [slave pointer (2)]
⎜ ↳ Wacom Intuos5 touch M Pen pad id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]

>xsetwacom --list devices
Wacom Intuos5 touch M Pen stylus id: 9 type: STYLUS
Wacom Intuos5 touch M Finger touch id: 10 type: TOUCH
Wacom Intuos5 touch M Pen eraser id: 12 type: ERASER
Wacom Intuos5 touch M Pen cursor id: 13 type: CURSOR
Wacom Intuos5 touch M Pen pad id: 14 type: PAD


Any ideas?


Reply to this

-

 Re: Device not found

 
 by BrendanScott on: Apr 30 2013
 
Score 50%

ps. Adding the [0027] entry as per:
http://kde-apps.org/content/show.php?content=114856&forumpage=9

Doesn't seem to work for me.


Reply to this

-

 Re: Device not found

 
 by BrendanScott on: Apr 30 2013
 
Score 50%

Scratch that
Have installed lastest unstable from
https://projects.kde.org/projects/extragear/base/wacomtablet

And rebooted
and now it seems to work.


Reply to this

-

 Bug in express keys

 
 by BrendanScott on: May 1 2013
 
Score 50%

If I try to assign + (ie "key +shift = -shift) in the settings page, it records "+" but sends "=".
There seem to be problems with !@# etc as well.


Reply to this

-

 Re: Bug in express keys

 
 by Temar on: May 1 2013
 
Score 50%

Quote:
If I try to assign + (ie "key +shift = -shift) in the settings page, it records "+" but sends "=".


If you want to send a '+' sign, then the correct sequence would be "key plus". To set this, just use the button mapping dialog and press the "keyboard shortcut input button", then press Shit= and the shortcut button should correctly display the '+' sign.

Quote:

There seem to be problems with !@# etc as well.


If you tried a sequence like "key +shift 1 -shift", then it will not work as it basically translates to: "Send shift-down event, send 1, send shift-up event". As xsetwacom does not know anything about your keyboard layout, it can not translate Shift1 to '!'.

Just use the button mapping dialog and map the sequence with the keyboard shortcut button. Let me know if it works for you.


Reply to this

-

 Re: Re: Bug in express keys

 
 by BrendanScott on: May 1 2013
 
Score 50%

No, I configure it through kcm_tablet, and I enter a +:
click keyboard icon for ring up on express buttons tab
click spanner/Input... button
type the key + (ie shift+=).
click ok button,
click apply button

The label in the select button dialog shows a + (as does the label in the expressbuttons tab after I click ok).

BUT, when I actually "click" the ringup button I get a =:
======================================
Similarly for # and ! (the only other two I've tried)

Since then, I have tried some xsetwacom combinations, but can't get them to work either.


Reply to this

-

 Re: Re: Re: Bug in express keys

 
 by BrendanScott on: May 1 2013
 
Score 50%

ps if I click a button with shift assigned to it and the ring button I get a +
If I try to assign # I get nothing on the ring click


Reply to this

-

 Re: Re: Re: Re: Bug in express keys

 
 by Temar on: May 1 2013
 
Score 50%

Quote:

ps if I click a button with shift assigned to it and the ring button I get a +
If I try to assign # I get nothing on the ring click


I tested it again and there are indeed multiple problems with xsetwacom. The '+' and '-' keys worked for me because I do not use an english keyboard layout and do not have to press the shift key to get a plus or minus.

I tried it with '!' which is also Shift-1 on my keyboard and indeed it does not work as xsetwacom does not properly map these keys. However there is help on the way and it seems future versions of xsetwacom will have a fix for this:

http://sourceforge.net/mailarchive/forum.php?thread_name=CAF8JNhKSCfjJNAgb-zjMyTEpui_RxVOV3xW3MydSUZ74o9SLgA%40mail.gmail.com&forum_name=linuxwacom-devel

We could also fix this easily on our side, like we already do for the plus and minus keys, but it seems there is another bug (or feature) in xsetwacom which somehow maps the key back to its "unshifted" base form. So in your case where you have to press Shift-= to get a plus key, xsetwacom maps this to its base form which is '='.

From my point of view this is a bug in xsetwacom, however we have to talk to the xsetwacom guys to ask how this is supposed to work. They might see it as a feature, because using "key +shift exclam -shift" actually gives you the '!'. However using "key exclam" will be translated to a '1'.

Unfortunately we can not easily work around this problem in our software. When entering a keyboard shortcut like "Shift-1", Qt returns the actual key which is "!". To translate this back into "Shift-1" we would have to take keyboard layouts into account or write our own keyboard shortcut input widget.

I think we have to talk to the xsetwacom guys first and see if they want to fix this on their side. Also I have to check the latest xsetwacom version as this bug might already be fixed.


Reply to this

-

 Re: Re: Re: Re: Re: Bug in express keys

 
 by BrendanScott on: May 2 2013
 
Score 50%

Thanks for the feedback. I will just assign + to some other shortcut for the time being.
Apparently its already been fixed upstream:
http://article.gmane.org/gmane.linux.drivers.wacom/6721


Reply to this

-

 Re: Re: Re: Re: Re: Re: Bug in express keys

 
 by BrendanScott on: May 3 2013
 
Score 50%

This works for me from xsetwacom:
key shift plus



-

 Re: Re: Re: Re: Re: Re: Bug in express keys

 
 by Temar on: May 5 2013
 
Score 50%

I commited a fix for this problem, which should fix most (but not all) button mapping problems. There still seem to be some bugs left in xsetwacom which we can not work around on our side.

Thanks for testing and reporting this bug!



-

 Gimp Plugin for Touchring Mode Setting

 
 by BrendanScott on: May 3 2013
 
Score 50%

I have written a plugin for gimp to do mode setting for wacom intuos 5 touchring. That is, click the middle button and it cycles through the modes, making the touchring do different things zoom, brush size, layers, scroll.
The plug in is available here:
http://registry.gimp.org/node/28096

I only have an Intuos 5 touch medium, but the plug in should work with
other models. The source code has some details about setting up udev rules
so that permissions work correctly (for the status leds).


Reply to this

-
.

 Lots of compile errors

 
 by msx on: May 8 2013
 
Score 50%

Hello Etric, I'm having all these errors, can you help me debug them?
http://pastebin.com/LYBvZTve

Cheers!
/Martín


Reply to this

-

 Re: Lots of compile errors

 
 by Temar on: May 9 2013
 
Score 50%

Your DTD does not contain the tags which are required to build the handbook. No idea why, but you can work around this problem by not building the handbook.

Edit CMakeLists.txt in the root directory and remove the line "add_subdirectory( doc )".


Reply to this

goto page: prev  ... 4  5  6  7  8  9  10  11  12  13  14 

Add commentBack






-
-
Do you like or dislike Ubuntu Unity?
 Yes, unity is alien technology!
 It is less confusing than Gnome 3 default, shell.
 Granny thinks it is much more usable than Gnome 2
 Canonical is embarrasing itself with this split project
 Gnome 3 default shell is much better
 I dislike Unity, Gnome 3 default shell is alien technology!
 None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.