-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (20) .- Knowledge Base  . 

wacom tablet

   2.0.2  

KDE System Tool

Score 85%
wacom tablet
zoom


wacom tablet
zoom


wacom tablet
zoom


Issue Tacker:  Link
Homepage:  Link
Version Control:  Link
Minimum required   KDE 4.x
Downloads:  3665
Submitted:  Nov 4 2009
Updated:  Jul 10 2014

Description:

KDE 4 KCModule

This module implements a GUI for the Wacom Linux Drivers and extends it
with profile support to handle different button / pen layouts per profile.

For hardware support have a look at http://www.linuxwacom.sourceforge.net

Project Repository:
https://projects.kde.org/projects/extragear/base/wacomtablet

get the source with
git clone git://anongit.kde.org/wacomtablet

(K)Ubuntu 12.x & 13.04:
https://launchpad.net/~maret/+archive/wacom

OpenSUSE 12.2, 12.3 & Factory:
http://software.opensuse.org/download.html?project=home:Temar:wacom&package=kcm_tablet




Changelog:

+++++++++++++++++++++++++++
# v2.0.2
* Fix compile error on older Qt versions (remove iconset="theme" stuff)
* Add Raw Sample and Suppress to ui

+++++++++++++++++++++++++++
# v2.0.1
* More translations
* Add Wacom Intuos Pro S / PTH-451/S
* Add WacomIntuos Pen Small / CTL-480S tablet
* Add definition of Wacom Intuos PT S / CTH-680S-RUPL
* Add Wacom Intuos PT M / CTH-680S-ENES
* Add support for Wacom Intuos Pro M / PTH-651
* cmake: remove extra kio linking
* adjusted control point and draw below curve area colors to be less websafe looking
* Added Wacom Cintiq 13HD
* Added Samsung Series 7 Slate
+++++++++++++++++++++++++++
# v2.0
* Fixed bug which would prevent the default profile from being created
properly.
* Fixed bug which made it impossible to use some special keys as express
button shortcut.
* Fixed bug where the plasma applet would not rotate the stylus controls.
* Fixed bug which displayed the tablet in an inverted rotation if auto-rotate
was selected.
* Fixed bug which prevented the screen mappings from being applied correctly
when the tablet was rotated.
* Fixed bug which would not allow to set a screen mapping on the touch device.
* Fixed bug where invalid area mappings would make the stylus stick in the
upper left corner.
* Changed way how tablets are reset to their full tablet mapping to fix
problems with Intuos 5 tablets.
* Added some more tablets to the tablet database.
* Updated button hardware mappings for the Intuos 5 Touch.
* Disabled Waltop devices in the database as they are in conflict with some
Wacom devices.
* Improved button shortcut handling.
* Improved handling of auto-rotation.
* Tablet areas can now be selected for each screen independently.
* All screen mapping can now be handled with one dialog.
* Global shortcut to switch between Fullscreen and a single Monitor.
* Tablet and touch area selection now takes the rotation settings into account.
* Added feature which allows the user to invert the scroll direction of the touch device.
* Many bugfixes in the background.


Note:
you must install a wacom-driver 0.20 or higher
See:
http://linuxwacom.git.sourceforge.net/git/gitweb.cgi?p=linuxwacom/xf86-input-wacom;a=summary




LicenseGPL
Source(source code 2.0.2)
openSUSE Factory
openSUSE 12.3
openSUSE 12.2
Send to a friend
Subscribe
Other  Apps  from Etric
Report inappropriate content



goto page: prev   1  2  3  4  5  6  7  8  9  10  11 ...

-

 Lenovo X201

 
 by Ray-Ven on: Aug 22 2010
 
Score 50%
Ray-VenRay-Ven
Schoolteache r

Hi, I'd love to use this in combination wit krandr to rotate my tablet screen. Or is there a better sollution for that?
Tablet is not been recognized though.

Thanks
Ray


Reply to this

-

 Re: Lenovo X201

 
 by Etric on: Aug 22 2010
 
Score 50%

Right now it is not possible.
Never thought about krandr support, but I will add it later on.

What tablet device is in the Lenovo?

Have a look at:
http://websvn.kde.org/trunk/playground/base/wacomtablet/README?view=markup

If your tablet is recognized via xsetwacom, it will work :)

Let me know if you have any poblems


Reply to this

-

 Re: Re: Lenovo X201

 
 by Ray-Ven on: Aug 22 2010
 
Score 50%
Ray-VenRay-Ven
Schoolteache r

I'm very new to this tablet things, my first device are the n900 and x210 Tablet.
Currently i'm running ubuntu maverick (alpha)
tablet and stylus work out-of-the-box

xsetwacom -list gives me:
xsetwacom list
Serial Wacom Tablet stylus STYLUS
Serial Wacom Tablet eraser ERASER
Serial Wacom Tablet touch TOUCH

but i.e. xsetwacom -s get Stylus PressCurve
(tried stylus or STYLUS and stylus STYLUS instead of Stylus) says cannot find the device 'Stylus'


xsetwacom --list -v says:
... Display is '(null)'.
... 'list' requested.
... Found device 'Virtual core XTEST pointer' (4).
... Found device 'Virtual core XTEST keyboard' (5).
... Found device 'Power Button' (6).
... Found device 'Video Bus' (7).
... Found device 'Sleep Button' (8).
... Found device 'Integrated Camera' (9).
... Found device 'AT Translated Set 2 keyboard' (10).
... Found device 'ThinkPad Extra Buttons' (13).
... Found device 'Serial Wacom Tablet stylus' (16).
Serial Wacom Tablet stylus STYLUS
... Found device 'Serial Wacom Tablet eraser' (14).
Serial Wacom Tablet eraser ERASER
... Found device 'Serial Wacom Tablet touch' (15).
Serial Wacom Tablet touch TOUCH
... Found device 'SynPS/2 Synaptics TouchPad' (12).
... Found device 'TPPS/2 IBM TrackPoint' (17).
... Found device 'TPPS/2 IBM TrackPoint' (18).
... Found device 'Logitech USB Receiver' (19).
... Found device 'Logitech USB Receiver' (20).
... Found device 'SynPS/2 Synaptics TouchPad' (11).

hope this helps.

Thanks,

Ray


Reply to this

-

 Re: Re: Re: Lenovo X201

 
 by Ray-Ven on: Oct 4 2010
 
Score 50%
Ray-VenRay-Ven
Schoolteache r

xsetwacom --list -v gives me:
... Found device 'Serial Wacom Tablet eraser' (13).
Serial Wacom Tablet eraser ERASER
... Found device 'Serial Wacom Tablet touch' (14).
Serial Wacom Tablet touch TOUCH
... Found device 'Serial Wacom Tablet stylus' (15).
Serial Wacom Tablet stylus STYLUS

and using the numbers (13,14,15) let's me change settings. Doesn't work with the names though.

and xsetwacom get "13" TabletID gives back:
227

what now?


Reply to this

-

 Re: Re: Re: Re: Lenovo X201

 
 by Ray-Ven on: Oct 4 2010
 
Score 50%
Ray-VenRay-Ven
Schoolteache r

xinput list-props "Serial Wacom Tablet touch"


Device 'Serial Wacom Tablet touch':
Device Enabled (125): 1
Coordinate Transformation Matrix (127): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
Device Accel Profile (247): 0
Device Accel Constant Deceleration (248): 1.000000
Device Accel Adaptive Deceleration (249): 1.000000
Device Accel Velocity Scaling (250): 10.000000
Wacom Tablet Area (270): 0, 0, 2631, 1652
Wacom Rotation (271): 0
Wacom Serial IDs (273): 227, 0, 3, 0
Wacom TwinView Resolution (274): 0, 0, 0, 0
Wacom Display Options (275): -1, 0, 1
Wacom Screen Area (276): 0, 0, 1280, 800
Wacom Proximity Threshold (277): 0
Wacom Capacity (278): -1
Wacom Pressure Threshold (279): 27
Wacom Sample and Suppress (280): 2, 4
Wacom Enable Touch (281): 0
Wacom Hover Click (282): 0
Wacom Enable Touch Gesture (283): 1
Wacom Touch Gesture Parameters (284): 50, 20, 250
Wacom Tool Type (285): "TOUCH" (287)
Wacom Button Actions (286): "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0), "None" (0)


Reply to this

-

 Re: Re: Re: Re: Re: Lenovo X201

 
 by Ray-Ven on: Jan 9 2011
 
Score 50%
Ray-VenRay-Ven
Schoolteache r

I realize, that you added support for the x201!
Nice! Too bad I can't find a deb package :-(
I'll try to build a dirty checkinstall package - If you want me to send it to you, let me know


Reply to this

-

 x201 tablet

 
 by Ray-Ven on: Aug 31 2010
 
Score 50%
Ray-VenRay-Ven
Schoolteache r

Maybe I should let you know following facts:
2.6.35-19-generic (amd64, Maverick)
KDE 4.5
kcm tablet 1.0


Reply to this

-

 Re: x201 tablet

 
 by Ray-Ven on: Aug 31 2010
 
Score 50%
Ray-VenRay-Ven
Schoolteache r

kcmtablet 1.2.0, sorry (is there no edit button?!)


Reply to this

-

 run kcm setings at startup

 
 by rdydel on: Sep 7 2010
 
Score 50%

Hi,
Works very well with my Wacom PrnPartner 2 on openSUSE 11.3.

I heve one question, how to make run kcm tablet setings at a startup openSUSE?
Now when I boot sustem, I have to run system setings and get to keyboard & mouse, and since then my configuration works.


Reply to this

-

 Can you include PO files?

 
 by gokcen on: Oct 2 2010
 
Score 50%

Hello,

Thanks for the KCModule, this was what we were waiting.

1- Can you please include missing pot/po files so we can translate the application and it will be better for distros to include this module.

2- Can you also use "svn export" to get rid of .svn directories in tarball?

3- Can you get the latest commits from KDE SVN and make this tarball up-to-date?


Reply to this

-

 Re: Can you include PO files?

 
 by Etric on: Oct 7 2010
 
Score 50%

Hi,

Quote:
1- Can you please include missing pot/po files so we can translate the application and it will be better for distros to include this module

The pot files are now included in the file. About the translation process, as this program will hopefully soon be part of the KDE family the translation is done in the same way all translations are done in KDE (and some already started to translate it)

Quote:
2- Can you also use "svn export" to get rid of .svn directories in tarball?

The tarball should be without any .svn directories now

Quote:
3- Can you get the latest commits from KDE SVN and make this tarball up-to-date?


I've updated to the current status, that is available in kdereview at the moment. As I changed a lot in the tablet detection area, some more feedback is always appreciated.


Reply to this

-

 wacom 4 graphire not detected

 
 by nowardev on: Oct 7 2010
 
Score 50%

libxi-dev to compile on kubuntu..
but doesn't work :D

xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Logitech USB Mouse id=9 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=11 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=12 [slave pointer (2)]
⎜ ↳ Wacom Graphire4 4x5 eraser id=13 [slave pointer (2)]
⎜ ↳ Wacom Graphire4 4x5 cursor id=14 [slave pointer (2)]
⎜ ↳ Wacom Graphire4 4x5 pad id=15 [slave pointer (2)]
⎜ ↳ Wacom Graphire4 4x5 id=16 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=10 [slave keybo


Reply to this

-

 no way graphire4

 
 by nowardev on: Oct 8 2010
 
Score 50%

doesn't work anyway

xsetwacom list dev

Wacom Graphire4 4x5 eraser ERASER
Wacom Graphire4 4x5 cursor CURSOR
Wacom Graphire4 4x5 pad PAD
Wacom Graphire4 4x5 STYLUS

xsetwacom get "Wacom Graphire4 4x5" tabletid
21

sudo nano /usr/share/kde4/apps/wacomtablet/data/wacom_devicelist

added but....noway doens't work


[0015]
model=CTE_440
layout=unknown
name=Wacom Graphire4 4x5
padbuttons=2
wheel=yes
touchring=yes
touchstripl=yes


Reply to this

-

 Re: no way graphire4

 
 by Etric on: Oct 8 2010
 
Score 50%

is the kded started? in the system settings you can start/stop the kded services on its own.

usually when my program is installed the service is not started right away (but will start every time the system is restarted afterwards)

in case the kded is running, could you start the kded with debug output please.

to enable debug output, run:
kdebugdialog
and enable the output for the kded (or just everything)

in the konsole run:
kquitapp kded
then
kded4

plugin / out you tablet and the wacomtablet should complain why your tablet is not found


Reply to this

-

 Re: Re: no way graphire4

 
 by nowardev on: Oct 9 2010
 
Score 50%

kded4 was crashing everytime
and yea was your software :D
downloaded the B version
and it's working
ty so much
wheel still doesn't work on my graphire buyt i know it's a xsetwacom problem with my tablet.


Reply to this

goto page: prev   1  2  3  4  5  6  7  8  9  10  11 ...

Add commentBack






-
-
Do you like or dislike Ubuntu Unity?
 Yes, unity is alien technology!
 It is less confusing than Gnome 3 default, shell.
 Granny thinks it is much more usable than Gnome 2
 Canonical is embarrasing itself with this split project
 Gnome 3 default shell is much better
 I dislike Unity, Gnome 3 default shell is alien technology!
 None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.