-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (23) .- Knowledge Base  . 

wacom tablet

   2.1.0 beta1  

KDE System Tool

Score 85%
wacom tablet
zoom


wacom tablet
zoom


wacom tablet
zoom


Issue Tacker:  Link
Homepage:  Link
Version Control:  Link
Minimum required   KDE 4.x
Downloads:  3843
Submitted:  Nov 4 2009
Updated:  Aug 21 2014

Description:

KDE 4 KCModule

This module implements a GUI for the Wacom Linux Drivers and extends it
with profile support to handle different button / pen layouts per profile.

For hardware support have a look at http://www.linuxwacom.sourceforge.net

Project Repository:
https://projects.kde.org/projects/extragear/base/wacomtablet

get the source with
git clone git://anongit.kde.org/wacomtablet

(K)Ubuntu 12.x & 13.04:
https://launchpad.net/~maret/+archive/wacom

OpenSUSE 12.2, 12.3 & Factory:
http://software.opensuse.org/download.html?project=home:Temar:wacom&package=kcm_tablet




Changelog:

+++++++++++++++++++++++++++
# v2.1.0-0.1.beta1

* Implement support for multible tablets at once
* Add simple dialog app to ease tablet detection and databse adding
* Add global shortcut for profile rotation
* Add status LED support for profile rotation (Intous/Chintiq)
* Fix profile not found error on tablet connect

+++++++++++++++++++++++++++
# v2.0.2
* Fix compile error on older Qt versions (remove iconset="theme" stuff)
* Add Raw Sample and Suppress to ui

+++++++++++++++++++++++++++
# v2.0.1
* More translations
* Add Wacom Intuos Pro S / PTH-451/S
* Add WacomIntuos Pen Small / CTL-480S tablet
* Add definition of Wacom Intuos PT S / CTH-680S-RUPL
* Add Wacom Intuos PT M / CTH-680S-ENES
* Add support for Wacom Intuos Pro M / PTH-651
* cmake: remove extra kio linking
* adjusted control point and draw below curve area colors to be less websafe looking
* Added Wacom Cintiq 13HD
* Added Samsung Series 7 Slate
+++++++++++++++++++++++++++
# v2.0
* Fixed bug which would prevent the default profile from being created
properly.
* Fixed bug which made it impossible to use some special keys as express
button shortcut.
* Fixed bug where the plasma applet would not rotate the stylus controls.
* Fixed bug which displayed the tablet in an inverted rotation if auto-rotate
was selected.
* Fixed bug which prevented the screen mappings from being applied correctly
when the tablet was rotated.
* Fixed bug which would not allow to set a screen mapping on the touch device.
* Fixed bug where invalid area mappings would make the stylus stick in the
upper left corner.
* Changed way how tablets are reset to their full tablet mapping to fix
problems with Intuos 5 tablets.
* Added some more tablets to the tablet database.
* Updated button hardware mappings for the Intuos 5 Touch.
* Disabled Waltop devices in the database as they are in conflict with some
Wacom devices.
* Improved button shortcut handling.
* Improved handling of auto-rotation.
* Tablet areas can now be selected for each screen independently.
* All screen mapping can now be handled with one dialog.
* Global shortcut to switch between Fullscreen and a single Monitor.
* Tablet and touch area selection now takes the rotation settings into account.
* Added feature which allows the user to invert the scroll direction of the touch device.
* Many bugfixes in the background.


Note:
you must install a wacom-driver 0.20 or higher
See:
http://linuxwacom.git.sourceforge.net/git/gitweb.cgi?p=linuxwacom/xf86-input-wacom;a=summary




LicenseGPL
Source(source code 2.0.2)
openSUSE Factory
openSUSE 12.3
openSUSE 12.2
Send to a friend
Subscribe
Other  Apps  from Etric
Report inappropriate content



goto page: prev   1  2  3  4  5  6  7  8  9  10  11  12  13  14  15 

-

 How to lauch this

 
 by KozaG on: Nov 8 2011
 
Score 50%

This application looks nice. I just don't understand how to start it. Do I need some other program first?

I'm total new to Ubuntu and just switched from Windows.


Reply to this

-

 Re: How to lauch this

 
 by Etric on: Nov 17 2011
 
Score 50%

In the case you didn't found out yourself already.

The easiest way to start it, is by simply relogging into KDE to start the kded afterwards hotplugging and the systemsettings module are working.


Reply to this

-

 has the repo been moved?

 
 by perezmeyer on: Nov 16 2011
 
Score 50%

Hi! Has the repo been moved? I can't find a 1.3.5 tag in https://projects.kde.org/projects/extragear/base/wacomtablet/repository


Reply to this

-

 Re: has the repo been moved?

 
 by Etric on: Nov 17 2011
 
Score 50%

It is still at the same place, I've simply forgot to tag the repo. 1.3.5 is the current master


Reply to this

-

 Re: Re: has the repo been moved?

 
 by perezmeyer on: Nov 17 2011
 
Score 50%

Thanks Etric!


Reply to this

-

 wacomtablet

 
 by gerard82 on: Dec 2 2011
 
Score 50%

My OS is Gentoo Linux,been using it for 7 years.
I have a Wacom Bamboo Pen & Touch.
I used it in Gimp.First I used xsetwacom to set things the way I wanted them to work.
Then I came across this program and installed version 1.3.4.
I liked the way you could set everything in a gui.
But using it in Gimp-2.6.11 after a while it would act "funny" (unusable).
So I uninstalled it and used bash scripts instead.
When I discovered that there was an upgrade to 1.3.5 I tried again.
Alas,same problem.
Frankly I think it's KDE4.7.3's sorry state and not this program,but I'm not sure.
When I use the tablet with the bash scripts it keeps working fine.
Gerard.


Reply to this

-

 Re: wacomtablet

 
 by Etric on: Dec 4 2011
 
Score 50%

Sorry to hear it is not working correctly. At the end it is my fault not "KDE 4.7.3's current state".

Could you do me a little favour and try 1.3.5 again, when you see the error save the
~/.kde/share/config/tabletprofilesrc and send it to me together with your bash script that works correctly.


Reply to this

-

 Re: Re: wacomtablet

 
 by gerard82 on: Dec 5 2011
 
Score 50%

Well problem solved!
I reinstalled and then it happened again.
I searched for the ~/.kde4/share/config/tabletprofilerc file and noticed that its date was November 28.
So I deleted it and then using the nice GUI I set it the way I want it.
I have been using the tablet for hours now and no
"funny" things happened.
I have xf86-input-wacom-0.11.1 installed.
I want to thank you for your time and a very nice program.
Gerard.


Reply to this

-
.

 Ver. 1.3.3

 
 by achilleask on: Dec 18 2011
 
Score 50%

I keep trying to install the latest version (1.3.5) on Kubuntu 11.10 and it always shows version 1.3.3.
I tried both the source linked on this site and cloning git and it's the same.

I'm trying to get the latest version because one of the four buttons on my Bamboo CTH-460 isn't being recognised and doesn't work.

Any tips on what might be wrong?


Reply to this

-

 Re: Ver. 1.3.3

 
 by achilleask on: Dec 18 2011
 
Score 50%

I managed to get it working by editing the tabletprofilerc file. Apparently, one of the buttons (button 2) is recognized as button 5 instead and it's not available in the GUI. Setting it in the rc file manually did the trick.


Reply to this

-

 Re: Re: Ver. 1.3.3

 
 by Etric on: Dec 23 2011
 
Score 50%

Hi,

1.3.3 was correct, I simply forgot to update the versions string ;) Fixed this for the new update

The button mapping problem was a bag "bug" introduced by soem kernel changes with kernels >= 2.6.38

I'll upload a new version soon to fix this and some other bugs


Reply to this

-

 Re: Re: Re: Ver. 1.3.3

 
 by achilleask on: Dec 23 2011
 
Score 50%

Awesome, thanks for the reply.


Reply to this

-

 Mount & and profile error on startup

 
 by wbwb on: Jan 29 2012
 
Score 50%

This seems to be what may be a really helpful tool - so keep up the good work!!
Yet, after installation and (maybe only?) on first startup I experienced a very frightening behavior of my KDE (KDE Version 4.6.00 (4.6.0) "release 6" on openSUSE 11.4 (x86_64), with kernel 2.6.37.6-0.11-desktop):
After installation I logged out of KDE. After logging back in I got three consecutive error meassage boxes at the top of my desktop:
#1: that no default profile would exist for KDE wacom
#2: that my first partition could not be mounted
#3: that my second partition could not be mounted
The mesgs disappeared too quickly to memorize them literally.
After that I noticed a lot of HDisk action and my desktop remained completely empty.
After HDisk action stopped I killed the X-server because even my taskbar was gone. Then I could log in again to KDE ... The err msgs were there again, but I had at least my taskbar back. With that I could open my KDE personal settings, and found a 'Graphic Tablet' in the 'Input Devices'. I played around with some of the settings such as to 'Apply' them, as I hoped that this would generate the 'default profile' (?).
After logging in and out again, the err msgs seem to have disappeared - but I am not sure at all if I'm back to normal ...
So my questions are:
a) why at all would KDE generate err msgs of not being able to mount partitions after installation of KDE wacom
b) how can I make sure that err a) is gone now?
c) if err a) comes back, is there a fully working and clean 'make uninstall' in the Makefile of this app?


Reply to this

-

 Re: Mount & and profile error on startup

 
 by Etric on: Jan 31 2012
 
Score 50%

*oucht* that sounds serious.

Now the sad thing. I'm a bit lost about this behavior in general.

the #1 error is normal. After installation or whenever you attach a new unknown tablet to the system you do not have a profile (hence the message) and a default one will be created.

What happens at this point in the background:
* a new entry in ~/.kde/share/config/tabletsprofiles is created for your tablet device.
* to get good defaults I'll ask the current tablet what default values it has.

So the question is. can you reproduce this behavior? ( you should definitely backup before you try ;)
* Did you have your tablet in use via the standard approach and some xsetwacom calls?
* What tablet do you have in use? and which version of the wacom driver?

The error a) is frighten me a bit, but I access the harddrive only via KConfig method and this should definitely not produce these errors.

also c) make uninstall will remove the program but you have to delete the ~/.kde/share/config/tabletsprofiles by hand to remove this too (also if you wanna check if this happens every time you start the program the first time you only need to delete config file too).


Reply to this

-

 Re: Re: Mount & and profile error on startup

 
 by wbwb on: Feb 5 2012
 
Score 50%

I've been logging in and out of KDE now for a week, I have un/plugged my tablet frequently, and I have deliberately shut down my machine several times. The errors which I have described did not show up again, and I did not experience any unusual behavior of my system. So I hope(?) everything is fine again.

I understand that returning to the pre-installation situation and trying to reproduce the errors would be interesting. But I'm a reluctant to do so on this particular machine - it is my workhorse.

So, since there is no definite statement from you, like "..this behavior is due to so-and-so..", I'll rather leave things as they are.

Regarding my tablet and setup details:
- it is a very simple Wacom Graphire4 4x5
- I did not use xsetwacom to set it up. Actually I did not do any setup at all before installing your wacom KDE tool.

Regarding the drivers version
- in my kernel sources in /usr/src/linux-2.6.37.6-0.11/drivers/input/tablet/wacom.h I have:
#define DRIVER_VERSION "v1.52"
#define DRIVER_AUTHOR "Vojtech Pavlik <vojtech@ucw.cz>"
#define DRIVER_DESC "USB Wacom tablet driver"
#define DRIVER_LICENSE "GPL"

- and ~>modinfo wacom returns
filename: /lib/modules/2.6.37.6-0.11-desktop/kernel/drivers/input/tablet/wacom.ko
license: GPL
description: USB Wacom tablet driver
author: Vojtech Pavlik <vojtech@ucw.cz>
license: GPL
description: USB Wacom tablet driver
author: Vojtech Pavlik <vojtech@ucw.cz>
srcversion: 404C1FA94C2D4F3BB6E8D80
vermagic: 2.6.37.6-0.11-desktop SMP preempt mod_unload modversions


Reply to this

-

 KCM Wacom tablet left handed use

 
 by mak33 on: Mar 1 2012
 
Score 50%

I have installed the KDE Config Plugin for a wacom bamboo pen&touch 3rd gen. (usb id 056a:00de)

Situation:
My normal mouse is on the left side, with buttons switched for left hand use (so button 1 is mapped to 3 and the other way round). The pad is placed on the right side. Now the pen button mapping is wrong for the tablet and I can't configure the pen's tip to be button 3! The same for touch operation: gesture for "left click" produces right click and I can't reconfigure that, too.

Is this possible only by invoking the xsetwacom tool directly?

Any hints from wacom tablet users are welcome!

Regards
Martin


Reply to this

-

 Re: KCM Wacom tablet left handed use

 
 by Etric on: Mar 1 2012
 
Score 50%

You could try a call like
xsetwacom set "device name sytlus" Button 1 3

I have removed the feature to change the pen tip to anything else than left click a while ago, because it causes only trouble. Not sure this is fixed in the driver yet.

For the touch gestures I'm not sure how this would be done.
As far as I know, the gestures are hard coded.

Should you find a way to solve your problem via xsetwacom please let me know and I'll change this tool accordingly.


Reply to this

goto page: prev   1  2  3  4  5  6  7  8  9  10  11  12  13  14  15 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.