KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    Linux42.org    OpenSkillz.com   


- Content .- Fans (4) .- Knowledge Base  . 



KDE Service Menu

Score 78%



Link:  http://
Downloads:  125243
Submitted:  Mar 26 2004
Updated:  Apr 9 2009


!!!Important update!!

I've always thought we're all here open-minded and kind people. Seems like I was wrong.

Today I've received a letter from a man called Yassen Pavlov smack@vip.bg with the following text:

"I just wanted to let you know that I can't believe what an bitch you are. You asked for the guy who was maintaining the project you abandoned to give you admin rights and you never showed up again since he did so. Not even once... Thank you very much for that. I hope you'll die from cancer."

Well thanks a lot Yassen, this is what I actually need right now being a young mom with a little kid on my hands. See now, I'm here, are you happy?

OK, now to the point. I've switched to MacOS completely and have no platform to develop and test this script. It was a good experience and it was fun. I actually did not ever expected it would be such a success. But now I have to pass it over to somebody who wants to continue this development.
Please contact me jinjiru at jinjiru dot com if you want to take this project to your hands.

Mount ISO Image is an advanced script which allows to perform multiple operations with ISO, NRG (Nero Burning ROM), UDF (DVD), CUE/BIN, CCD/IMG/SUB (CloneCD), XDVDFS (XBOX) and MDF images.
Mount/unmount operations can be performed in two different ways: using kdesu or sudo. During the installation you'll be offered to choose a variant to use.
Note: If you prefer to use sudo, you should first choose to "Setup sudo config" in installation menu.

- German (by Markus Bloch)
- Italian (by marcosegato)
- Russian (by Jinjiru)
- Serbian (by Mladen Pejaković)
- Spanish (by Javier Ariza Rodríguez & Alberto Garcia)
- Turkish (by Atilla Öntaş)

If you submit translations, please, send them within the utf-8 text file to prevent encoding mistakes! All non utf translations will not be considered!

Bugs and translations
I really need your help with translations and feature requests - please send them pejakm at gmail dot com. If you sent any translations or suggestions some time ago - please resend them!
If you find any errors please do not hesitate to report them. If you have any suggestions or want to contribute in any manner - you're always welcome!

Important Notice!!!

Since this project appears to be abandoned, administrators have gave moderation control over this project to me, pejakm. I intend to continue and to improve this script as good as I can. If the original authors decide to continue their work I will happily give them this back.


0.9.5 - Thursday 3 January 2008

+ Feature: visual interaction improvement (added colors)
+ Feature: mountiso.sh is now installed in "$PREFIX/bin" (thanks goes to Musikolo for suggestion)
+ Code cleanup, minor improvements and fixes

0.9.4 - Thursday 3 January 2008

+ Feature: data extractor (extracts installation data, ie. *.desktop files and "mountiso.sh" script)
+ Feature: kdialog in creating images added; also added notice upon canceling image creation
+ Feature: Ability to disable notice upon successful mount, unmount and canceling image creation
+ Feature: mountiso.sh is now installed in "$PREFIX/local/bin"
+ Turkish translation added (by Atilla Öntaş)
+ Code cleanup - Monday 31 December 2007

+ German translation added (by Markus Bloch)

0.9.3 - Monday 31 December 2007

+ Feature: Added notice upon successful mount an unmount
+ Small bugfixes
+ Spanish translation added ( by Javier Ariza Rodríguez & Alberto Garcia)

0.9.2 - Thursday 27 December 2007

+ Feature: Mount/umount MDF images
+ Feature: Convert MDF to ISO (using 'mdf2iso' from http://mdf2iso.berlios.de)
+ Feature: Image menus are now in top level
+ Feature: Installer message if utility not installed
+ Fix: Fixed common "file is not an iso or is corrupted" error
+ Code cleanup (removed non utf and incomplete translations (remained: Italian, Russian; added: Serbian), etc.)

0.9.1 - Sunday 16 October 2005

+ Feature: Check ISO Type
+ Code cleanup

0.9 - Monday 24 May 2004

+ Feature: Mount CUE/BIN images (using 'cdemu' from http://cdemu.sourceforge.net)
+ Feature: Create XBOX images (using 'extract-xiso' from http://dwl.xbox-scene.net/~xbox/xbox-scene/tools/isotools/extract-xiso_v2.3.linux.x86.static.tgz)
+ Feature: Convert NRG images to ISO
+ Fix: Some ISO files created with WinISO have a non-standard "magic number" (thanks to Ignacio Serantes for info)
+ Fix: Menu for NRG, CUE/BIN, CloneCD images no longer suggests to "Manage *ISO*"

other(MountISO install script)
other(MountISO install script (mirror))
(More screenshots)
Send to a friend
Other  Apps  from prjanique
Report inappropriate content

goto page: prev  ... 8  9  10  11  12  13  14  15  16  17  18  19  20  21  22 



 by Superstoned on: Aug 30 2006
Score 50%

this should be in KDE4 by default... maybe ask for inclusion?

Reply to this


 Re: ej

 by Superstoned on: Aug 30 2006
Score 50%

btw it doesn't work for me... no matter if i use (with setup of course) kdesu or sudo, both tell me when i try to mount an image: ERROR: "/home/superstoned/Films/the sentinels/ss2g-sendvdr.iso" has data error! File might be of wrong type or corrupted.

but manually mounting the file works fine. ???

Reply to this


 Re: Re: ej

 by msak007 on: Sep 9 2006
Score 50%

I'm having the same exact problem. Images are mountable using terminal, but mounting using MountISO gives me an error that the image or data is corrupted.

Reply to this


 Re: Re: Re: ej

 by Superstoned on: Sep 9 2006
Score 50%

it might be that the location of the iso should not contain spaces. so /data/test.iso does work, /data and stuff/test.iso does not. not sure, but this was the problem for acetoneISO...

Reply to this


 Re: Re: Re: ej

 by brianpeterson on: Sep 13 2006
Score 50%

It's easy to fix. I tried emailing the author but it does not look like his email works...

The problem is how the type is being determined by the script (this program is mostly a large shell script).

Go here: /home/yourusername/.kde/share/apps/mountiso

Open in your editor (like kate) this file:

Then there are two places you need to change...

1. Around line 111 you will see a case statement with: 008008 change that to 000000

2 Around line 148 you will see a case statement with: 008008 change that to 000000

Now this will fix it. But it might allow for mounting files that are not really ISO... That might be bad. So don't try it...

Looking at his script it looks like it's working right. It's just that he has the wrong hex code for the type. I don't know why that is. Maybe the Kernel has changed something? Because the hex code for an ISO should be the same no matter what.

It's also possible he is getting the wrong line number in the header. That would mean the type code is not working right.

But I don't care! It works for me!

Reply to this


 don't work

 by warrob on: Oct 7 2006
Score 50%

With ANY iso I try it says:

ERROR: "openSuSE_10.1.iso" has data error! File might be of wrong type or corrupted.

but manually mounting with:

sudo mount -o loop openSuSE_10.1.iso /mnt/xxx/

successfully mount it.

Reply to this


 patch to solve

 by warrob on: Oct 7 2006
Score 50%

The problem is that mountiso do not proper recognize some images.

A simple way to bypass the problem is to replace some lines in the ~/.kde/share/apps/mountiso/mountiso.sh
Specifically you have to replace these lines:

# Anything else
rmdir "$MOUNTDIR"
err 7 "$1"

with these:

# Anything else

Reply to this


 can't install

 by cakarins on: Nov 5 2006
Score 50%

Hello. When I run ./install.sh, I get following error:
osis@osis-laptop:~/Desktop/mount-iso-0.9.1$ ./install.sh
./install.sh: 146: function: not found

Couldn't find !
Type the full path here or press "Ctrl+C" to abort:

Path of what I'm supposed to enter?

Reply to this



 by mithrilhall on: Nov 6 2006
Score 50%

I'm also getting this error:

./install.sh: 146: function: not found

Couldn't find !
Type the full path here or press "Ctrl+C" to abort:

Reply to this



 by HxA on: Nov 11 2006
Score 50%

I get the same error
I'm working on Ubuntu Edgy. There the problem occurs. This is because Edgy has as default the dash shell and no longer the bash shell. This is the case for other Debian based distributions too.

The MountIso script is not posix sh compatible and needs the bash to run.

So do the following.
Open the install.sh script with an editor (e.g. Kate) and replace all occurrences of

"/bin/sh" with "/bin/bash"

This should fix the problem.
The problem is because Debian changed it's default shell from bash do dash and all scripts that are not fully Posix compatible may not work as expected. Whenever you get errors executing a script try to run it explicitly with

> bash skriptname.sh

This should work.
- HxA

Reply to this


 Re: Error

 by tony134340 on: Nov 26 2006
Score 50%

Thanks, I also got the error since I moved to Kubuntu Edgy but I just did the "bash install.sh" part and all is good. Great script. I wish it was in by default.

Reply to this

goto page: prev  ... 8  9  10  11  12  13  14  15  16  17  18  19  20  21  22 

Add commentBack

How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

 Who we are
More about us
Frequently Asked Questions
Updates on identi.ca
Updates on Twitter
Content RSS   
Events RSS   

Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Sponsor us
Report Abuse

Copyright 2003-2016 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.