-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (63) .- Knowledge Base  . 

Veromix - volume control / soundmenu

   0.18.3  

Plasmoid Script

Score 86%
Veromix - volume control / soundmenu
zoom


Veromix - volume control / soundmenu
zoom


Veromix - volume control / soundmenu
zoom


Homepage:  Link
Downloads:  7112
Submitted:  Dec 7 2009
Updated:  Jun 14 2012

Description:

Veromix is a mixer for the Pulseaudio sound server.

Features:
- Media player controls (aka nowplaying)
- per application voluem control (replay & record)
- global hotkeys
- can life in system tray
- switch sound card profiles (for ex. from regular to HDMI)
- control LADSPA effects (equalizer and other effects)
- keyboard navigation (use Tab- and Arrow-keys)

Quickstart:
- middle click on panel icon mutes the default output
- mouse wheel over panel icon increases/decreases volume
- drag and drop playback streams between different output devices
- right click context menu:
-- kill playback streams
-- set default output device
-- set per channel volume
-- switch sound card profiles
- assign hotkeys
- click the add icon (bottom-right) to add a new effect
(drag and drop playback stream to the effect sink)


More Info:
- Howto: http://www.omgubuntu.co.uk/2012/02/how-to-increase-volume-over-100-in-kde/
- YouTube: http://www.youtube.com/watch?v=fph8xqsJd_g
- Review: http://padoca.wordpress.com/2011/03/18/kmix-veromix-qml-and-other-stories/
- Review: http://techlaze.com/2011/08/best-plasma-widgets-kde/

FAQ:
- Disable KMix: Set "AutoStart=false" in "[Global]" section of .kde/share/config/kmixrc

Requirements:
- plasma-scriptengine-python
- python-xdg
- python-qt4-dbus
- pulseaudio
- swh-plugins / ladspa-swh-plugins (for equalizer and other effects)
- ladspa-sdk / ladspa (dynamically detect installed ladspa plugins)

Changelog: http://code.google.com/p/veromix-plasmoid/source/browse/Changelog

Packages:
- Debian: http://packages.debian.org/plasma-widget-veromix
- Arch: https://aur.archlinux.org/packages.php?ID=60883
- openSUSE: https://build.opensuse.org/package/show?package=plasmoid-veromix&project=KDE%3AExtra


Please report bugs/wishes here: http://code.google.com/p/veromix-plasmoid/issues/list




LicenseGPL
Send to a friend
Subscribe
Other  Apps  from nik3nt3
Report inappropriate content



goto page:  1  2  3  4  5  6  7  8 ...

-
.

 This is awesome.

 
 by Saleel on: Mar 23 2010
 
Score 50%

Is there anyway I can add this inside the system tray, like the weather icon?


Reply to this

-

 Re: This is awesome.

 
 by nik3nt3 on: Mar 23 2010
 
Score 50%

Thanks for the tip: Enjoy 0.4!


Reply to this

-

 Thanks

 
 by BLeAm on: Mar 23 2010
 
Score 50%

Cool, thanks for your great work!


Reply to this

-

 Kudos!

 
 by mrsaccess on: Mar 23 2010
 
Score 50%

Very nice and useful plasmoid although not perfect yet. I hope you will get some help from KDE devs since I believe this plasmoid should be included in the KDE SC.


DO NOT PANIC
Reply to this

-

 kde compatibility

 
 by Syvolc on: Mar 23 2010
 
Score 50%

"place it in your systemtray"

so, it's ok from KDE SC 4.4 ? not for 4.3 ?


Syvolc
Reply to this

-
.

 Re: kde compatibility

 
 by Vistausss on: Mar 23 2010
 
Score 50%
VistausssVistausss
Ubukuntu/Ubu ntu-NL
Home
-
Heimen Stoffels -3

Ubukuntu/Ubuntu-NL
Netherlands, Almere
Last visit Aug 2 2012
1 Friends
5 Groups

More info
Send a message
Add as friend
Other contents
--

Yes. Widgets in System Tray is supported since 4.4.0

So get yourself an upgrade! :)


Posted by Vistausss.
Reply to this

-
.

 Re: Re: kde compatibility

 
 by Syvolc on: Mar 24 2010
 
Score 50%

Ok, thx.

Very good job, it's the accomplishment of the brainstorm : KVolumoid : http://kde-look.org/content/show.php/KVolumoid?content=108842

bye


Syvolc
Reply to this

-

 utf-8

 
 by WMP on: Mar 27 2010
 
Score 50%

Can you make support to utf-8 chart in channel name?


Reply to this

-

 Re: utf-8

 
 by nik3nt3 on: Mar 30 2010
 
Score 50%

yepp - fixed -> 0.5


Reply to this

-

 Unable to run with KDE4 trunk

 
 by tittiatcoke on: Mar 30 2010
 
Score 50%

Hi,

I am running KDE4 trunk and I am unable to use this plasmoid. I can install it successfully, but it doesn't show up in my pkasmoid list. Strangely enough I can run it with plasmoidviewer veromix-plasmoid and it display fine.

Adding it manually to plasma-desktop-appletsrc, delivers the following error message :

plasma-desktop(15391)/libplasma Plasma::Applet::load: offers is empty for "veromix-plasmoid"
plasma-desktop(15391)/libplasma Plasma::ContainmentPrivate::addApplet: Applet "veromix-plasmoid" could not be loaded.
plasma-desktop(15391)/libplasma Plasma::AppletPrivate::init: Check your constructor! You probably want to be passing in a Service::Ptr or a QVariantList with a valid storageid as arg[0].

and the plasmoid is not shown.

At this moment I am not sure if this indicates a bug in plasma from trunk or that trunk requires something additionally from the plasmoid. At the moment I am checking with the plasma team, but would appreciate also your feedback.

Thanks

Regards

Raymond


Reply to this

-

 Re: Unable to run with KDE4 trunk

 
 by nik3nt3 on: Mar 30 2010
 
Score 50%

Hy

idea #1
-------
Are other python-plasmoids working (on the desktop/panel)? I ask this because i get:

plasmoidviewer(4840)/libplasma Plasma::Applet::load: we have a script using the "python" API

and you got:

plasma-desktop(15391)/libplasma Plasma::Applet::load: offers is empty for "veromix-plasmoid"



idea #2
-------
Is it shown in the list of available widgets for the notifications-area/systray (settings of notification-area "Plasma Widgets")?


Maybe something is wrong with the metadata.desktop. I used

X-Plasma-NotificationArea=true

maybe TRUNK requires that i explicitly allow it to add on the desktop


-----
I also get the warning about the constructor, e.g.

plasmoidviewer(4840)/libplasma Plasma::AppletPrivate::init: Check your constructor! You probably want to be passing in a Service::Ptr or a QVariantList with a valid storageid as arg[0].
-----

/nik


Reply to this

-

 Re: Re: Unable to run with KDE4 trunk

 
 by tittiatcoke on: Mar 30 2010
 
Score 50%

Hi Nik,

I got a couple of steps further. I have it now visible in my plasmoid list. However I needed to change the desktop file and Change the type from Plasma/PopupApplet to Plasma/Applet. This made it at least visible.

If I now add it to the desktop/panel, I get the following log:


plasma-desktop(27672) Plasma::WidgetExplorer::addApplet: "veromix-plasmoid" ()
plasma-desktop(27672)/libplasma Plasma::Applet::load: we have a script using the "python" API
plasma-desktop(27672)/libplasma Plasma::Package::filePath: "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/config/default-configrc" does not exist
plasma-desktop(27672)/libplasma Plasma::AppletPrivate::setupScriptSupport: setting up script support, package is in "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/" which is a "Plasmoid" package , main script is "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/code/main.py"
plasma-desktop(27672)/libplasma Plasma::Package::filePath: "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/locale" does not exist
plasma-desktop(27672)/libplasma Plasma::Package::filePath: "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/config/main.xml" does not exist
plasma-desktop(27672)/libplasma Plasma::Package::filePath: "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/ui/config.ui" does not exist
Loaded library : libpulse.so
veromix icon installed

Which looks better, however I get a plasmoid with the Red/White cross in it. I guess this is due to the missing stuff indicated in the log.

Regards
Raymond


Reply to this

-

 Re: Re: Re: Unable to run with KDE4 trunk

 
 by nik3nt3 on: Mar 30 2010
 
Score 50%

Hy Raymond

Bad news: Plasma/PopupApplet support was introduced in 4.3: I found that solution by try and error (and looking at the javascript code ).

With your change the widget(the sliders) of the plasmoid are not corretly added to the plasmoid (because it depends on PopUpApplet)... so I understand that it is not working.

Is there a class PopUpApplet defined in ython on your system (in 4.3 it is not). From the python view this would make sense (e.g. make a subclass of Plasma.PopUpApplet instead of Plasma.Applet).

On my system Plasma.Applet is defined in: /usr/share/pyshared/PyKDE4/plasmascript.py
Dou you have a PopUpApplet there?

/nik


Reply to this

-

 Re: Re: Re: Re: Unable to run with KDE4 trunk

 
 by tittiatcoke on: Mar 30 2010
 
Score 50%

Hi

I have checked the file that you mentioned (with openSUSE it is located under the python directory), but I can't find any reference there to PopupApplet. I also checked the same file located on svn.kde.org, but there it is also not mentioned.

Which distribution are you running ? Either with 4.5 it disappears again, or your distribution made some additions.

Regards

Raymond


Reply to this

-

 Re: Re: Unable to run with KDE4 trunk

 
 by tittiatcoke on: Mar 30 2010
 
Score 50%

Hi Nik,

I got a couple of steps further. I have it now visible in my plasmoid list. However I needed to change the desktop file and Change the type from Plasma/PopupApplet to Plasma/Applet. This made it at least visible.

If I now add it to the desktop/panel, I get the following log:


plasma-desktop(27672) Plasma::WidgetExplorer::addApplet: "veromix-plasmoid" ()
plasma-desktop(27672)/libplasma Plasma::Applet::load: we have a script using the "python" API
plasma-desktop(27672)/libplasma Plasma::Package::filePath: "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/config/default-configrc" does not exist
plasma-desktop(27672)/libplasma Plasma::AppletPrivate::setupScriptSupport: setting up script support, package is in "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/" which is a "Plasmoid" package , main script is "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/code/main.py"
plasma-desktop(27672)/libplasma Plasma::Package::filePath: "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/locale" does not exist
plasma-desktop(27672)/libplasma Plasma::Package::filePath: "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/config/main.xml" does not exist
plasma-desktop(27672)/libplasma Plasma::Package::filePath: "/home/hq000006/.kde4/share/apps/plasma/plasmoids/veromix-plasmoid/contents/ui/config.ui" does not exist
Loaded library : libpulse.so
veromix icon installed

Which looks better, however I get a plasmoid with the Red/White cross in it. I guess this is due to the missing stuff indicated in the log.

Regards
Raymond


Reply to this

-

 Re: Re: Re: Unable to run with KDE4 trunk

 
 by tittiatcoke on: Mar 30 2010
 
Score 50%

As addition, I checked the PidginPlasmoid (python based as well) and this one is working fine. It also contains the missing directories/files.

From this plasmoid I got the idea of changing the things in the desktop file.


Reply to this

-

 Re: Re: Re: Re: Unable to run with KDE4 trunk

 
 by nik3nt3 on: Mar 30 2010
 
Score 50%

hi rayond

im running kubuntu 9.10 with KDDE 4.3 from the backports repository.

About the file: Sorry I just made a guess - because it would make more sense in python to subclass PopUpApplet than to enable that(PopUp) functioality in the metadata.desktop file.

The pidgin-plasmoid crashes plasma-desktop (in plasmoidviewer it works).

Is the pidgin-plasmoid working in your panel (popUp)?

/nik


Reply to this

-

 Re: Re: Re: Re: Re: Unable to run with KDE4 trunk

 
 by nik3nt3 on: Mar 30 2010
 
Score 50%

wrong info: I'am running 4.4. with backports...
I will have a look at pidgin-plasmoid later...


Reply to this

-

 Re: Re: Re: Re: Re: Unable to run with KDE4 trunk

 
 by tittiatcoke on: Mar 30 2010
 
Score 50%

Hi,

Ok. I just checked pidgin-plasmoid and this does not work as Icon in the panel. At least not something that Pop's up when clicked on.

I will see if I get somewhere in the #plasma IRC channel, otherwise the bug might appear when 4.5 is released. Or maybe against that time it is fixed.

Thanks for your helo.


Reply to this

-

 Re: Re: Re: Re: Re: Re: Unable to run with KDE4 tr

 
 by nik3nt3 on: Apr 15 2010
 
Score 50%

hi

do you have good news for me or is it still not working with TRUNK?

/nik



goto page:  1  2  3  4  5  6  7  8 ...

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.