-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans  .- Knowledge Base  . 

Kumula Business Suite

   1.0 (Base)  

KDE Business Software

Score 82%
Kumula Business Suite
zoom


Kumula Business Suite
zoom


Kumula Business Suite
zoom


Link:  http://www.kumula.org
Minimum required   PyKDE/PyQt
Downloads:  10684
Submitted:  Apr 13 2004
Updated:  May 6 2006

Description:

Kumula is designed to become a complete software suite for business needs. Started as software for consultants, it is flexible enough to be used by almost any class of business. It provides a small CRM ("Clients") and some other applications. Everybody is invited to use it or enhance it.

Installation:
Look at the INSTALL file in the package or visit www.kumula.org for a detailed installation description.




Changelog:

This is the last stable release before I'll port it to Qt4 (as "Kumula2"), so I feel free to call it "1.0". :-)

The whole suite is becoming bigger and bigger, so now it's time to split it. This is the base package with the central Kumula library and the most important applications. The package contains the following programs:

- BizCalc:
The modular designed calculator tool, coming with a spartanic RPN calculator and an unit conversion module

- Clients:
The client/customer management application, with many improvements (like individual client attributes) and the modules "Info" (logo+description), "Contacts" (for managing contact persones, addresses and communication data) and "Tickets" (for letting the users talk about a client like on a web forum)

- Configurator:
The central configuration utility, to setup the database access and the user interface (menus, icons, ...) of all Kumula applications.

- Users:
A small tool for managing the people using Kumula.

Further application will be provided in separate packages for easier maintenance and faster bugfixes and updates.




LicenseLGPL
Source(kumula-base-1.0)
Send to a friend
Subscribe
Other  Apps  from KumulaTeam
Report inappropriate content



goto page: prev   1  2  3  4 

-
.

 postgres support?

 
 by burzin on: Dec 12 2004
 
Score 50%

the sql script provided to install kumula does not work with postgres sql. Is it worth altering to make it work, or does kumula only support mysql?


Reply to this

-

 Re: postgres support?

 
 by KumulaTeam on: Dec 14 2004
 
Score 50%

We hoped that the sql scripts would work with any sql database, but we tested them only with MySQL. Of course, because Qt supports other databases such as PostgreSQL or SQLite, it would be nice if the scripts would work with these databases, too.

If you know WHY the scripts don't work, please give us a hint how we could make them more compatible for future releases.


Reply to this

-

 Re: Re: postgres support?

 
 by burzin on: Dec 14 2004
 
Score 50%

psql errors in CREATE TABLE:
* uses double quote characters " instead of backquote `
Fix: tr
* doesn't like TYPE=MyISAM
* doesn't like int(11)
Fix?
int
* KEY `IDX_name` (`name`)
Fix?
create index name on countries;
* AUTO_INCREMENT=240
Fix?
create sequence countries_id increment 240;


Reply to this

-
.

 Re: Re: postgres support?

 
 by burzin on: Dec 15 2004
 
Score 50%

I fixed the four scripts to run in psql, but running bin/configurator gives errors:

Traceback (most recent call last):
File "/opt/kumula/bin/configurator", line 37, in ?
kumula.MainWin = KConfigWindow()
File "/opt/kumula/bin/../lib/KumulaMainWindow.py", line 35, in __init__
self.createUI()
File "/opt/kumula/bin/../lib/configurator/ConfigWindow.py", line 133, in createUI
self.clearWState(Qt.WState_Polished)
AttributeError: WState_Polished


Reply to this

-

 Re: Re: Re: postgres support?

 
 by KumulaTeam on: Dec 15 2004
 
Score 50%

I guess this error is caused by an outdated version of PyQt (for example, the version 3.5 had this bug). Please upgrade to at least PyQt 3.10, the current version is 3.13.

You should have installed actual versions of Qt and Python, too.


Reply to this

-

 configurator error

 
 by redwood64 on: Feb 21 2005
 
Score 50%

kumula-2004.09
PyQt-3.14
qt-x11-free-3.3.4
Python-2.4
kde-3.3.2
mysql-4.1.10
sip-4.2
linux-2.6.10

After compiling everything without
errors, when I run configurator I get:

# /opt/kumula/bin/configurator
Traceback (most recent call last):
File "/opt/kumula/bin/configurator", line 37, in ?
kumula.MainWin = KConfigWindow()
File "/opt/kumula/bin/../lib/KumulaMainWindow.py", line 35, in __init__
self.createUI()
File "/opt/kumula/bin/../lib/configurator/ConfigWindow.py", line 112, in createUI
self.cbAppPDF.setSizePolicy(QSizePolicy(7,0,0,0,self.cbAppPDF.sizePolicy().hasHeightForWidth()))
TypeError: argument 1 of QSizePolicy() has an invalid type

self.cbAppPDF.setSizePolicy(QSizePolicy(7,0,0,0,self.cbAppPDF.sizePolicy().hasHeightForWidth()))
TypeError: argument 1 of QSizePolicy() has an invalid type


Reply to this

-

 Re: configurator error

 
 by KumulaTeam on: Feb 27 2005
 
Score 50%

Which distro do you use? I use Gentoo on two machines, and there are no problems with qt-3.3.4-r1 + PyQt-3.13, but after upgrading to qt-3.3.4-r2 + PyQt-3.14, I get the same error...

I will try to understand this, if you get any explanation please post it here...


Reply to this

-

 Re: Re: configurator error

 
 by redwood64 on: Feb 28 2005
 
Score 50%

I compile from source using sorcerer.
I'm competent with c but alas not with c++.
QSizePolicy() seems to be defined in
qt-x11-free-3.3.4/src/kernel/qsizepolicy.h


Reply to this

-

 Re: Re: Re: configurator error

 
 by KumulaTeam on: Mar 1 2005
 
Score 50%

Thank you, I know where QSizePolicy is defined and which function it has. But I wonder why it works with PyQt-3.13, but not with PyQt-3.14 anymore. On the PyQt changelog there are no regarding differences.

Also it's curious because this code is generated by pyuic, the PyQt pendant for uic, which generates the code from Qt Designer files...

I will test it out, maybe there are other circumstances causing this problem.


Reply to this

-

 Re: configurator error

 
 by KumulaTeam on: Mar 5 2005
 
Score 50%

GOOD NEWS! I've found out why this error occurs. Obviously, the way QSizePolicy() is handled had changed between the PyQt versions. The code has to be changed from

QSizePolicy(7, 0, ...) to
QSizePolicy(QSizePolicy.Expanding, QSizePolicy.Fixed, ...)

Or, maybe the better way for all, wait for the next Kumula release (in a few days) where the problem is fixed. We're already in the testing period.


Reply to this

-

 Re: Re: configurator error

 
 by PeterC on: Dec 1 2005
 
Score 50%

Hi

I posted a similar error on the wiki

./configurator
Traceback (most recent call last):
File "./configurator", line 14, in ?
import kumula
File "./../lib/kumula.py", line 15, in ?
from qt import *
ImportError: No module named qt

I'm using FC4 and qt is installed will the next release fix this?


regards

PeterC

Reply to this

-

 Re: Re: Re: configurator error

 
 by KumulaTeam on: Dec 3 2005
 
Score 50%

Hi Peter, I guess you don't have PyQt installed. PyQt is the interface between Qt and Python; if it's not installed, Python cannot import the Qt modules. Try to install PyQt from the Fedora repository or visit http://www.riverbankcomputing.co.uk/pyqt


Reply to this

-

 Re: conf

 
 by PeterC on: Dec 3 2005
 
Score 50%

Oh Bum!

That'll teach me for being a smart ar...

Configurator now works although it is refusing to connect to the database for some reason I get this error message from the terminal;

[root@lightstar bin]# ./configurator
QSqlDatabase: QMYSQL3 driver not loaded
QSqlDatabase: available drivers:

:(


Regards
PeterC

Reply to this

-

 Re: conf

 
 by PeterC on: Dec 3 2005
 
Score 50%

Hooray
sorted it out I didn't have qt-mysql installed.

Thanks for your patience.


Regards
PeterC

Reply to this

-
.

 eGroupware + Kumla

 
 by whieber on: Dec 3 2005
 
Score 50%

Seems to me that it would be excellent to merge eGroupware + Kumla + oscommerce together. Maybe not merge them but make them have integrated functions so that one could operate an entire business with these tools integrated easily. Just a thought.

Walter


Buy Pumps from me I support Linux! http://www.thepumpbox.com Wilden, Goulds, Roper, March, IMO, Milton Roy, Pulsafeeder, and others too.
Reply to this

-
.

 KMyMoney also

 
 by whieber on: Dec 3 2005
 
Score 50%

Kumula and KMyMoney would also make a nice pair.

http://www.kde-apps.org/content/show.php?content=10180
WAlter


Buy Pumps from me I support Linux! http://www.thepumpbox.com Wilden, Goulds, Roper, March, IMO, Milton Roy, Pulsafeeder, and others too.
Reply to this

-

 Kumula

 
 by KDE-newbie on: Feb 9 2006
 
Score 50%

...or even all three of them integrating... imagine that....


Reply to this

-

 a bit offtopic

 
 by dec0ding on: Feb 13 2006
 
Score 50%

but what is the font u are using on the screenshot? It looks great...I thought it is Tahoma but I put on my system and it looks awful :S ... how do u put shadow on it?

Good, thanks and sorry !


(Crazy) since 1983
Reply to this

-

 Re: a bit offtopic

 
 by KumulaTeam on: Feb 15 2006
 
Score 50%

Yes, it IS Tahoma, but when it looks awful on your computer, play with your anti-aliasing settings. Anyway, the shadow comes from the "Active Heart" theme, which can be found at kde-look.org (or just "emerge activeheart" when using Gentoo).


Reply to this

-

 Re: Re: a bit offtopic

 
 by dec0ding on: Feb 17 2006
 
Score 50%

thanks...


(Crazy) since 1983
Reply to this

goto page: prev   1  2  3  4 

Add commentBack






-
-
Do you like or dislike Ubuntu Unity?
 Yes, unity is alien technology!
 It is less confusing than Gnome 3 default, shell.
 Granny thinks it is much more usable than Gnome 2
 Canonical is embarrasing itself with this split project
 Gnome 3 default shell is much better
 I dislike Unity, Gnome 3 default shell is alien technology!
 None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.