-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (7) .- Knowledge Base (1) . 

QuadKonsole4

   0.4.4  

KDE System Tool

Score 67%
QuadKonsole4
zoom


QuadKonsole4
zoom


other:  Link
Minimum required   KDE 4.x
Downloads:  439
Submitted:  Apr 22 2011
Updated:  Nov 13 2011

Description:

QuadKonsole4 is a KDE4 port of QuadKonsole (http://kde-apps.org/content/show.php/QuadKonsole?content=22482).

QuadKonsole4 tries to provide a keyboard focused interface to multiple KParts in one window. The default setting opens four Konsole KParts and defines some shortcuts for navigation. Because there is only one window decoration, it "wastes" a bit less screen space and all KParts are aligned automatically. You can open and close KParts at runtime using keyboard shortcuts or detach any KPart from the main window. Detaching a KPart will open a new QuadKonsole4 that can be used exactly like the original.

To use other KParts within QuadKonsole4 you can either open a new URL using the URL bar (default: Ctrl+Shift+G) or have QuadKonsole4 find another KPart for the current URL use KDE's global settings. Example: Create some tarball or other file using your favoutie commands, switch to dolphin and attach the new file to an email using drag'n'drop.

New features:
* Adding/removing/resizing of Konsole parts
* Supports embedding of other KParts (dolphin, kate, gwenview, ...)
* A few config options

Many thanks to pejakm and Pavel Fric for translating and to Michael Feige for a lot of good ideas!

Version 0.4.2 and later support both the old huge and the new simple context menus. For the new menus, you need to have libkonq (and -dev) packages installed at build time. The Debian packages are built with libkonq.




Changelog:

0.4.4
* Added Konqueror's sidebar to show history and bookmarks
* Added shortcut to "maximize" a single view within a main window
* Show the progress when opening a URL
* Open URLs from outside within an existing window
* Session management includes open views and URLs

0.4.3
* Support for web shortcuts
* New application QKRemote to control a running QuadKonsole4
* Configurable layout orientations

0.4.2
* Simpler context menus (requires libkonq)
* History support
* Tab bar for open views

0.4.1
* Fixes opening of remote files
* Fixed build with KDE < 4.6

0.4
* Added support for other KParts
* Serbian translation

0.3
* Support for X sessions includes number and size of Konsole parts
* Added detach on quit

0.2.1
* Fixed installation (thanks to symbianflo)
* Added --cmd command line option
* Added sloppy focus option




LicenseGPL
Source(quadkonsole4-0.4.4.tar.bz2)
Debian(quadkonsole4_0.4.4-1_amd64.deb)
Debian(wheezy_quadkonsole4_0.4.4-1_amd64.deb)
Send to a friend
Subscribe
Other  Apps  from kbo
Report inappropriate content



goto page: prev   1  2  3 

-
.

 rpm for mandriva

 
 by symbianflo on: Aug 18 2011
 
Score 50%
symbianflosymbianflo
MandrivaUser s.ro / Rosalinux.ro
Home
-
symbian Flo 130

MandrivaUsers.ro / Rosalinux.ro
Italy, Pordenone
Last visit 12 hours ago
2 Friends
1 Groups

More info
Send a message
Add as friend
Other contents
--

due the new klass required ,GVM is right, wont build on kde < 4.6.0, dropped gwenview-kpart I've manage to build it sorry but this time only for mandriva 2010.2 and only x86_64.
and less futures then the source allows it :(

On suse can't build it sorry.Same problem...


Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

Reply to this

-

 Re: Re: New release 0.4 incompatible with KDE < 4

 
 by GvM on: Aug 18 2011
 
Score 50%

@kbo
> Unfortunately there are 2 features that require a newer KDE release.
> I will try to change both, so QuadKonsole4 will work on older KDE releases, too.
That indeed would be the best thing...
However, I was not arguing against your implementation choice: in principle, if you really need the new classes, you can also decide to break the compatibility with rather old KDE versions (4.5.x is two release old now... but is still used in not-so-old distros).
My point is simply that, in that case, you should prominently tell the thing to the user of your source files or, at least, indicate - if possible - how to make the new source compatible with older kdelibs (a build time switch?...).


Reply to this

-
.

 rpms

 
 by symbianflo on: Aug 18 2011
 
Score 50%
symbianflosymbianflo
MandrivaUser s.ro / Rosalinux.ro
Home
-
symbian Flo 130

MandrivaUsers.ro / Rosalinux.ro
Italy, Pordenone
Last visit 12 hours ago
2 Friends
1 Groups

More info
Send a message
Add as friend
Other contents
--

Thx for adding testing/serching class feature,
rpms for mandriva and for suse updated


Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

Reply to this

-

 what is it

 
 by thstaerk on: Sep 12 2011
 
Score 50%

hey, I do not know quadKonsole. You explain that quadkonsole4 is a port of quadKonsole. Could you elaborate for people who do not know quadKonsole?

thanks

Thorsten


Attention! Dates in calendar are closer than they appear.
Reply to this

-

 Re: what is it

 
 by kbo on: Sep 13 2011
 
Score 50%

Probably there are many people around that don't know QuadKonsole. I just tried to describe it, but corrections or improvements are always welcome.


Reply to this

-
.

 Re: Re: what is it

 
 by thstaerk on: Sep 14 2011
 
Score 50%

good, thanks!


Attention! Dates in calendar are closer than they appear.
Reply to this

-
.

 KDE 4.7 libkonq5 conflict

 
 by brucew on: Sep 12 2011
 
Score 50%
brucewbrucew
Alcohol Justice
Home
-
Bruce Wolfe 1

Alcohol Justice
United States of America, San Rafael
Last visit Apr 4 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

The Debian package will not install without libkonq5. Installing libkonq5 uninstalls KDE 4.7 workspace if using GUI, ie, Kpackage, Synaptic, etc.


Reply to this

-
.

 Re: KDE 4.7 libkonq5 conflict

 
 by brucew on: Sep 12 2011
 
Score 50%
brucewbrucew
Alcohol Justice
Home
-
Bruce Wolfe 1

Alcohol Justice
United States of America, San Rafael
Last visit Apr 4 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

UPDATE: I have 4:4.7 installed and it still asks for libkonq5 though libkonq5-dev is masked under 4:4.7. Upon installing libkonq-dev and trying to install QuadKonsole4 again, it still throws an error:
"Error: Dependency is not satisfiable: libkonq5 (>=4:4.3.4)

Please advise


Reply to this

-

 Re: Re: KDE 4.7 libkonq5 conflict

 
 by kbo on: Sep 13 2011
 
Score 50%

Which Debian version are you using? I only installed the package on a Squeeze without upgrading anything. The included version of libkonq5 (4.4.5-2) should work.


Reply to this

-

 Re: Re: Re: KDE 4.7 libkonq5 conflict

 
 by brucew on: Sep 16 2011
 
Score 50%
brucewbrucew
Alcohol Justice
Home
-
Bruce Wolfe 1

Alcohol Justice
United States of America, San Rafael
Last visit Apr 4 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Not Debian, Kubuntu 11.04. Should work, no?


Reply to this

-

 Re: Re: Re: Re: KDE 4.7 libkonq5 conflict

 
 by kbo on: Sep 16 2011
 
Score 50%

Unfortunately, I have no Kubuntu to test it. But it seems as if the dependency information of my package is incompatible with Kubuntu's package management. Could you try to compile a package on your system? The easiest way is:

git clone git://kb.ccchl.de/quadkonsole4
cd quadkonsole4
dpkg-buildpackage

Please send me the package or at least the control file if the build succeeds.


Reply to this

-

 Re: Re: Re: Re: Re: KDE 4.7 libkonq5 conflict

 
 by brucew on: Sep 16 2011
 
Score 50%
brucewbrucew
Alcohol Justice
Home
-
Bruce Wolfe 1

Alcohol Justice
United States of America, San Rafael
Last visit Apr 4 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Okay, seems I got it installed that way but not without some bumps in the road.

Both CDBS and QUILT needs to be installed as they are dependencies.

At the very end though are these messages:
Quote:
dh_link -p quadkonsole4
dh_md5sums -pquadkonsole4
dh_builddeb -pquadkonsole4 -- -Zlzma
dpkg-deb: building package `quadkonsole4' in `../quadkonsole4_0.4.2-1_amd64.deb'.
signfile quadkonsole4_0.4.2-1.dsc
gpg: skipped "Karsten Borgwaldt <kb@kb.ccchl.de>": secret key not available
gpg: [stdin]: clearsign failed: secret key not available

dpkg-genchanges >../quadkonsole4_0.4.2-1_amd64.changes
dpkg-genchanges: including full source code in upload
dpkg-source --after-build quadkonsole4
dpkg-buildpackage: full upload; Debian-native package (full source is included)
dpkg-buildpackage: warning: Failed to sign .dsc and .changes file


I'll send you the build stdout but don't see a place to put attachments here. Send me a PM as to where I can send it to you.


Reply to this

-

 Re: Re: Re: Re: Re: Re: KDE 4.7 libkonq5 conflict

 
 by kbo on: Sep 16 2011
 
Score 50%

Thanks for all the information!

It seems that at least Kubuntu has changed the name of the package containing libkonq to "libkonq5abi1". So, my Debian package will simply not work on Kubuntu :(

I will have a look at the new packages and perhaps there will be another Debian/Kubuntu package with the next release.



-

 Re: Re: Re: Re: KDE 4.7 libkonq5 conflict

 
 by kbo on: Oct 1 2011
 
Score 50%

The new package for Debian Wheezy should work on Kubuntu and other Debian based distributions shipping KDE > 4.6.1 and libkonq5abi1. Could someone test it?


Reply to this

-
.

 rpm's for mandriva

 
 by symbianflo on: Oct 2 2011
 
Score 50%
symbianflosymbianflo
MandrivaUser s.ro / Rosalinux.ro
Home
-
symbian Flo 130

MandrivaUsers.ro / Rosalinux.ro
Italy, Pordenone
Last visit 12 hours ago
2 Friends
1 Groups

More info
Send a message
Add as friend
Other contents
--

rpm's for mandriva updated
http://mrb.mandrivausers.ro/index.php?search_for=quadkonsole4&search_submit=Search

thx man


Linus Torvalds only has to enter a room, and every Windows computer in it segfaults instantly.
http://video.linuxfoundation.org/video/1057

Reply to this

goto page: prev   1  2  3 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.