-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans  .- Knowledge Base  . 

cb2Bib

   1.4.9  

KDE Scientific

Score 82%
cb2Bib
zoom


Link:  Link
Depends on  Qt 4.x
Downloads:  5683
Submitted:  Jul 6 2004
Updated:  Nov 5 2012

Description:

The cb2Bib is a tool for rapidly extracting bibliographic references from email alerts, journal web pages, and PDF files. It facilitates the capture of single references from unformatted and non standard sources. Output references are written in BibTeX. Article files can be easily linked and renamed by dragging them onto the cb2Bib window. Additionally, it permits editing and browsing BibTeX files, citing references, searching references and the full contents of the referenced documents, inserting bibliographic metadata to documents, and writing short notes that interrelate several references.




Changelog:

This maintenance release fixes an issue with temporary files when operated remotely, adds some code cleanups and speedups, and sets minor improvements in keyword extraction.




LicenseGPL
Source
(Packages)
Send to a friend
Subscribe
Other  Apps  from constans
Report inappropriate content



goto page: prev   1  2  3 

-

 A couple of problems

 
 by paulatz on: Apr 4 2006
 
Score 50%

First I wish to thank you for your great software, it is definetly faster than writing bib at hand.

First of I have added this lines to my abbreviations:

PR|Phys. Rev.|Physical Review
PR|Phys. Rev. Lett.|Physical Review Letters
PR|Phys. Rev. A|Physical Review A
PR|Phys. Rev. B|Physical Review B

Second: network search does not work, or maybe I can't understand how it is supposed to work.

If I insert thew minimum information and than click on network lookup the status bar will show that it's lookin for info on www.ncbi.nlm.nih.gov and crossref.org and than stop: nothing happens.

I'll suppose the retrieved html to be copied in the cb2bib window, even if it cannot be autoparsed.

Furthermore, I'll setup my own bookmark file if I could figure out how it works (as www.ncbi.nlm.nih.gov definetly is *not* the right place for physics articles)

Last: clipboard connection could be tuned non to autopaste "internal" selections (e.g. I click on the "year" field it's autoselected, autopasted, autoparsed and messes up all the other fields). This is a minor problem, but it would be nice.

Bye and thanks.


Reply to this

-

 Re: A couple of problems

 
 by constans on: Apr 5 2006
 
Score 50%

1) Try typing prl at the journal box, press enter; you'll get Phys. Rev. Lett. written for you. Also, type praamop, to get Phys. Rev. A: At. Mol. Opt. Phys. So your journals are there... Should you prefer an incomplete abbreviation, feel free to modify the abbreviation file accordingly.

2) Network stuff might be tricked when retrieving of files is complicated by redirections or cookies. I'd suggest you to use kfmclient in these cases. See config panel. Make sure you don't have temporary files left in your home dir. This files are left there if so requested, to help you to write and debug your personalized netqinf file. Just at random, I tried prl, intro, set pages=1 and volume=10, and click net button. My browser show up with this page: http://prola.aps.org/abstract/PRL/v10/i1/p1_1 cb2Bib 0.6.0 includes a contributed regexp for PROLA. I could now easily extract the reference, and attach the pdf file to it, just dragging and dropping to cb2Bib. Feel free to modify and improve this regexps if you wish. NCBI is good for JCP and others. Crossref will work for many more, provided they have a DOI.

3) Go through the examples given at the netqinfo file. Try to understand them. Its syntax is pretty simple. It was designed having in mind that there is not definite database for scientific references. Insted, there is a huge number of different sites but just usefull for a very limitted number of journals. cb2Bib goals are to provide a frame or infrastructure to overcome this. I'd suggest to put sometime of yourself on it. I'm pretty sure it will pay off.

4) Just click connect/disconnect button if you need internal copying. cb2Bib is designed to minimize the number of steps needed for extracting a reference. In most of the cases this means to have it aware of clipboard changes.


Reply to this

-
.

 compiling error

 
 by schek on: Sep 12 2006
 
Score 50%

/usr/lib/qt/bin/uic c2bConfigure.ui -o c2bConfigure.h
uic: File generated with too recent version of Qt Designer (4.0 vs. 3.3.4)
make[1]: *** [c2bConfigure.h] Error 1
make[1]: Leaving directory `/home/nesanfor/cb2bib-0.6.91/src'
make: *** [sub-src] Error 2

It seems that it doesn't support the newer version


Schek
Reply to this

-
.

 How horrible!

 
 by surion on: Jan 21 2007
 
Score 50%

Oh, how horrible it depends on qt4. I need it desperately :)


Reply to this

-
.

 Binary Packages

 
 by arnehe on: Mar 15 2007
 
Score 50%

It would be great, if you could provide binary packages for some common distributions, e.g. using the openSUSE build service (http://en.opensuse.org/Build_Service).

Thanks,
Arne


Reply to this

-

 Re: Binary Packages

 
 by constans on: Apr 2 2007
 
Score 50%

Arne, I wasn't aware of this service. I looked at it and it seems a pretty good way to get the binaries for several distros/versions. I'll try to get an account there, and hopefully, next releases will have several binaries to chose from. Thanks.


Reply to this

-
.

 Re: Re: Binary Packages

 
 by arnehe on: Apr 2 2007
 
Score 50%

Great! Thanks, Arne.


Reply to this

-

 Re: Re: Re: Binary Packages

 
 by constans on: May 8 2007
 
Score 50%

Arne, thank you for let me know about the openSUSE build service. I got packages for SuSE and RedHat. Ubuntu and Debian will need to wait. There is the issue of (the lack of) Qt4 on the default packages available. As far as I read, updated, non SuSE distros will be available soon.

So thanks, and also thanks to the comunity behind openSUSE build service that gave me the permission to use their resources.


Reply to this

-

 compiles ok but ...

 
 by mfg on: Apr 3 2007
 
Score 50%
mfgmfg
universidad autonoma metropolitan a
Home
-
Manuel Fernandez 0

universidad autonoma metropolitana
Mexico, Mexico city
Last visit Jan 6 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Does not install.
I have version 0.7.2 working fine.
However, this 0.8.1 version does not install. (nor did 0.7.3).

The output is:
mfg@tepal:~/tepal-sys/downloads/tex/cb2bib-0.8.1$ sudo make install
Password:
cd src && make -f Makefile install
make[1]: Entering directory `/home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/src'
install -m 644 -p /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/AUTHORS /usr/local/share/cb2bib/
install -m 644 -p /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/COPYRIGHT /usr/local/share/cb2bib/
install -m 644 -p /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/LICENSE /usr/local/share/cb2bib/
cp -f -r /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/data /usr/local/share/cb2bib/
cp -f -r /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/c2btools /usr/local/share/cb2bib/
cp -f -r /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/testPDFImport /usr/local/share/cb2bib/
install -m 644 -p /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/src/icons/cb2bib.png /usr/local/share/pixmaps/
install -m 644 -p /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/cb2bib.desktop /usr/local/share/applications/
install -m 644 -p /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/dl_cb2bib.desktop /usr/local/share/applications/
install -m 755 -p "../bin/cb2bib" "/usr/local/bin/cb2bib"
strip "/usr/local/bin/cb2bib"
install -m 755 -p /home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/c2btools/dl_cb2bib /usr/local/bin/
strip /usr/local/bin/dl_cb2bib
strip: /usr/local/bin/dl_cb2bib: File format not recognized
make[1]: [install_script] Error 1 (ignored)
make[1]: Leaving directory `/home/mfg/tepal-sys/downloads/tex/cb2bib-0.8.1/src'
mfg@tepal:~/tepal-sys/downloads/tex/cb2bib-0.8.1$


Reply to this

-

 Re: compiles ok but ...

 
 by constans on: Apr 3 2007
 
Score 50%

Thank you for let me know, this message didn't catch my attention. The command 'make install' doesn't return any error code, which is what my packaging script checks. In any case, and in spite of this message, installation goes well (all files are properly copied).

On version 0.7.2 it was introduced the 'download to reference manager' functionality. For convenience, the shell script dl_cb2bib was included. This was done to avoid conflicts with the config file cb2bib.desktop on KDE, which opens *.bib files.

When installing, make does 'strip dl_cb2bib', and hence we get 'File format not recognized. Error 1 (ignored)'. This seems to be *normal* for shell scripts. I'm a bit puzzled regarding when this started. Version 0.7.2 already had dl_cb2bib. Make files are done by qmake. Qt requirements hasn't changed since then, though this could come from newer Qt versions.

I'll try to figure out how to avoid this message. For the moment, just ignore it. Installation should be fine. Let me know if it's not.


Reply to this

-

 Re: Re: compiles ok but ...

 
 by mfg on: Apr 4 2007
 
Score 50%
mfgmfg
universidad autonoma metropolitan a
Home
-
Manuel Fernandez 0

universidad autonoma metropolitana
Mexico, Mexico city
Last visit Jan 6 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Dear Constans,
I was puzzled with your reply but now I sort of understand, at least one part.

cb2bib version 0.7.2 remains installed in the path /usr/bin/cb2bib

However, cb2bib version 0.8.1 does install in the path /usr/local/bin/cb2bib

For this reason when I invoked it from the kde menu it gave me version 0.7.2 and I thought the newer version was not installed.

yours,


manuel
Reply to this

-

 Re: Re: Re: compiles ok but ...

 
 by constans on: Apr 4 2007
 
Score 50%

Manuel, thank you for your replay.

The default path changed to /usr/bin some time ago. I checked this now (I did a cleanup in the settings stuff in 0.8.1 and some bug could be there) and, by default, it should still be pointing to /usr/bin ...

Regarding the error message, I just learned that qmake does strip all executable files when writing the Makefile. I saw a post at the Qt mailing list, though it wasn't there any workaround to deal with attached scripts.

Anyway, hope now works smmooth :-)


Cheers,

Pere


Reply to this

-

 Just to repport

 
 by zivadinko on: May 11 2007
 
Score 50%

.rpm package converted to .deb via alien works good on Ubuntu Feisty.

(I spared myself from compiling from the source)


Reply to this

goto page: prev   1  2  3 

Add commentBack






-
-
Do you like or dislike Ubuntu Unity?
 Yes, unity is alien technology!
 It is less confusing than Gnome 3 default, shell.
 Granny thinks it is much more usable than Gnome 2
 Canonical is embarrasing itself with this split project
 Gnome 3 default shell is much better
 I dislike Unity, Gnome 3 default shell is alien technology!
 None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.