-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (1) . 

kio-locate

   0.4.5  

KDE Improvement

Score 78%
kio-locate
zoom


kio-locate
zoom


kio-locate
zoom


Link:  Link
Minimum required   KDE 3.2.x
Downloads:  16300
Submitted:  Oct 21 2004
Updated:  Oct 20 2005

Description:

kio-locate is a KDE I/O Slave for the locate command. This means that you can use kio-locate by simply typing in konquerors address box.

You can e.g. type "locate:index.html" to find all files that contain "index.html" in their name. There's even more: You can use kio-locate in all KDE applications, that accept URLs. Just take a look at the screenshots.

Many thanks to Tobi Vollebregt who has been improving kio-locate as a participant of Googles "Summer of Code". Thank you very much!




Changelog:

kio-locate (0.4.5) 2006-02-05 -- Armin Straub

* Search hits with non-ascii characters in the file name always showed up
with invalid size/owner/group information (fixed by Johan Billing).
* kio-locate should now compile with gcc-4.1_beta (fixed by Jan Jitse
Venselaar).
* Updated to bksys 1.5.1.


kio-locate (0.4.4) 2005-10-19 -- Armin Straub

+ Warn if locate (or whatever is selected) is not installed (suggested
by Axel K. Braun).
* Use slocate and rlocate as default when available (suggested by Nicolas
Degand).
* Closed a bug preventing the display of items having the same prefix
(reported by Takis).




LicenseGPL
(0.4.5 source)
Debian(0.4.5 debian sid)
(older versions)
(0.4.2tvo0.2 kubuntu hoary)
(0.4.3 RPM Fedora Core 4 (thanks to ociomax))
Send to a friend
Subscribe
Other  Apps  from arminstraub
Report inappropriate content



goto page: prev  ... 5  6  7  8  9  10  11  12  13  14 

-
.

 truncated tarball

 
 by nsteeves on: Oct 20 2005
 
Score 50%

Hi,

I love kio-locate, but the tarball for this version seems to be truncated somehow. Output from tar -xzf kio-locate_0.4.4.tar.gz is:

gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now


Reply to this

-

 Re: truncated tarball

 
 by arminstraub on: Oct 20 2005
 
Score 50%

I have uploaded the tarball again (the last upload was only partial because my modem connection broke). Thanks for pointing me to this issue! Hope it works now!


Reply to this

-

 Re: Re: truncated ta

 
 by dansmug on: Oct 20 2005
 
Score 50%

It does! :-)


Reply to this

-

 Happy early bday ;)

 
 by warbinger on: Oct 21 2005
 
Score 50%

Happy Bday Klocate ;)


Reply to this

-
.

 slocate

 
 by tosta on: Oct 21 2005
 
Score 50%
tostatosta
Ekaaty Linux
Home

Can you add a kio-slave for slocate too?


Reply to this

-

 Re: slocate

 
 by arminstraub on: Oct 21 2005
 
Score 50%

If installed, slocate is used automatically since this very version (see ChangeLog). A new kio-slave is therefore not needed.

Of course you can choose in the settings if slocate should be used or not manually as well.


Reply to this

-
.

 trouble with scons

 
 by Hintzy on: Jan 11 2006
 
Score 50%

I loved using kio-locate on my MDV 2005LE box, but when I did a major hardware upgrade and installed MDV 2006 (x86_64), I get this error when I try to run scons:

$ scons configure prefix=/usr
Traceback (most recent call last):
File "/usr/bin/scons", line 143, in ?
import SCons.Script
ImportError: No module named SCons.Script


Any ideas? I've already posted on the Mandriva Club forums about this and have gotten no response. Kio-locate is incredibly useful and I'd love to have it back!

Thanks!
-John


There are 10 types of people in this world: those who understand binary and those who don't.
Reply to this

-

 gcc-4.1.0 +glibc-2.4

 
 by mattepiu on: Mar 14 2006
 
Score 50%

Compiling error (~x86 arch):
g++ -O2 -march=athlon-xp -pipe -fomit-frame-pointer -I/usr/kde/3.5/include -I/usr/qt/3/include/ -fPIC -O2 -march=athlon-xp -pipe -fomit-frame-pointer -DNDEBUG -DNO_DEBUG -DQT_NO_TRANSLATION -DHAVE_UDS_HIDDEN -I. -Ibuild/src -c -o build/src/klocateconfiglocatewidget.os build/src/klocateconfiglocatewidget.cpp
/usr/qt/3/bin/moc -o build/src/kio_locate.moc build/src/kio_locate.h
g++ -O2 -march=athlon-xp -pipe -fomit-frame-pointer -I/usr/kde/3.5/include -I/usr/qt/3/include/ -fPIC -O2 -march=athlon-xp -pipe -fomit-frame-pointer -DNDEBUG -DNO_DEBUG -DQT_NO_TRANSLATION -DHAVE_UDS_HIDDEN -I. -Ibuild/src -c -o build/src/kio_locate.os build/src/kio_locate.cpp
build/src/kio_locate.h:187: error: extra qualification 'LocateProtocol::' on member 'processPath'
build/src/kio_locate.cpp: In function 'int kdemain(int, char**)':
build/src/kio_locate.cpp:1017: warning: '__comp_ctor ' is deprecated (declared at /usr/kde/3.5/include/kapplication.h:205)
scons: *** [build/src/kio_locate.os] Error 1
scons: building terminated because of errors.


Reply to this

-

 Re: gcc-4.1.0 +glibc

 
 by mattepiu on: Mar 17 2006
 
Score 50%

Fixed by removing just the extra qualifier
"LocateProtocol::"


Reply to this

-

 not able to install

 
 by kamaraju on: Apr 10 2006
 
Score 50%

I downloaded kio-locate_0.4.5-1_i386.deb from http://arminstraub.de/browse.php?page=programs_kiolocate&lang=en . But I am unable to install it on Debian Sid running kde 3.5.2. The exact errors are

$sudo dpkg -i kio-locate_0.4.5-1_i386.deb
Selecting previously deselected package kio-locate.
(Reading database ... 264885 files and directories currently installed.)
Unpacking kio-locate (from kio-locate_0.4.5-1_i386.deb) ...
dpkg: dependency problems prevent configuration of kio-locate:
kio-locate depends on kdelibs4c2 (>= 4:3.4.2-1); however:
Package kdelibs4c2 is not installed.
dpkg: error processing kio-locate (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
kio-locate

The website http://arminstraub.de/browse.php?page=programs_kiolocate&lang=en does not tell where to report the problems. So I have previously reported the problem to debian-user mailing list. I have not received any response from the developers on that list. So I am posting it here. The corresponding thread can be found at
http://lists.debian.org/debian-user/2006/04/msg00907.html

thanks
raju


Reply to this

-

 Re: not able to inst

 
 by arminstraub on: Apr 18 2006
 
Score 50%

This error occurs because I build the package some time ago, when kdelibs4c2 had not been replaced by kdelibs4c2a. Unfortunately, I am not using Debian any more, so I don't know how to update the package on my machine.

Perhaps someone can send me an updated deb file? Since the sources already contain the necessary files, creating the deb file should be as simple as fakeroot debian/rules binary provided all development packages are installed.


Reply to this

-

 Re: Re: not able to inst

 
 by kamaraju on: Apr 24 2006
 
Score 50%

I tried building this package. But there were some errors and it did not build properly. I am providing the errors below. If you have any suggestions, I would be happy to incorporate them.

$fakeroot debian/rules binary
test -x debian/rules
test "`id -u`" = 0
dh_clean -k
dh_installdirs -A
mkdir -p "."
python scons-mini/scons configure prefix=/home/software/unZipped/kio-locate/kio-locate-0.4.5/debian/kio-locate//usr
scons: Reading SConscript files ...
** installation prefix for the project set to: /home/software/unZipped/kio-locate/kio-locate-0.4.5/debian/kio-locate/usr
Checking for kde-config : kde-config was found as /usr/bin/kde-config
Checking for kde version : 3.5.2
Checking for the qt library : qt was found as /usr
Checking for uic : uic was found as /usr/bin/uic
Checking for moc : moc was found as /usr/bin/moc
Checking for the qt includes : the qt headers were found in /usr/include/qt3/
Checking for the kde includes : the kde headers were found in /usr/include/kde/
Checking KDE for UDS_HIDDEN : yes
touch ./config.status
python scons-mini/scons
scons: Reading SConscript files ...
scons: done reading SConscript files.
scons: Building targets ...
processing klocateconfig.kcfgc to get klocateconfig.h and klocateconfig.cpp
kconfig_compiler -dbuild/src build/src/kio_locate.kcfg build/src/klocateconfig.kcfgc
g++ -I/usr/include/kde/ -I/usr/include/qt3 -fPIC -O2 -DNDEBUG -DNO_DEBUG -DQT_NO_TRANSLATION -DHAVE_UDS_HIDDEN -I. -Ibuild/src -c -o build/src/klocateconfig.os build/src/klocateconfig.cpp


bunch of compilation commands and in the end

Install file: "build/src/kio_locate.so" as "debian/kio-locate/usr/lib/kde3/kio_locate.so"
Install file: "build/src/kio_locate.la" as "debian/kio-locate/usr/lib/kde3/kio_locate.la"
Install file: "build/src/locate.protocol" as "debian/kio-locate/usr/share/services/locate.protocol"
Install file: "build/src/locater.protocol" as "debian/kio-locate/usr/share/services/locater.protocol"
Install file: "build/src/rlocate.protocol" as "debian/kio-locate/usr/share/services/rlocate.protocol"
Install file: "build/src/locate.desktop" as "debian/kio-locate/usr/share/services/searchproviders/locate.desktop"
Install file: "doc/en/screenshot.png" as "debian/kio-locate/usr/share/doc/kde/HTML/en/kio-locate/screenshot.png"
Install file: "doc/en/index.docbook" as "debian/kio-locate/usr/share/doc/kde/HTML/en/kio-locate/index.docbook"
scons: done building targets.

scons: *** Dependency cycle: doc/en/index.cache.bz2 -> doc/en/index.cache.bz2 -> debian/kio-locate/usr/share/doc/kde/HTML/en/kio-locate/index.cache.bz2 -> install
File "/home/software/unZipped/kio-locate/kio-locate-0.4.5/scons-mini/scons-local-0.96.1/SCons/Taskmaster.py", line 145, in _find_next_ready_node
make: *** [common-install-impl] Error 2


Reply to this

-

 Re: Re: Re: not able to inst

 
 by Stumbles on: Dec 20 2006
 
Score 50%

I to get that Dependency cycle error but don't know how to get around it. Any pointers?


Reply to this

-

 Re: Re: Re: Re: not able to inst

 
 by davidanderson on: Jan 29 2007
 
Score 50%

I'm trying to create a package for Fedora Core 5, and I get this error too.

Anyone have a clue?


Reply to this

-
.

 Re: Re: Re: Re: Re: not able to inst

 
 by toyg on: Nov 29 2007
 
Score 50%
toygtoyg
Ancorasoft
Home
-
Giacomo Lacava -4

Ancorasoft
United Kingdom, Stockport
Last visit Apr 9 2012
0 Friends
4 Groups

More info
Send a message
Add as friend
Other contents
--

I think it's due to this call: meinproc --check --cache index.cache.bz2 index.docbook

This works when run as root, not when running under fakeroot, g*d knows why. Anyway, building as root (i know, i know, it's not nice) works fine on Debian etch.


Reply to this

-

 Re: not able to install

 
 by arminstraub on: May 23 2006
 
Score 50%

Karsten Schulz has just sent me an updated Debian package he created for Debian/sid.
I can't try it myself, but I hope this one works for you. Thank you, Karsten!


Reply to this

-

 Re: Re: not able to

 
 by kamaraju on: Jun 19 2006
 
Score 50%

Yes. It works! Thanks!


Reply to this

goto page: prev  ... 5  6  7  8  9  10  11  12  13  14 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.