-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans  .- Knowledge Base  . 

Smart DJ

   0.6.0  

Amarok Script

Score 79%
Smart DJ
zoom


Smart DJ
zoom


Smart DJ
zoom


Link:  Link
Depends on  PyKDE/PyQt
Downloads:  6368
Submitted:  Nov 18 2005
Updated:  Dec 29 2005

Description:

Smart DJ lets you find tracks based on how similar they sound to each other. It can also automatically add new tracks to your playlist based on how similar they are to what you've been listening to.

In addition to PyQt, this requires songanalysis (0.4.0 or higher), python-commandsplus, python-extattr, python-Observable and python-amarok (these last two are new dependencies) which can be found at

http://rudd-o.com/projects/

(the RPM packages have been linked here for your convenience, and will work if you have Fedora Core 4; the source packages are available at the aforementioned URL, and packages for other distributions may be found in the comments section of this page, thanks to very thoughtful and considerate individuals).

Songanalysis requires the GNU Scientific Library (package named libgsl or gsl, depending on your operating system), mpg321 (package mpg321) and ogg123 (package vorbis-tools).




Changelog:

- Fixed various bugs
- Functionality was split into separate libraries which can be used standalone now




LicenseGPL
Source(Smart DJ script)
Fedora(Required: songanalysis 0.4.0 (RPM package))
Fedora(Required: python-commandsplus (RPM package))
Fedora(Required: python-extattr (RPM package))
Fedora(Required: python-Observable (RPM package))
Fedora(Required: python-amarok (RPM package))
Send to a friend
Subscribe
Other  Apps  from RuddO
Report inappropriate content



goto page: prev   1  2  3  4  5  6 

-

 can't find tracks

 
 by HessiJames on: Nov 24 2005
 
Score 50%

Hi, very good that now apostophes are supported. But I can't find similar tracks, when I click on one and select "find tracks similar to selection...". I have scanned a song which I have twice. Both have 135 bpm.


Reply to this

-
.

 Re: can't find track

 
 by RuddO on: Nov 25 2005
 
Score 50%

I need more details in order to help you with the issue. Saying "i cannot find any tracks" without letting me know error messages, behaviours, or what the log file says, is close to useless for debugging.


Reply to this

-

 Re: Re: can't find track

 
 by ChrisFritz on: Dec 1 2005
 
Score 50%

I've been having the same problem as this person -- when I get a chance, I'll see if I can figure out what's going on, and e-mail anything I find, if I find anything.


Reply to this

-

 Re: Re: Re: can't find track

 
 by ChrisFritz on: Dec 1 2005
 
Score 50%

Ah, I see jdm33 further below in the comments found the solution. When I changed the greater/least to max/min, it worked out just fine (I'm still running an older Smart DJ, so I don't know if this was already fixed in the current release after jdm33's comment.) Now that this works, I can finally enjoy the script =D


Reply to this

-
.

 Re: can't find track

 
 by RuddO on: Dec 2 2005
 
Score 50%

Lots of bugs have been fixed. I suggest you give it another go. If you are using SQLite as the database type (which is the default) then you'll see it working now.


Reply to this

-

 SQL incompatability?

 
 by jdm33 on: Nov 26 2005
 
Score 50%

Hi,

Nice work - I'd been wondering whether something like this was possible for a while.

To get the script (v 0.3.6) working though, I had to hack the script to replace SQL uses of GREATEST/LEAST with MAX/MIN as GREATEST/LEAST don't seem to be supported by my DB backend.

I think my backend is sqlite, but it doesn't actually look as though amarok links the sqlite library in so I'm getting confused. Certainly I debugged the problem by trying out the SQL sql from the log file in sqlitebrowser and that told me that 'GREATEST'/'LEAST' aren't recognized.

Is it possible to fix this or is there some major headache here with different DBs supporting different SQL variants?


Thanks,
-Jon

Reply to this

-

 Re: SQL incompatability?

 
 by blaster999 on: Nov 27 2005
 
Score 50%

Well, Oracle and MySQL both support least() and greatest(), but SQLite and Postgres do not. Min() and max() are better supported.

BTW, amaroK has a builtin version of sqlite, so it doesn't link to an external sqlite lib.


It is not the size of the hammer that counts. It's how you wield it.
Reply to this

-
.

 Re: SQL incompatabil

 
 by RuddO on: Dec 1 2005
 
Score 50%

Now there is support for SQLite


Reply to this

-
.

 Which packets

 
 by wdsl on: Nov 29 2005
 
Score 50%

do i need for debian?

I can't find this RPM packets for Debian ;-(

thx
wdsl


Reply to this

-

 Re: Which packets

 
 by blaster999 on: Nov 30 2005
 
Score 50%

You can compile from sources. You need songanalysis, python-commandsplus and python-extattr. You can get them all from http://www.usm.edu.ec/~amadorm/software/


It is not the size of the hammer that counts. It's how you wield it.
Reply to this

-
.

 error code 1 :(

 
 by zefo on: Dec 1 2005
 
Score 50%
zefozefo
T-Systems Slovakia
-
Jozef Riha 0

T-Systems Slovakia
Slovak Republic, Kosice
Last visit May 28 2009
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Traceback (most recent call last):
File "/home/jose/.kde/share/apps/amarok/scripts/Smart DJ/Smart DJ", line 61, in ?
test_ui()
File "/home/jose/.kde/share/apps/amarok/scripts/Smart DJ/Smart DJ", line 58, in test_ui
import uiqt as ui
File "/home/jose/.kde/share/apps/amarok/scripts/Smart DJ/uiqt.py", line 15, in ?
from qt import *
RuntimeError: the sip module supports API v%u.0 to v%u.%u but the %s module requires API v%u.%u


-- jose
Reply to this

-
.

 Re: error code 1 :(

 
 by RuddO on: Dec 2 2005
 
Score 50%

Your SIP bindings do not match your PyQt or Qt library version. Update them three.

Next version will have a message box if this happens, advising about the best course of action.


Reply to this

-

 If 0.4 crashes....

 
 by blaster999 on: Dec 1 2005
 
Score 50%

... ats tartup, try changing the line 232 of amarok.py to
logger.debug("Detected SQLite/PostgreSQL as database type")

(erease "self." at the beginning). That worked for me. YMMV.


It is not the size of the hammer that counts. It's how you wield it.
Reply to this

-
.

 Re: If 0.4 crashes..

 
 by RuddO on: Dec 2 2005
 
Score 50%

This bug has been fixed now


Reply to this

-

 gentoo ebuilds

 
 by gordin on: Dec 2 2005
 
Score 50%

I submitted ebuilds for gentoo to http://bugs.gentoo.org for songanalysis, python-commandsplus and python-extattr.
They can be found at
http://bugs.gentoo.org/show_bug.cgi?id=114243
http://bugs.gentoo.org/show_bug.cgi?id=114245
http://bugs.gentoo.org/show_bug.cgi?id=114246

have fun


Reply to this

goto page: prev   1  2  3  4  5  6 

Add commentBack






-
-
Do you like or dislike Ubuntu Unity?
 Yes, unity is alien technology!
 It is less confusing than Gnome 3 default, shell.
 Granny thinks it is much more usable than Gnome 2
 Canonical is embarrasing itself with this split project
 Gnome 3 default shell is much better
 I dislike Unity, Gnome 3 default shell is alien technology!
 None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.