-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans  .- Knowledge Base  . 

KFreeFlight

   0.3.2-r2  

KDE Other Game

Score 77%
KFreeFlight
zoom


KFreeFlight
zoom


KFreeFlight
zoom


Link:  Link
Minimum required   KDE 3.3.x
Downloads:  5262
Submitted:  Jan 25 2006
Updated:  Sep 23 2006

Description:

KFreeFlight is a flightgear gui-frontend which can launch it with the most common options without taping a very long command line. Some clicks and you can fly away.
Include FlightGear 0.9.9 and 0.9.10 features. Works well with the FlightGear CVS version.
- carrier
- multiplayer
- winter scenery
- etc...

KFreeFlight is available in english, french and italian languages.

You can find a CVS version too (click on the website link)

KFreeFlight follow KDE developppement and be sure you have the lastest KDE version before reporting bug.

Please, sending a bug report is the best way to help you if you have problem with it. You can find the email address on the kfreeflight web site (http://kfreeflight.sourceforge.net).
I don't take a look every day on the kde-apps web site.




Changelog:

CVS version available on the project website.
- More friendly GUI
- Switch to modular application
- Automatic scenarri list
- Automatic carriers list and start point
- A lot of little things

v0.3.2-r2
Critic bug fix only

v0.3.2
Add 3D aircraft rendering
Remove aircraft thumbnails
Add system tray integration option

v0.3.1
Add real weather window : download the metar and make a report
Add Find an airport by ICAO code, by name or coordinates in the apt.dat.gz file
Add personnal screen resolution (settable by the settings menu)
Update multiplayer options
Add lightning and precipitation rendering option

v0.2.1
Add shadows(aircraft, ai objects, scenery objects) options
Add bump mapped clouds option
Add reload aircraft list button
Add ATC-Chatter option (FlightGear CVS version only)

v0.2
Add gps start position
Add reload config in menu
Add i18n

v0.1.4
Add toolbar and statusbar
Add Comm tab
Add Carrier tab
Update Radio tab ->Add TACAN and nav,adf standby
Update Settings Menu -> add personnal options for FlightGear
Update Time tab
Add dev aircraft image


v0.1.2
Now you can add new airports and runways without edited airports.dat.
Add Radio tab
Add Weather tab
Add Menu settings:
- Font and Color
- Application settings are now in the menu
Add About entry menu
Add File - Quit entry menu
Add Splashscreen at startup
Add Multiplayer game mode
Add Flight plan : route/way




LicenseGPL
Source
Send to a friend
Subscribe
Other  Apps  from didier13
Report inappropriate content



goto page: prev   1  2  3 

-
.

 SlackWare Update!!!

 
 by gohanz on: Mar 24 2006
 
Score 50%

A SlackWare TGz package with SlackBuild Script is Ready to DownLoad!!!

http://www.slacky.it/

http://www.slacky.it/index.php?option=com_remository&Itemid=1&func=fileinfo&filecatid=922&parent=category


Reply to this

-

 Never succeded

 
 by dovidhalevi on: Mar 25 2006
 
Score 50%

in compiling this. A bunch of troublesome AM_.... symbols in the configure, no real hints in the suggested autoconf documentations and running automake et al simply cripples further attempts to ./configure.


Reply to this

-

 Re: Never succeded

 
 by greeneagle on: Mar 29 2006
 
Score 50%

WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -f Makefile.cvs

do that in clean unpacked source dir
then ./configure; make; make install

I managed to get a working kfreeflight using that command with this package:
kfreeflight-0.2.1rc1.tar.gz

I had same aclocal errors as you had before trying that. configure looked fine but subsequent makes or configures all gebroken compalining about aclocal stuff.

I managed to get a build but not working kfreeflight from sourceforge unstable 0.3.1

trying 0.2.1 now ...

A paragui underquoted aclocal warning seems to be okay.


Reply to this

-

 Re: Re: Never succeded

 
 by didier13 on: Apr 8 2006
 
Score 50%

error or warning?
warnings appeared when i updated autoconf or automake. it's not the best way but the application can be build anyway.
send me a bug report if you can't build it. launch configure like this:
./configure >> kfreeflight.txt
In that way all stdout messages are in the file which be included with the bug report


Reply to this

-

 Re: Never succed

 
 by dovidhalevi on: Apr 17 2006
 
Score 50%

Tried above commands with make (no gmake). Set things up, successful ./configure. Link stage of make gives a lot of these:
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `SGSerialPort::open_port(std::basic_string const&)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `SGSerialPort::SGSerialPort()'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `SGSerialPort::close_port()'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgmodel.so: undefined reference to `SGEnviro::getFOV(float&, float&)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netAddress::getPort() const'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgmodel.so: undefined reference to `sgEnviro'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::setBlocking(bool)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgscreen.so: undefined reference to `jpeg_set_defaults'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::listen(int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::accept(netAddress*)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netAddress::getHost() const'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgscreen.so: undefined reference to `jpeg_std_error'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::close()'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::setHandle(int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgtgdb.so: undefined reference to `SGBucket::get_height() const'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgtgdb.so: undefined reference to `SGBucket::get_width() const'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `SGBucket::gen_base_path() const'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `SGSerialPort::set_baud(int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `SGSerialPort::write_port(char const*, int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgscreen.so: undefined reference to `jpeg_abort_compress'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgscreen.so: undefined reference to `jpeg_start_compress'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgscreen.so: undefined reference to `jpeg_destroy_compress'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::select(netSocket**, netSocket**, int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgscreen.so: undefined reference to `jpeg_CreateCompress'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::~netSocket()'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::connect(char const*, int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgscreen.so: undefined reference to `jpeg_finish_compress'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::recv(void*, int, int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::open(bool)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgscreen.so: undefined reference to `jpeg_set_quality'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::bind(char const*, int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netInit(int*, char**)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgscreen.so: undefined reference to `jpeg_write_scanlines'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `SGSerialPort::~SGSerialPort()'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `SGSerialPort::read_port(char*, int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::send(void const*, int, int)'
/usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libsgio.so: undefined reference to `netSocket::netSocket()'


Reply to this

-
.

 error

 
 by linux3114a on: Apr 14 2006
 
Score 50%

created a rpm for Suse 10.0 w/o problem

When trying to select a fly , it's selected but cannot display thumbnail.jpg

see message :

avec :/usr/share/games/FlightGear/Aircraft/bf109/thumbnail.jpg
*** Attention *** : Aucune miniature trouvée, essai avec un autre répertoire
*** Erreur *** : Pas de miniature pour cet avion:bf109
*** Succès *** : La liste des avions a été crée!


raoul
Reply to this

-
.

 SuSE 10 V 0.3.1

 
 by linux3114a on: Apr 15 2006
 
Score 50%

kfreeflight-0.3.1-1-lotus.i586.rpm
at
http://home.tiscali.be/raoul.linux/downloadSuSE10.0.htm

Also the following packages :

FlightGear-0.9.10-1-lotus.i586.rpm
SimGear-0.3.10.tar.gz
freeglut-2.2.0-83.i586.rpm


Raoul
Reply to this

-

 thumbnail problem

 
 by didier13 on: Apr 16 2006
 
Score 50%

The thumbnail problem was solved in the 0.3.2 release (available tuesday or wednesday on sourceforge).
And with this version, you have choice between thumbnail and 3D rendering with plib or simgear (more slowly)


Reply to this

-
.

 Error with V0.3.2

 
 by linux3114a on: Apr 17 2006
 
Score 50%

When i unzip my flightgear Base file under /usr/local/share/FlightGear/ , I have the following path for my aircrafts

/usr/local/share/FlightGear/data/aircrafts/...

when starting your front end I receive in your log the following path for yours aircrafts selection

/usr/local/share/FlightGear/Aircraft/xxx/Avion

STRANGE
No problem with previous version


Raoul
Reply to this

goto page: prev   1  2  3 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.