-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (1) .- Knowledge Base  . 

KopyShop

   0.1.10  

KDE Printing

Score 79%
KopyShop
zoom


KopyShop
zoom


Link:  Link
Minimum required   KDE 3.5.x
Downloads:  2655
Submitted:  Jan 29 2006
Updated:  Feb 7 2006

Description:

KopyShop is a simple KDE application to copy a sheet of paper. It uses a scanner and a printer to do that. The main advantage of KopyShop is that your copy is nearly the same size as the original. One Idea was that this task should easy for the end user. Techniclly it uses the SANE and KPrinter to communicate with the devices. Additionaly it has the feature to save or load image files. The input and output resolutions are adjustable, as well as the input and output device (last is done bei the KDE printer dialog)


Requirements
=========
-Running KDE 3 (tested on gentoo, kde3.5).
-sane-backends installed.
-A configured and working SANE device and a output device supported by KPrinter.
-installed libkscan / kdegraphics

For installing source: all things you need to compile a KDE application and SANE header files.


Known bugs/limitations
=================
Warning! Don't start KopyShop when your scanning device is not ready, program will possibly wait endlessly.

-Physical size of scanner must be nearly the same as the printer (usualy A4).
-Some error/status messages are missing...
-German translation didn't work.

TODO
====
- flexible zooming
- some bug fixing for the GUI

additional licens information: the headers from libkscan are included because they are missed. Many thx to Klaas Freitag for helping with the libkscan thing.




Changelog:

0.1.10 Bugfix release
-fix compile error in ksprefswidgetbase.ui
-code clean up

0.1.9
testing release for upcoming 0.2
-new GUI
-new preview
-ability to crop before print
-center selected area on page
-lots of bugfixes
-use external libkscan instead of include into kopyshop
(if you have a KDE prior 3.5, then kopyshop could not work as expected)

0.1.1 BUGFIX release
-application icon (thx to Stefanie Denecke)
-app settings are restorable
-new option: scale to fit paper size
-better print size correction

0.1.0
initial release




LicenseGPL
Source(Source)
Gentoo(Gentoo Ebuild)
Source(source v0.1.1 (for KDE prior 3.5))
Send to a friend
Subscribe
Other  Apps  from sarahb523
Report inappropriate content



goto page: prev   1  2  3  4 

-
.

 Problem

 
 by cyberclaus on: Jan 31 2006
 
Score 50%

I waited for so long for this application and now I have problem installing it.
./configure run without error, but make said
"`m4_symbols' from frozen file not found in builtin table!"

What's that. Never had that before. What can I do th get this app run? Any help is appreciated.
Thanks in advance.


cyberclaus
Reply to this

-

 Re: Problem

 
 by sarahb523 on: Jan 31 2006
 
Score 50%

make problems also mysterious for me. But could you give some more informations please? distro, gcc, make, automake ...

try:
make -f admin/Makefile.common
./configure
make


Reply to this

-

 Re: Re: Problem

 
 by cyberclaus on: Jan 31 2006
 
Score 50%

Thanks for answering so soon.
Tried your suggestion and got the same error with the first command (make -f ...)
Here the desired informations:
Distro: SuSE 9.3 Prof. on x386 platform
gcc: 3.3.5-5
make: 3.80
automake: 1.9.5
m4: 1.4.2
KDE: 3.5.0 Level a
Thanks for your help.


cyberclaus
Reply to this

-

 Re: Re: Problem

 
 by cyberclaus on: Feb 1 2006
 
Score 50%

Meanwhile I found something. I upgraded autoconf from 2.5.8 to 2.5.9 and the former error message is gone. But ... sorry ... there is a new one that I can't understand.
Here are the last lines from make:
    cd . && perl admin/am_edit
    cd . && perl admin/am_edit Makefile.in
    cd . && rm -f configure
    cd . && make -f admin/Makefile.common configure
    make[1]: Entering directory `/home/Downloads/kopyshop-0.1.1'
    Can't open configure: No such file or directory.
    make[1]: Leaving directory `/home/Downloads/kopyshop-0.1.1'
    /bin/sh ./config.status --recheck
    running /bin/sh ./configure --prefix=/opt/kde3 --no-create --no-recursion
    /bin/sh: ./configure: No such file or directory
    make: *** [config.status] Error 127

Can you give me an explanation what this means, where it comes from and how to solve this?
Thank you


cyberclaus
Reply to this

-
.

 SlackWare Package!!!

 
 by gohanz on: Feb 1 2006
 
Score 50%

A SlackWare TGz package with SlackBuild Script is Ready to DownLoad!!!

http://www.slacky.it/

http://www.slacky.it/index.php?option=com_remository&Itemid=1&func=fileinfo&filecatid=920&parent=category


Reply to this

-

 Re: SlackWare Package!!!

 
 by sarahb523 on: Feb 1 2006
 
Score 50%

thx, for packaging. BTW I didn't believe to get so much positiv response for my tiny app. I take your positive impulses for further development.


Reply to this

-

 cool

 
 by tagwar on: Feb 4 2006
 
Score 50%

I have been waiting for something like that, but... it only gets a small part of the page I want to copy... perhaps there should be a way to select papersize before scanning... and being able to save preferences would be nice as well..

besides that, thanks a lot for a great tool..


Reply to this

-

 Re: cool

 
 by sarahb523 on: Feb 5 2006
 
Score 50%

the new version 0.2 is in work and it has some nice features. a real preview, ability to crope an image, selecting paper size, new gui. The new version werks basicly yet, but there are lots of small things to do.

regards, sarah


Reply to this

-
.

 SuSE Rpm

 
 by Animatrix30 on: Feb 5 2006
 
Score 50%

Webpage >> http://www.animweb-fr.com/SuSE

Direct link >> http://www.animweb-fr.com/SuSE/rpm/kopyshop-0-1.1.i386.rpm

Enjoy it !


Reply to this

-
.

 Re: SuSE Rpm

 
 by cyberclaus on: Feb 5 2006
 
Score 50%

This works and I'm happy.

Thank you very much.


cyberclaus
Reply to this

-
.

 COmpiling

 
 by Animatrix30 on: Feb 6 2006
 
Score 50%

Hi !

When the make is running, I obtain this errors :

if g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/opt/kde3/include -I/usr/lib/qt3/include - I/usr/X11R6/include -I../libkscan -DQT_THREAD_SUPPORT -D_REENTRANT -Wno-long -long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -O2 -Wformat-security -Wmissing-forma t-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -M T ksprefswidgetbase.o -MD -MP -MF ".deps/ksprefswidgetbase.Tpo" -c -o ksprefswid getbase.o ksprefswidgetbase.cpp; \
then mv -f ".deps/ksprefswidgetbase.Tpo" ".deps/ksprefswidgetbase.Po"; else rm - f ".deps/ksprefswidgetbase.Tpo"; exit 1; fi
ksprefswidgetbase.cpp:15:67: error: /home/daten/devel/cpp/kde/kopyshop/libkscan/ previewer.h: Aucun fichier ou répertoire de ce type
make[2]: *** [ksprefswidgetbase.o] Erreur 1
make[2]: Leaving directory `/home/animatrix/Documents/34553-kopyshop-0.1.9/kopys hop-0.1.9/src'
make[1]: *** [all-recursive] Erreur 1
make[1]: Leaving directory `/home/animatrix/Documents/34553-kopyshop-0.1.9/kopys hop-0.1.9'
make: *** [all] Erreur 2


At a moment, there is a /home/daten.
My home's folder is /home/animatrix.

Is-it a bug at me ? Or is the source file ?

Bye


Reply to this

-

 Re: COmpiling

 
 by sarahb523 on: Feb 6 2006
 
Score 50%

try:
make clean && ./configure && make -f admin/Makefile.common && ./configure && make

(it could be neccessary to add --prefix /usr or similar to configure, depends on your system)

it seems there is some garbage from my installation in it :-( But this release is mostly for bug hunting for the upcomming 0.2, thx for reproting!

regards,
sarah


Reply to this

-

 Re: COmpiling

 
 by sarahb523 on: Feb 6 2006
 
Score 50%

replace src/ksprefswidgetbase.ui with this:
http://spookyk.dyndns.org/sarah/kopyshop/ksprefswidgetbase.ui

hope that helps.


Reply to this

-

 Re: Re: COmpiling

 
 by Animatrix30 on: Feb 6 2006
 
Score 50%

Hi !!

Thanks. The installation works.
But, contrary to the last version I can scan !!!

My scanner isn't detected, whereas Kooka (for example) yes !

This is the error, after I try to scan a document (crash of programm) :

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1098460928 (LWP 27562)]
[KCrash handler]
#7 0x40045032 in KScanDevice::apply () from /opt/kde3/lib/libkscan.so.1
#8 0x08051e5f in KopyShop::slScan_clicked ()
#9 0x08050b13 in KopyShop::slCopy_clicked ()
#10 0x08050d45 in KopyShop::qt_invoke ()
#11 0x40e67a49 in QObject::activate_signal ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x40e67ef0 in QObject::activate_signal ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x411b14e9 in QButton::pressed () from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x40efc6bd in QButton::mousePressEvent ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x40ea172b in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x40e07d41 in QApplication::internalNotify ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40e08ea8 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0x40a8214e in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#19 0x40da2cd8 in QETWidget::translateMouseEvent ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x40da1afb in QApplication::x11ProcessEvent ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x40db5bea in QEventLoop::processEvents ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x40e1ec39 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x40e1eb36 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x40e0768f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0x08050ace in main ()


I will post rpm tomorrow :)

P.S. : My (old) scanner is a Plustek Optic Pro 1212U.


Reply to this

-

 Re: Re: Re: COmpiling

 
 by sarahb523 on: Feb 7 2006
 
Score 50%

I guess your libkscan is to old? before 0.1.9 parts of libkscan were included and installed libkscan (used by kooka) wasn't used. Now only libkscan headers are included, because there not shiped with kdegraphics yet and now kopyshop uses installed libkscan. posibly my headers form kdegraphics 3.5 dont fit to your libkscan in kdegraphics-3.3.2?


Reply to this

-
.

 Build Problems

 
 by BorgQueen on: Feb 6 2006
 
Score 50%

System Info: Debian Sarge, KDE 3.3.2.
I get this error msg regardless...

if g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include/kde -I/usr/share/qt3/include -I/usr/X11R6/include -I../libkscan -DQT_THREAD_SUPPORT -D_REENTRANT -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -O2 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -MT ksprefswidgetbase.o -MD -MP -MF ".deps/ksprefswidgetbase.Tpo" -c -o ksprefswidgetbase.o ksprefswidgetbase.cpp; \
then mv -f ".deps/ksprefswidgetbase.Tpo" ".deps/ksprefswidgetbase.Po"; else rm -f ".deps/ksprefswidgetbase.Tpo"; exit 1; fi
ksprefswidgetbase.cpp:15:67: /home/daten/devel/cpp/kde/kopyshop/libkscan/previewer.h: No such file or directory
ksprefswidgetbase.cpp: In constructor `
KsPrefsWidgetBase::KsPrefsWidgetBase(QWidget*, const char*, bool, unsigned
int)':
ksprefswidgetbase.cpp:202: error: invalid use of undefined type `struct
Previewer'
ksprefswidgetbase.h:21: error: forward declaration of `struct Previewer'
ksprefswidgetbase.cpp:203: error: `sizePolicy' undeclared (first use this
function)
ksprefswidgetbase.cpp:203: error: (Each undeclared identifier is reported only
once for each function it appears in.)
ksprefswidgetbase.cpp:203: error: `setSizePolicy' undeclared (first use this
function)
ksprefswidgetbase.cpp:205: error: no matching function for call to `QGridLayout
::addWidget(Previewer*&, int, int)'
/usr/share/qt3/include/qlayout.h:331: error: candidates are: void
QGridLayout::addWidget(QWidget*, int, int, int)
make[2]: *** [ksprefswidgetbase.o] Error 1
make[2]: Leaving directory `/home/Software/SoftwareTesting/SourceFiles/kopyshop-0.1.9/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/Software/SoftwareTesting/SourceFiles/kopyshop-0.1.9'
make: *** [all] Error 2

What do you think it might be? The first couple of versions worked great.


Reply to this

goto page: prev   1  2  3  4 

Add commentBack






-
-
Do you like or dislike Ubuntu Unity?
 Yes, unity is alien technology!
 It is less confusing than Gnome 3 default, shell.
 Granny thinks it is much more usable than Gnome 2
 Canonical is embarrasing itself with this split project
 Gnome 3 default shell is much better
 I dislike Unity, Gnome 3 default shell is alien technology!
 None of the above, I like the 2Gb for free and Apple alike behavior. Will post a comment instead

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.