-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (1) .- Knowledge Base  . 

Kwlan

   0.6.3  

KDE Networking Tool

Score 84%
Kwlan
zoom


Kwlan
zoom


Kwlan
zoom


Link:  http://
Minimum required   KDE 3.x
Downloads:  29582
Submitted:  Mar 28 2006
Updated:  Aug 23 2007

Description:

Network manager for kde.

Allows you to configure different network profiles using all encryptions wpa_supplicant provides (wep, wpa, wpa2 etc) for wireless networks.
Since version 0.4.5 kwlan can connect to unencrypted networks if wpa_supplicant is not available.

Kwlan can also store profiles for wired networks.

Dialup networks can be edited and connected to as well.

Systray icons show connection statistics per interface (can be disabled).

Attention: Since 0.6.0, Kwlan uses kdesu to do administrative tasks so you must be able to run dhclient, ifconfig, wpa_supplicant (see help file)!
New kubuntu binery fixes dependency problems.




Changelog:

Version 0.6.3:
-------------
- Fixed Bug: Setting to show New Interface Wizard was not stored correctly.
- Fixed Bug: Adding new network from Scanning didn't fill in encryption settings automatically
- Fixed Bug: WPA enabled networks were shown as new if wpa_supplicant was not started
- Fixed Bug: access to pppd was not tested correctly
- Access Dialup networks from context menu of interface systray icon.

Version 0.6.2
-------------
- Added option for ad-hoc networks
- Added option to show commands in kdesu password requests
- Shows signal strength in context menu
- Shows unconfigured networks in context menu to automatically add the scanned networks
- rewritten scanning code independent of wpa_supplicant




LicenseGPL
Source
Ubuntu(kubuntu edgy binaries)
Send to a friend
Subscribe
Other  Apps  from tmichel
Report inappropriate content



goto page: prev   1  2  3  4  5  6  7  8  9 ...

-

 problem with 0.2.1

 
 by danone on: Mar 30 2006
 
Score 50%

I get a problem linking v. 0.2.1:
After getting compile errors (iwlib.h and wireless.h weren't there) I figured out to install libiw-dev package (Debian).
Now I get the following:

/bin/sh ../libtool --silent --mode=link --tag=CXX g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -o kwlan -R /usr/lib -R /usr/share/qt3/lib -R /usr/X11R6/lib -L/usr/X11R6/lib -L/usr/share/qt3/lib -L/usr/lib main.o kwlanview.o kwlanmainwin.o configuration.o wlanlib.o kstartsupplicantdlg.o wpa_ctrl.o kprofileconfigdlg.o kwlantraywin.o kscandlg.o keventhistorydlg.o kuserdatarequestdlg.o kwlansettingsdlg.o kwlaniface_skel.o kwlan.o kstartsupplicant.o kprofileconfig.o kscan.o keventhistory.o kuserdatarequest.o kwlansettings.o pref.moc.o kwlantraywin.moc.o -liw -lkio -lkdeprint
/usr/lib/libiw.a(iwlib.so): In function `iw_sockets_open': multiple definition of `iw_sockets_open'
wlanlib.o:wlanlib.cpp:(.text+0x0): first defined here
/usr/bin/ld: Warning: size of symbol `iw_sockets_open' changed from 67 in wlanlib.o to 81 in /usr/lib/libiw.a(iwlib.so)
collect2: ld returned 1 exit status

I tried package versions 27+28pre14-1 (testing) and 27+28pre15-1 (unstable) of libiw28 and libiw-dev... ideas?!

danone


Reply to this

-

 Re: problem with 0.2

 
 by tmichel on: Mar 30 2006
 
Score 50%

Hi,

I am using libiw-dev and libiw28 here without problems (kubuntu dapper).
Do you have multiple versions of iwlib installed?


Reply to this

-

 Re: Re: problem with

 
 by danone on: Mar 30 2006
 
Score 50%

no, there's only this one package called libiw28 and the devel. package libiw-dev - both with version mentioned above

danone


Reply to this

-

 Re: Re: Re: problem

 
 by danone on: Mar 30 2006
 
Score 50%

same error with 0.2.2
what does this error message mean???
any hints???


Reply to this

-
.

 i found out, that...

 
 by danone on: Mar 31 2006
 
Score 50%

I manually fixed the linking problem by modfifying the generated src/Makefile, line 270,271:

# the libraries to link against.
kwlan_LDADD = -liw $(LIB_KFILE) $(LIB_KDEPRINT)

to:

# the libraries to link against.
kwlan_LDADD = /lib/libiw.so $(LIB_KFILE) $(LIB_KDEPRINT)

-liw is replaced by /usr/lib/libiw.a - this produced the error. Strangely enough both files belong to the same package libiw-dev...

May a configure problem? I used "configure --prefix=/usr", but executing "make" "configure" seems to be run again... Maybe that breaks something? I tried "configure --prefix=/usr --libdir=/lib" but it didn't work either.

Suggestions??

danone


Reply to this

-

 Re: Re: problem with

 
 by tmichel on: Apr 1 2006
 
Score 50%

Hi,

please try out version 0.2.3 as I was told (thanks to Valentine Sinitsyn) that I defined this function twice.


Reply to this

-

 package

 
 by visik7 on: Mar 30 2006
 
Score 50%

any ubuntu packages ?


Reply to this

-

 Re: package

 
 by tmichel on: Apr 1 2006
 
Score 50%

Sorry, not yet. KWlan is under hevy development at the moment and I did not find the time to look into the creation of binary packages. As soon as I've implemented most of the requested stuff, removed bugs and cleaned up code I will look into it.


Reply to this

-

 Re: package

 
 by tmichel on: Apr 3 2006
 
Score 50%

Hi, I've made a first ubuntu package. If your interested, send me your email address and I'll send it to you.

Regards,

Tom.


Reply to this

-
.

 won't build

 
 by ademmer1977 on: Apr 4 2006
 
Score 50%

I wanted to give this app a try, but the latest and the previous release won't build.

Configure works fine, but make quits:

make
cd . && make -f admin/Makefile.common configure.in ;
make[1]: Entering directory `/home/ademmer/Downloads/kwlan.kdevelop'
make[1]: Leaving directory `/home/ademmer/Downloads/kwlan.kdevelop'
cd . && /bin/sh /home/ademmer/Downloads/kwlan.kdevelop/admin/missing --run aclocal-1.7
/home/ademmer/Downloads/kwlan.kdevelop/admin/missing: line 46: aclocal-1.7: command not found
WARNING: `aclocal-1.7' is missing on your system. You should only need it if
you modified `acinclude.m4' or `configure.in'. You might want
to install the `Automake' and `Perl' packages. Grab them from
any GNU archive site.
cd . && \
/bin/sh /home/ademmer/Downloads/kwlan.kdevelop/admin/missing --run automake-1.7 --gnu Makefile
/home/ademmer/Downloads/kwlan.kdevelop/admin/missing: line 46: automake-1.7: command not found
WARNING: `automake-1.7' is missing on your system. You should only need it if
you modified `Makefile.am', `acinclude.m4' or `configure.in'.
You might want to install the `Automake' and `Perl' packages.
Grab them from any GNU archive site.
cd . && perl admin/am_edit Makefile.in
cd . && rm -f configure
cd . && make -f admin/Makefile.common configure
make[1]: Entering directory `/home/ademmer/Downloads/kwlan.kdevelop'
configure.in:39: error: possibly undefined macro: AM_INIT_AUTOMAKE
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.in:44: error: possibly undefined macro: AM_CONFIG_HEADER
configure.in:47: error: possibly undefined macro: AC_CHECK_COMPILERS
configure.in:48: error: possibly undefined macro: AC_ENABLE_SHARED
configure.in:49: error: possibly undefined macro: AC_ENABLE_STATIC
configure.in:54: error: possibly undefined macro: AM_KDE_WITH_NLS
configure.in:57: error: possibly undefined macro: AC_PATH_KDE
configure.in:62: error: possibly undefined macro: AC_CHECK_KDEMAXPATHLEN
make[1]: *** [configure] Fehler 1
make[1]: Leaving directory `/home/ademmer/Downloads/kwlan.kdevelop'
make: *** [configure] Fehler 2

Any ideas?


Reply to this

-

 Re: won't build

 
 by tmichel on: Apr 4 2006
 
Score 50%

Hi,

in your post i read:

WARNING: `aclocal-1.7' is missing on your system. You should only need it if
you modified `acinclude.m4' or `configure.in'. You might want
to install the `Automake' and `Perl' packages. Grab them from
any GNU archive site.


You should do as suggested - I used automake 1.7 during development.
If you use kubuntu, a debian package is available at http://home.arcor.de/tom.michel


Reply to this

-

 Re: Re: won't build

 
 by NeilMonday on: Apr 4 2006
 
Score 50%

Could you possibly make it use the latest automake version for newer releases? Trying to downgrade to automake 1.7 is a pain in the butt. Im sure its an awesome app and I can't wait to use it once i can install automake 1.7.


Reply to this

-

 Re: Re: Re: won't bu

 
 by tmichel on: Apr 4 2006
 
Score 50%

Hi,

I just put together 0.3.0 and tested it with automake-1.9.

Please give it a try.


Reply to this

-
.

 Re: Re: Re: Re: won't bu

 
 by herwig on: Apr 4 2006
 
Score 50%

It is still complaining about aclocal-1.7 (under Suse 10.0)


Reply to this

-

 Re: won't build

 
 by tmichel on: Apr 4 2006
 
Score 50%

Hi,

in your post i read:

WARNING: `aclocal-1.7' is missing on your system. You should only need it if
you modified `acinclude.m4' or `configure.in'. You might want
to install the `Automake' and `Perl' packages. Grab them from
any GNU archive site.


You should do as suggested - I used automake 1.7 during development.
If you use kubuntu, a debian package is available at http://home.arcor.de/tom.michel


Reply to this

-

 make error

 
 by NeilMonday on: Apr 4 2006
 
Score 50%

/usr/include/linux/if.h:94: error: redefinition of ‘struct ifmap’
/usr/include/net/if.h:111: error: previous definition of ‘struct ifmap’
/usr/include/linux/if.h:130: error: redefinition of ‘struct ifreq’
/usr/include/net/if.h:126: error: previous definition of ‘struct ifreq’
/usr/include/linux/if.h:180: error: redefinition of ‘struct ifconf’
/usr/include/net/if.h:176: error: previous definition of ‘struct ifconf’
wlanlib.cpp: In function ‘QStringList getInterfaces(QWidget*)’:
wlanlib.cpp:51: warning: comparison between signed and unsigned integer expressions
make[2]: *** [wlanlib.o] Error 1
make[2]: Leaving directory `/root/kwlan.kdevelop/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/kwlan.kdevelop'
make: *** [all] Error 2


Reply to this

-

 Re: make error

 
 by bluebrother on: Apr 4 2006
 
Score 50%

compiles with the following changes -- but crashes upon exit. Also some dialogs look really strange ...

--- src/wlanlib.cpp.orig 2006-04-01 14:07:22.000000000 +0200
+++ src/wlanlib.cpp 2006-04-04 23:24:51.000000000 +0200
@@ -5,7 +5,7 @@
#include <qstringlist.h>
//#include <linux/socket.h>
#include <sys/socket.h>
-#include <net/if.h>
+//#include <net/if.h>
#include <sys/types.h>
#include <sys/ioctl.h>
#include <stdio.h>
@@ -135,7 +135,7 @@
char buffer[IW_ESSID_MAX_SIZE];
if (m_socket < 0)
return QString::null;
- wrq.u.essid.pointer = &buffer;
+ wrq.u.essid.pointer = &buffer[0];
wrq.u.essid.length = IW_ESSID_MAX_SIZE;
if (iw_get_ext(m_socket, m_ifname.ascii(), SIOCGIWESSID, &wrq) >= 0)
return QString::fromAscii((char *)wrq.u.essid.pointer, wrq.u.essid.length);


Reply to this

-
.

 scan results window

 
 by oshogg on: Apr 5 2006
 
Score 50%

Hi,

Great appl. I love it very much. I really hope this will develop in a full-fledged application.

One bug: When I select on Scan, it displays the window with Scan results. Now, if I resize the scan results window - the content is not resized to fit the new window size. Just a minor issue.

Osho


Reply to this

-

 Re: scan results win

 
 by NickelGuy on: Apr 5 2006
 
Score 50%

Totally agree, great App. This type of app has been sorely missing for awhile. Quick comment though: when you disable wpa_supplicant the systray icon does not go back to the disconnected icon, but instead changes to the low signal strength icon.


Reply to this

-
.

 SuSE 10 Comp Error

 
 by linux3114a on: Apr 5 2006
 
Score 50%

e -DQT_THREAD_SUPPORT -D_REENTRANT -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -O2 -g -march=i586 -mtune=i686 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -MT wlanlib.o -MD -MP -MF ".deps/wlanlib.Tpo" -c -o wlanlib.o wlanlib.cpp; \
then mv -f ".deps/wlanlib.Tpo" ".deps/wlanlib.Po"; else rm -f ".deps/wlanlib.Tpo"; exit 1; fi
/usr/include/linux/if.h:94: error: redefinition of ‘struct ifmap’
/usr/include/net/if.h:111: error: previous definition of ‘struct ifmap’
/usr/include/linux/if.h:130: error: redefinition of ‘struct ifreq’
/usr/include/net/if.h:126: error: previous definition of ‘struct ifreq’
/usr/include/linux/if.h:180: error: redefinition of ‘struct ifconf’
/usr/include/net/if.h:176: error: previous definition of ‘struct ifconf’
wlanlib.cpp: In function ‘QStringList getInterfaces(QWidget*)’:
wlanlib.cpp:51: warning: comparison between signed and unsigned integer expressions
make[2]: *** [wlanlib.o] Erreur 1
make[2]: Leaving directory `/usr/src/packages/BUILD/kwlan-0.2.3/src'
make[1]: *** [all-recursive] Erreur 1
make[1]: Leaving directory `/usr/src/packages/BUILD/kwlan-0.2.3'
make: *** [all] Erreur 2
error: Bad exit status from /var/tmp/rpm-tmp.77856 (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.77856 (%build)


raoul
Reply to this

goto page: prev   1  2  3  4  5  6  7  8  9 ...

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.