-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (2) .- Knowledge Base  . 

PDFedit

   0.3.1s  

KDE Text Editor

Score 86%
PDFedit
zoom


PDFedit
zoom


Link:  Link
Minimum required   Qt 3.x
Downloads:  10912
Submitted:  Jan 18 2007
Updated:  May 2 2007

Description:

Complete editing of pdf documents is easy with PDFedit. You can change either raw pdf objects (for advanced users) or use predefined gui functions. For any support please follow steps at http://sourceforge.net/support/getsupport.php?group_id=177354




Changelog:

0.3.1:
* german translation (thanks to Andreas Mantke)
* minor gui enhancements (added some missing tooltips...)
* bugfixes

0.3:
* Cygwin version
* russian translation
* speed ups
* bugfixes
* installation bugfixes

0.2.5:
* Bugfixes

0.2.4:
* 64bit compilability fix
* Fixed bug with units precision, 1234pt showing up as 1.23e+3pt
* Console scripts bug fixed (not running scripts from current directory)
* Added QSPdf.save() function
* Spanish translation added

0.2.3:
+ page rotation, text extraction,
+ simple drawing, lines, rectangles, layer control
+ revision control
+ text operations, highlight, strike through, delete, simple add, moving, color changing
+ simple pdf to xml support
+ everything based on QSA scripting language
+ access to raw pdf objects
...

Special devel features:
+ pdf to whatever format support




LicenseGPL
Send to a friend
Subscribe
Other  Apps  from misuj1am
Report inappropriate content



goto page: prev   1  2  3  4  5  6 

-

 Doesn't see bost lib

 
 by Xaleandr on: Jan 21 2007
 
Score 50%

Hello,

I tried to install pdfedit.
I installed the boost libaries [http://boost.org ], but somewhy pdf edit doesn't see them :
I get "You need boost libraries ..." message

[I checked that there ARE libboost_... libraries in /usr/local/lib ]

What could be the reason ???

Thanks in advance,
Xaleandr


Reply to this

-

 Re: Doesn't see bost lib

 
 by g2rp on: Jan 22 2007
 
Score 50%

maybe because you have to install the boost developement, in ferdora its boost-dev. It happened to me too, i hope it'll help you


Reply to this

-
.

 Re: Doesn't see

 
 by Xaleandr on: Jan 22 2007
 
Score 50%

Thanks a lot !

The problem was really due to the absence of boost-dev


Reply to this

-
.

 Re: Re: Doesn't see

 
 by ffelix on: Jan 26 2007
 
Score 50%

Hello.
I am suffering the same problem. I downloaded the latest version of the boost libs and compiled it (it took forever). Everything is installed as it should be. Nevertheless the compilation of pdfedit ist not possible due to the error pointed out before. Is there any way to prescribe the search path?

This problem occured when trying to install pdfedit on my private computer running Kubuntu Hoary (I do not see any use in upgrading since it is pretty much customized). I then attempted an installation on a Fedora Core 6 system which did not lead to full success so far. In particular, I get the following error when trying to compile:

QOutputDevPixmap.cpp: In constructor »QOutputDevPixmap::QOutputDevPixmap(Guchar*)«:
QOutputDevPixmap.cpp:39: Fehler: Aufruf des überladenen »QImage(int)« ist mehrdeutig
/usr/include/QtGui/qimage.h:104: Anmerkung: Kandidaten sind: QImage::QImage(const char*, const char*)
/usr/include/QtGui/qimage.h:102: Anmerkung: QImage::QImage(const QString&, const char*)
/usr/include/QtGui/qimage.h:100: Anmerkung: QImage::QImage(const char* const*)
QOutputDevPixmap.cpp: In member function »virtual void QOutputDevPixmap::endPage()«:
QOutputDevPixmap.cpp:62: Fehler: »class QImage« hat kein Element namens »reset«
QOutputDevPixmap.cpp:78: Fehler: »IgnoreEndian« ist kein Element von »QImage«

(Sorry for the german error messages, our SysAdmin is responsible for the crappy setup and theres unfortunately nothing I can do about this.)

Can anyone give me a hint how to install the programm without running into this much trouble? Are there any packages (either deb rpm or whatever) available somewhere?

Thanks.


best,
felix

Reply to this

-

 Re: Re: Re: Doesn't see

 
 by bedahr on: Jan 26 2007
 
Score 50%

Same here @ Gentoo...

Any solution to this?

--bedahr


Reply to this

-

 Re: Re: Re: Doesn't see

 
 by ahorseman on: Jan 31 2007
 
Score 50%
ahorsemanahorseman
University of Lancaster

The problem is that, by default, the boost headers are installed in /usr/local/include/boost-?_??_?/boost and the pdfedit configure expects them to be in /usr/local/include/boost.
A simple symbolic link gets around the problem.


Reply to this

-
.

 Re: Doesn't see bost lib

 
 by BorgQueen on: Feb 7 2007
 
Score 50%

HI same problem but I do have the devel packages installed. Any ideas why it would fail to see this? Latest version of boost btw.


Reply to this

-

 compile fails on x86

 
 by nbecker on: Jan 23 2007
 
Score 50%

g++ -c -pipe -DQT_CLEAN_NAMESPACE -g -Wall -W -g -O0 -DQT_SHARED -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -I/usr/lib64/qt-3.3/mkspecs/default -I. -I../qsa/src/qsa -I.. -I../utils -I../xpdf -I../xpdf/xpdf -I../xpdf/goo -I../kernel -I../kpdf-kde-3.3.2 -I../xpdf/splash -I/usr/lib64/qt-3.3/include -I.ui/ -I.moc/ -o .obj/basegui.o basegui.cc
../utils/observer.h: In instantiation of ‘observer::ObserverHandler’:
../kernel/iproperty.h:134: instantiated from here
../utils/observer.h:529: warning: ‘observer::ObserverHandler’ has a field ‘observer::ObserverHandler::observers’ whose type uses the anonymous namespace
../utils/observer.h: In instantiation of ‘observer::ObserverHandler’:
../kernel/ccontentstream.h:82: instantiated from here
../utils/observer.h:529: warning: ‘observer::ObserverHandler’ has a field ‘observer::ObserverHandler::observers’ whose type uses the anonymous namespace
../utils/observer.h: In instantiation of ‘observer::ObserverHandler’:
../kernel/cannotation.h:344: instantiated from here
../utils/observer.h:529: warning: ‘observer::ObserverHandler’ has a field ‘observer::ObserverHandler::observers’ whose type uses the anonymous namespace
../utils/observer.h: In instantiation of ‘observer::ObserverHandler’:
../kernel/cpage.h:312: instantiated from here
../utils/observer.h:529: warning: ‘observer::ObserverHandler’ has a field ‘observer::ObserverHandler::observers’ whose type uses the anonymous namespace
../utils/observer.h: In instantiation of ‘observer::ObserverHandler’:
../kernel/pdfwriter.h:281: instantiated from here
../utils/observer.h:529: warning: ‘observer::ObserverHandler’ has a field ‘observer::ObserverHandler::observers’ whose type uses the anonymous namespace
basegui.cc: In member function ‘QVariant gui::BaseGUI::selectPagesDialog(const QString&) const’:
basegui.cc:530: error: conversion from ‘long unsigned int’ to ‘const QVariant’ is ambiguous
/usr/lib64/qt-3.3/include/qvariant.h:169: note: candidates are: QVariant::QVariant(double)
/usr/lib64/qt-3.3/include/qvariant.h:166: note: QVariant::QVariant(Q_ULLONG)
/usr/lib64/qt-3.3/include/qvariant.h:165: note: QVariant::QVariant(Q_LLONG)
/usr/lib64/qt-3.3/include/qvariant.h:164: note: QVariant::QVariant(uint)
/usr/lib64/qt-3.3/include/qvariant.h:163: note: QVariant::QVariant(int)
/usr/lib64/qt-3.3/include/qvariant.h:131: note: QVariant::QVariant(const char*)
make[2]: *** [.obj/basegui.o] Error 1


Reply to this

-

 Re: compile fails on

 
 by misuj1am on: Jan 26 2007
 
Score 50%

please try this patch

03:18:25.000000000 +0100
/** @file
GUI Base - class containing extra functionalyty presen only in GUI
@author Martin Petricek
*/

@@ -523,11 +523,11 @@
// Starts dialog as modal and do something if OK is pressed
if(QDialog::Accepted == dialog->exec())
{
// Get result and craete QVariant from it using QValueList
StdItems stditems;
dialog->getResult (stditems);
for (StdItems::iterator it = stditems.begin(); it != stditems.end(); ++it)
- qitems.append ((uint)*it);
+ qitems.append (*it);
qvitems = QVariant(qitems);
}
// Cleanup


Reply to this

-

 klik://pdfedit

 
 by pfeifle on: Jan 26 2007
 
Score 50%
pfeiflepfeifle
Infotec Deutschland GmbH
editor
Home
-
Kurt Pfeifle 0

Infotec Deutschland GmbH
Germany, stuttgart
Last visit Jan 24 2011
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

klik://pdfedit is now defaulting to the new version 0.2.3 (See also: http://pdfedit.klik.atekon.de/ )

If you have the klik client installed, just click on this link: klik://pdfedit

To install the klik client, run this command (as user!, not as root) in a konsole or an "[alt]+[f2]" mini-cli:

   wget klik.atekon.de/client/install -O -|sh

If you don't know what klik is: see http://klik.atekon.de/wiki/index.php/What_is_klik
If you have more questions: see http://klik.atekon.de/wiki/index.php/User%27s_FAQ
If you want to see the user comments about klik+pdfedit: http://pdfedit.klik.atekon.de/comments/

Cheers,
Kurt


Reply to this

-
.

 Slow on Kubuntu

 
 by sorush on: Jan 27 2007
 
Score 50%

I get a lot of slow responses on journals downloaded from the internet.
Don't know why but might be able to find out later. I used this package.
http://members.chello.cz/gliding/pdfedit_0.2.3_i386.deb
for the kubuntu edgy 6.10


Reply to this

-
.

 0.2.4 qt3 and qt4

 
 by anli on: Jan 28 2007
 
Score 50%

Have tried 0.2.4 with these env

QTDIR=/usr/qt/3/ QMAKESPEC="/usr/qt/3/mkspecs/linux-g++"

and have got the same error - 'src/kpdf-kde-3.3.2' dir still doesn't see qt3 :-(


Reply to this

-
.

 qt3/qt4 SOLVED

 
 by anli on: Jan 28 2007
 
Score 50%

... this way:

PATH=/usr/qt/3/bin:$PATH; QTDIR=/usr/qt/3/; QMAKESPEC="/usr/qt/3/mkspecs/linux-g++"; ./configure --prefix=/usr/local


Reply to this

-

 Re: qt3/qt4 SOLVED

 
 by davepb on: Jan 30 2007
 
Score 50%

Thanks

I've been looking around for weeks for this fix. It's a pity they don't state this on their website!

Dave


Reply to this

-

 -lqt-mt

 
 by collinm on: Jan 30 2007
 
Score 50%

when i buil i get

/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../x86_64-suse-linux/bin/ld: cannot find -lqt-mt
collect2: ld returned 1 exit status


www.laboiteaprog.com
Reply to this

goto page: prev   1  2  3  4  5  6 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.