-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (12) .- Knowledge Base  . 

Semantik

   0.9.1  

KDE Education

Score 81%
Semantik
zoom


Semantik
zoom


Semantik
zoom


Link:  Link
Minimum required   KDE 4.x
Downloads:  9911
Submitted:  Mar 26 2007
Updated:  Jan 14 2014

Description:

Semantik - a mindmapping-like tool for document generation (reports, thesis, etc).

The requirements are:

Runtime:
KDE4 >= 4.8
Python >= 2.3 && Python < 3.0

Compilation:
KDE4 development packages (kdebase-devel)
Python2 development package
The objective caml compilers (ocaml)
The program kde4-config in the PATH

Some systems may require special compilation options such as:
PYTHON=python2 PYTHON_VERSION=2.7 waf configure build




Changelog:

Semantik 0.9.1
--------------
* Svg map export
* Odt template fixes
* Include svg pictures in odt documents
* command-line svg export
* More reasonable size for the actors head
* Prevent the memory corruption when opening the same recent file again
* Make the text visible in the odt document created (Issue 27)
* fixed the diagram top/bottom alignment function
* Copy diagram pictures to clipboard from main window
* Copy diagrams to the clipboard

Semantik 0.9.0
--------------
* New application for editing and managing diagrams
* Enhanced printing system from the menu
* Print diagrams from the command-line
* Fixed the jitter on the drawing area

Semantik 0.8.4
--------------
* Export maps to pdf pictures from the command-line
* Color scheme fixes #30
* Null byte fix for text pasted from Chrome #26

Semantik 0.8.3
--------------
* New dialog for exporting the map as a picture with a specific size
* More consistent gui elements (dialog buttons, menus)
* New UML shapes
* Straight arrows on the diagrams

Semantik 0.8.2
--------------
* Fixed several crashes
* Fixe various LaTeX templates
* New actor and usecase elements




LicenseGPL
(semantik)
Send to a friend
Subscribe
Other  Apps  from ita256
Report inappropriate content



goto page: prev   1  2  3  4  5  6  7  8  9 

-

 kdi importing?

 
 by petercruickshank on: Jul 6 2007
 
Score 50%

Hi, I know you told me that this program is not finished yet, but can you say yet whether kdissert files are planned to be importable in the finished Semantik application?


Reply to this

-

 Re: kdi importing?

 
 by ita256 on: Jul 6 2007
 
Score 50%

The kdi files can be imported already (v0.4.2).


Reply to this

-
.

 installation Kubuntu

 
 by erincong on: Jul 29 2007
 
Score 50%

Hi, I want to install Semantik 0.48 on Kubuntu 7.04, but after ./waf configure I get these error
-----------
./waf configure
Checking for program g++ : ok /usr/bin/g++
Checking for program cpp : ok /usr/bin/cpp
Checking for program ar : ok /usr/bin/ar
Checking for program ranlib : ok /usr/bin/ranlib
Checking for compiler could create pragramms : ok
Checking for compiler could create shared libs : ok
Checking for compiler could create static libs : ok
Checking for flags -Wall : ok
Checking for flags -O2 : ok
Checking for flags -g -DDEBUG : ok
Checking for flags -g3 -O0 -DDEBUG : ok
Checking for program qmake-qt4 : not found
Checking for program qmake4 : not found
Checking for program qmake : not found
Checking for header QtGui/QFont : not found
cannot find QtGui/QFont in ['include/', '/usr/share/qt4/include/', '/opt/qt4/include', '/usr/include/', '/usr/local/include/']
------------------------------

What I need to do.

Tkanks to all


Emilio
Reply to this

-

 Re: installation Kubuntu

 
 by ita256 on: Jul 29 2007
 
Score 50%

Install Qt development packages (Qt >= 4.2), i think it is called libqt4-dev


Reply to this

-
.

 Re: Re: installation

 
 by erincong on: Jul 29 2007
 
Score 50%

Thanks, after installed libqt4-dev there are new erros, can you help me?

-------------------------
Checking for program g++ : ok /usr/bin/g++
Checking for program cpp : ok /usr/bin/cpp
Checking for program ar : ok /usr/bin/ar
Checking for program ranlib : ok /usr/bin/ranlib
Checking for compiler could create pragramms : ok
Checking for compiler could create shared libs : ok
Checking for compiler could create static libs : ok
Checking for flags -Wall : ok
Checking for flags -O2 : ok
Checking for flags -g -DDEBUG : ok
Checking for flags -g3 -O0 -DDEBUG : ok
Checking for program qmake-qt4 : ok /usr/bin/qmake-qt4
Checking for header QtGui/QFont : ok /usr/include/qt4
Checking for program uic-qt3 : not found
Checking for program uic3 : ok /usr/bin/uic3
Checking for program uic-qt4 : ok /usr/bin/uic-qt4
Checking for uic version : ok (version 4.2.3)
Checking for program moc-qt4 : ok /usr/bin/moc-qt4
Checking for program rcc : ok /usr/bin/rcc
Checking for program lrelease : ok /usr/bin/lrelease
Checking for program lupdate : ok /usr/bin/lupdate
Checking for package Qt3Support_debug : not found
Checking for package QtCore_debug : not found
Checking for package QtGui_debug : not found
Checking for package QtNetwork_debug : not found
Checking for package QtOpenGL_debug : not found
Checking for package QtSql_debug : not found
Checking for package QtSvg_debug : not found
Checking for package QtTest_debug : not found
Checking for package QtXml_debug : not found
Checking for package Qt3Support : ok
Checking for package QtCore : ok
Checking for package QtGui : ok
Checking for package QtNetwork : ok
Checking for package QtOpenGL : ok
Checking for package QtSql : ok
Checking for package QtSvg : ok
Checking for package QtTest : ok
Checking for package QtXml : ok
Checking for program python : ok /usr/bin/python
Checking for Python version >= 2.4.2 : ok 2.5.1
Checking for library python2.5 : ok
Checking for header Python.h : ok
Checking for program ocamlopt : not found
Checking for program ocamlc : not found
The objective caml compiler was not found:
install it or make it availaible in your PATH
--------------


Emilio
Reply to this

-
.

 Re: Re: Re: installation

 
 by ita256 on: Jul 29 2007
 
Score 50%

The error message looks pretty clear, the ocaml compiler needs to be installed too. Before you ask, Python-dev is needed too, but this is written in the project description already (look above).


Reply to this

-
.

 problems....

 
 by sonicprogress on: Jul 30 2007
 
Score 50%

Errors from ./waf configure

Checking for package Qt3Support_debug (cached) : not found
Checking for package QtCore_debug (cached) : not found
Checking for package QtGui_debug (cached) : not found
Checking for package QtNetwork_debug (cached) : not found
Checking for package QtOpenGL_debug (cached) : not found
Checking for package QtSql_debug (cached) : not found
Checking for package QtSvg_debug (cached) : not found
Checking for package QtTest_debug (cached) : not found
Checking for package QtXml_debug (cached) : not found
Checking for package Qt3Support_debug (cached) : not found
Checking for package QtCore_debug (cached) : not found
Checking for package QtGui_debug (cached) : not found
Checking for package QtNetwork_debug (cached) : not found
Checking for package QtOpenGL_debug (cached) : not found
Checking for package QtSql_debug (cached) : not found
Checking for package QtSvg_debug (cached) : not found
Checking for package QtTest_debug (cached) : not found
Checking for package QtXml_debug (cached) : not found

./waf

[62/62] * cpp_link : build/default/src/AbLaK.o build/default/src/AblaK.o build/default/src/Ablak.o build/default/src/Aux.o build/default/src/BnvzS.o build/default/src/BnvzS_py.o build/default/src/Bnvzs.o build/default/src/Bnvzs_rc.o build/default/src/Egyenes.o build/default/src/Eldz.o build/default/src/Fbjrt.o build/default/src/Flult.o build/default/src/Izlt.o build/default/src/IztKil.o build/default/src/Iztpr.o build/default/src/Jelzpn.o build/default/src/Magyaraz.o build/default/src/OzzK.o build/default/src/Prmza.o build/default/src/Prn.o build/default/src/Rslt.o build/default/src/Sbln.o build/default/src/Szines.o build/default/src/Szrt.o build/default/src/Vadrt.o build/default/src/elgyk.o build/default/src/armtlkto.o build/default/camlprog.o build/default/tsts_rc.o -> build/default/src/semantik
Compilation finished successfully

When i run it:

ASSERT: "visual != -1" in file itemviews/qheaderview.cpp, line 1101
Aborted (core dumped)

I'm using Kubuntu Feisty
packages installed: libqt4-dev ocaml Python-dev


Reply to this

-
.

 Re: problems....

 
 by ita256 on: Jul 30 2007
 
Score 50%

What Qt version are you using ?

Also, could you please re-compile the project using this:
waf distclean; waf configure --nocache; waf --nocache; sudo waf install


Reply to this

-

 Re: problems....

 
 by giuped on: Jul 31 2007
 
Score 50%
giupedgiuped
DigiMix Multimedia
Home
-
Giuseppe B. 6

DigiMix Multimedia
Italy, Catania
Last visit Aug 10 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Same problem: --nocache give same error:
Quote:
ASSERT: "visual != -1" in file itemviews/qheaderview.cpp, line 1101
Aborted (core dumped)




Giuped
Reply to this

-
.

 Re: Re: problems....

 
 by ita256 on: Aug 1 2007
 
Score 50%

This problem does not occur with a qt4.3.0 compiled from source, i am looking for the reason.


Reply to this

-

 Re: Re: problems....

 
 by giuped on: Jul 31 2007
 
Score 50%
giupedgiuped
DigiMix Multimedia
Home
-
Giuseppe B. 6

DigiMix Multimedia
Italy, Catania
Last visit Aug 10 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

On kubuntu feisty lbQT4-dev version is 4.3.0


Giuped
Reply to this

-

 Re: Re: Re: problems....

 
 by GFD on: Aug 1 2007
 
Score 50%

No in Feisty, libQt version is 4.2 but 4.3 with backport repos. It works only with the 4.2 version.


Reply to this

-

 Italian Translation

 
 by giuped on: Jul 31 2007
 
Score 50%
giupedgiuped
DigiMix Multimedia
Home
-
Giuseppe B. 6

DigiMix Multimedia
Italy, Catania
Last visit Aug 10 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Do you need Italian Translation? I have seen it.ts exist but is not translated.
(I'm the "old" Kdissert's italian translator, remember me? ;) )


Giuped
Reply to this

-
.

 Re: Italian Translation

 
 by ita256 on: Aug 1 2007
 
Score 50%

You may.

For now Semantik does not have the KDE libraries, and i am still undecided on the translation system to use (remain Qt-only or use the KDE one ?).

The strings are also subject to change (the variables in the code completion), and have not been reviewed yet.

It is difficult to keep the translations up-to-date but it can be done if you have a particular requirement.


Reply to this

-

 0.4.9b on Mac OS X

 
 by jstrube on: Aug 1 2007
 
Score 50%

I am trying to install on Mac OS X.
I am pretty confident that I have all the prerequisites. However,
Quote:
> ./waf configure --nocache
Checking for program g++ : ok /usr/bin/g++
Checking for program cpp : ok /usr/bin/cpp
Checking for program ar : ok /usr/bin/ar
Checking for program ranlib : ok /usr/bin/ranlib
Checking for compiler could create pragramms : ok
Checking for compiler could create shared libs : ok
Checking for compiler could create static libs : ok
Checking for flags -Wall : ok
Checking for flags -O2 : ok
Checking for flags -g -DDEBUG : ok
Checking for flags -g3 -O0 -DDEBUG : ok
Checking for header QtGui/QFont : ok /usr/local/Trolltech/Qt-4.3.0/include/
Checking for program uic-qt3 : not found
Checking for program uic3 : ok /usr/local/Trolltech/Qt-4.3.0/bin/uic3
Checking for program uic-qt4 : not found
Checking for program uic : ok /usr/local/Trolltech/Qt-4.3.0/bin/uic
Checking for uic version : ok (version 4.3.0)
Checking for program moc-qt4 : not found
Checking for program moc : ok /usr/local/Trolltech/Qt-4.3.0/bin/moc
Checking for program rcc : ok /usr/local/Trolltech/Qt-4.3.0/bin/rcc
Checking for program lrelease : ok /usr/local/Trolltech/Qt-4.3.0/bin/lrelease
Checking for program lupdate : ok /usr/local/Trolltech/Qt-4.3.0/bin/lupdate
Checking for framework Qt3Support : not found
Checking for framework QtCore : ok
Checking for framework QtGui : ok
Checking for framework QtNetwork : ok
Checking for framework QtOpenGL : ok
Checking for framework QtSql : ok
Checking for framework QtSvg : ok
Checking for framework QtTest : ok
Checking for framework QtXml : ok
Checking for program python : ok /usr/local/bin/python
Checking for Python version >= 2.4.2 : ok 2.5.1
Checking for library python2.5 : not found
Checking for library python2.5 : ok
Checking for header Python.h : ok
Checking for program ocamlopt : ok /sw/bin/ocamlopt
Checking for program ocamlc : ok /sw/bin/ocamlc
Checking for program ocamllex : ok /sw/bin/ocamllex
Checking for program ocamlyacc : ok /sw/bin/ocamlyacc


then it dies with
Quote:
[18/44] * rcc : build/default/tsts.qrc -> build/default/tsts_rc.cpp
Traceback (most recent call last):
File "/Users/jstrube/Downloads/semantik-0.4.9b/waf", line 321, in <module>
try: Scripting.Main()
File "/Users/jstrube/Downloads/semantik-0.4.9b/.waf-1.1.1-1534209504/wafadmin/Scripting.py", line 211, in Main
ret = bld.compile()
File "/Users/jstrube/Downloads/semantik-0.4.9b/.waf-1.1.1-1534209504/wafadmin/Build.py", line 178, in compile
ret = executor.start()
File "/Users/jstrube/Downloads/semantik-0.4.9b/.waf-1.1.1-1534209504/wafadmin/Runner.py", line 247, in start
if not proc.must_run():
File "/Users/jstrube/Downloads/semantik-0.4.9b/.waf-1.1.1-1534209504/wafadmin/Task.py", line 196, in must_run
self.m_dep_sig = self.m_scanner.get_signature(self)
File "/Users/jstrube/Downloads/semantik-0.4.9b/.waf-1.1.1-1534209504/wafadmin/Scan.py", line 28, in get_signature
ret = self._get_signature(task)
File "/Users/jstrube/Downloads/semantik-0.4.9b/.waf-1.1.1-1534209504/wafadmin/Scan.py", line 74, in _get_signature
return self._get_signature_default_strong(task)
File "/Users/jstrube/Downloads/semantik-0.4.9b/.waf-1.1.1-1534209504/wafadmin/Scan.py", line 105, in _get_signature_default_strong
for node in task.m_inputs: add_node_sig(node)
File "/Users/jstrube/Downloads/semantik-0.4.9b/.waf-1.1.1-1534209504/wafadmin/Scan.py", line 89, in add_node_sig
if tree.needs_rescan(node, env): self.do_scan(node, env, task.m_scanner_params)
File "/Users/jstrube/Downloads/semantik-0.4.9b/.waf-1.1.1-1534209504/wafadmin/Scan.py", line 63, in do_scan
tree.m_deps_tstamp[variant][node] = tree.m_tstamp_variants[variant][node]
KeyError: <b:/Users/jstrube/Downloads/semantik-0.4.9b/src/AbLaK.h>


This error has come up with every version of semantik so far. Please note that I _do_ have Qt3Support
l -d /usr/local/Trolltech/Qt-4.3.0/include/Qt3Support
drwxr-xr-x 296 root wheel 9.9K Jul 31 18:43 /usr/local/Trolltech/Qt-4.3.0/include/Qt3Support

Any help is geatly appreciated.
Cheers


Reply to this

-

 Re: 0.4.9b on Mac OS

 
 by ita256 on: Aug 1 2007
 
Score 50%

Do you have Qt3 too on the system ?


Reply to this

-

 Re: Re: 0.4.9b on Ma

 
 by jstrube on: Aug 2 2007
 
Score 50%

yes, I do, but only for X11. It's in a completely different location, though.
I have tried to figure out how waf checks for the directories, but it's too smart for me ;-)


Reply to this

-

 Re: Re: Re: 0.4.9b o

 
 by jstrube on: Aug 4 2007
 
Score 50%

In order to try and help debug this, I have more or less randomly started to add print statements. If you could help me narrow down where to look for the problem, I'd be very appreciative. For some reason, the file really is in the dict of tree.m_tstamp_variants, but with key 0 rather than the default. I have no idea if that helps, but I'd be happy to provide more helpful info if you tell me how.
The output of
Quote:
print 'tree', tree
print 'nodes', nodes
print 'names', names
for key, value in tree.m_tstamp_variants.items():
print key, value

in lines 64-68 of Tools/Scan.py yields
Quote:
variant default
node <b:/Users/jstrube/Downloads/semantik-0.5.0/src/AbLaK.h>
tree <Build.Build instance at 0x10d9e18>
nodes []
names []
0 {</Users/jstrube/Downloads/semantik-0.5.0/src/Vadrt.cpp>: '\x9e\xba\x94S\x08\xb6/0\x152\xb2\xe5\xc5\x068\xec', </Users/jstrube/Downloads/semantik-0.5.0/src/elgyk.cpp>: '\x11j\x11\xcf\x14\x18\x9b\xba\x8fO\xfco\x85%}?', </Users/jstrube/Downloads/semantik-0.5.0/src/Flult.cpp>: "\x98}\xca+U*,.\xfe\xe7't\x8d\xbb,B", </Users/jstrube/Downloads/semantik-0.5.0/src/elgyk.h>: '\xb4\xe3\xa3]\xebw))ui{\xcf\xb6\xe2A\xb5', </Users/jstrube/Downloads/semantik-0.5.0/src/Izlt.cpp>: '\x97\xa48\xa0\x85H\xde\xf3\xec\x17Z\xef*\xe8\xd6\x07', </Users/jstrube/Downloads/semantik-0.5.0/src/Vadrt.h>: '\xb0\xdc\x90u\xaf$\xa4\x82\xfc}r\x19\x05Y\xb4_', </Users/jstrube/Downloads/semantik-0.5.0/src/Egyenes.cpp>: '{K-!?Xa\x18\x14FTV\x8br\xacF', </Users/jstrube/Downloads/semantik-0.5.0/waf>: '\x05M\xeak5z\xae+^\xc4\xce\x14\x08$\x8bR', </Users/jstrube/Downloads/semantik-0.5.0/src/Bnvzs.qrc>: 't\x1bc\xfbu+\x06|\xa9\xc3\x13\x8a3\x86\xf2U', </Users/jstrube/Downloads/semantik-0.5.0/src/Eldz.cpp>: 'N\xedF\xad\x9cF+E\xdd\xff\xcd,\xc9\xb0Fd', </Users/jstrube/Downloads/semantik-0.5.0/src/Prmza.h>: '\x8fx\t]\x10\xf3W\xc1hN\xd3\xb5\xe5\xa6GO', </Users/jstrube/Downloads/semantik-0.5.0/example.sem>: '\x91\x89\xeb#\xa5h\x82\x18Y\xe6\x0f!B\xc2\x8d\x92', </Users/jstrube/Downloads/semantik-0.5.0/src/Prn.cpp>: '\xd4\xa2w\xbbwi\xeb\xb5\xa8\xa3\xd8\xd6\xed\x8b\xd1\x16', </Users/jstrube/Downloads/semantik-0.5.0/src/Magyaraz.h>: '\x89L\xa7\x1doz\xee}\xa9\x8b\xb1\x93Ltd8', </Users/jstrube/Downloads/semantik-0.5.0/src/Sbln.cpp>: '?\xff\xb9\x1br\xb5k\x1a5\xc3F]\xeaE\xbc\xb7', </Users/jstrube/Downloads/semantik-0.5.0/src/energia.mli>: '\xf1dSdg\xb4\x87\xd6HyU\xa9p72\x02', </Users/jstrube/Downloads/semantik-0.5.0/src/AbLaK.cpp>: '\x14\x02\x7f\xf5\xa0 o\x0c\xa1\x0b\xf7\x96\xa8|\x1d\x7f', </Users/jstrube/Downloads/semantik-0.5.0/src/Bnvzs.h>: '\xe9-ho\xaf*cGuN!\x90\x82\x8e\xc6\xf3', </Users/jstrube/Downloads/semantik-0.5.0/src/Aux.h>: '{\x8f\xc4&\x13.\xd3\x8d\xd7$\xa0\xaa\xfd\x1f\x02\xb7', </Users/jstrube/Downloads/semantik-0.5.0/src/azelott.ml>: '>\xb0\x90\xba\x16L2\x83\xff!1\xe6c\xd3\xf5!', </Users/jstrube/Downloads/semantik-0.5.0/src/Egyenes.h>: '\xd2:\xea\xcf\xc8T\x98\xc5\x8f\x11p\xb2\xf4\xb0&0', </Users/jstrube/Downloads/semantik-0.5.0/src/con.h>: 'A\x12\x1f\x9bt\x9b\xd6\x1e\x181\x00\x99W\xff\xa2\xdd', </Users/jstrube/Downloads/semantik-0.5.0/src/Iztpr.cpp>: '\x97R[\xe7\x8c\xd0\xe4\x04\xb7h\x03s#\x90\xd1w', </Users/jstrube/Downloads/semantik-0.5.0/src/Szines.cpp>: '\xac\x84`7+O\x08\x16\x1aB9\xbb{S\x0b\xd5', </Users/jstrube/Downloads/semantik-0.5.0/src/OzzK.h>: '\x95\x1ewy/\xbc3\xa8`\x18\xfd*\x83\xe9\xaa\xcb', </Users/jstrube/Downloads/semantik-0.5.0/src/Rslt.h>: '\xceG\x8a\x1b6\x03,0\xfav\xc1\xc9%<\xaa\xb3', </Users/jstrube/Downloads/semantik-0.5.0/src/Flult.h>: '\xd5\n+2t9G\xea\xc5\x9d\x08a\xd4o\x9fs', </Users/jstrube/Downloads/semantik-0.5.0/LICENSE.QPL>: '\xbb\xfdA\x1c\x05+/Ux\xb8\x087\x18\xce\x9aC', </Users/jstrube/Downloads/semantik-0.5.0/src/Jelzpn.h>: '\xf8\t\xfa|bW\x8e\xd7\xda\xea\rM\xb5\xb0M2', </Users/jstrube/Downloads/semantik-0.5.0/src/Iztpr.h>: '1\x1c\x0e5\xb6\xa3\xe8k\xdf,!\xd7\xb1\xbc\n^', </Users/jstrube/Downloads/semantik-0.5.0/src/Aux.cpp>: '\xb5\xce\xc9\xbd4\xadO\xa5+mh\x1e\x0f\x96\x83\xfb', </Users/jstrube/Downloads/semantik-0.5.0/src/semantik_ca.ts>: "'\x04\xf5\x82\xab\xd0\x1e\x0f\xe9\x8ai\xc6\xf4C\xf4T", </Users/jstrube/Downloads/semantik-0.5.0/src/Rslt.cpp>: '\xf8\x1e\xb27|\xd1\x19{;\xf8\xb9\xce\xc3\xab\xcea', </Users/jstrube/Downloads/semantik-0.5.0/src/azelott.mli>: '\x07\xfeS\x87\x11@\xe3,\xf2[\xe6\xe0\xa8d\xb9\xbd', </Users/jstrube/Downloads/semantik-0.5.0/src/IztKil.h>: '(\xce\xe6;?\xf1\xe1g%\xa4V\xfd\x02J\x03\xde', </Users/jstrube/Downloads/semantik-0.5.0/src/Bnvzs.cpp>: 'Z\\"\xec\xa9\xea\xb7Iw\xe3\xeaO\xdf\xf4^\x8b', </Users/jstrube/Downloads/semantik-0.5.0/wscript>: '\x9d\x15\xf7)\x99\x92\xb1\x12e]\xf68\x02/\x1c\xba', </Users/jstrube/Downloads/semantik-0.5.0/src/BnvzS_py.cpp>: "\x83\x19\x02\xe2\x01#\x0f\x03'z\xcc\xe8\xbcQ\xc5\xfa", </Users/jstrube/Downloads/semantik-0.5.0/src/semantik_fr.ts>: ',\xf3m\x92Z\x83\xc6\x0c\x9b\x0fp\xff\xdcG\xfc[', </Users/jstrube/Downloads/semantik-0.5.0/src/Jelzpn.cpp>: '\t"\xe8x:\x9d\xa6g\x8c\x82\x0f@\xc5\x8e@A', </Users/jstrube/Downloads/semantik-0.5.0/src/armtlkto.c>: 'o\xa9:9\xfc\x9e\xe7(\x1e\xb5mx\x89\xff\xbdO', </Users/jstrube/Downloads/semantik-0.5.0/src/AblaK.h>: '\xd6\xf9"[S\xc1\x82-\xf7\xd8i\xe9\x13\x83b\xd5', </Users/jstrube/Downloads/semantik-0.5.0/src/Magyaraz.cpp>: '\xd9\xf4W\x88H\xf1\xf1\xe0\xdd\xd9D\xb0N|6\x08', </Users/jstrube/Downloads/semantik-0.5.0/src/energia.ml>: '\xa7\xc3k\xaej)\xe5\xfa\x81#%\xc9\x8b8\x8eg', </Users/jstrube/Downloads/semantik-0.5.0/src/Fbjrt.cpp>: '\x16\xf6-\xd1\x95\xba\xba\xb8R\xef6\x89\x1f$\xd9}', </Users/jstrube/Downloads/semantik-0.5.0/.lock-wscript>: '\xdb0m\xd3"\\N\xd5X\xdb\xf6c\xccI\xb8Y', </Users/jstrube/Downloads/semantik-0.5.0/src/mozdulatlan.mli>: '\xbat\xb7\xf7\x0bO\xd8\xf0\xf09y\xc0bVe\x83', </Users/jstrube/Downloads/semantik-0.5.0/src/Prn.h>: '\xb6YH<WV[\x9eM\x96\xe8M\xafF\x80\xf3', </Users/jstrube/Downloads/semantik-0.5.0/src/Szrt.h>: 'm\x04.\x96\xa1\xc8\x98\x021*kQ\xebl\x19\xee', </Users/jstrube/Downloads/semantik-0.5.0/src/OzzK.cpp>: '\xb1~\x08\xbf\x8dF\xda(}\xaf\x86\x86\x06z,(', </Users/jstrube/Downloads/semantik-0.5.0/src/semantik_de.ts>: '@\xc5,\xaf\xf4\x95\xd2\x8b\x8bPSIL\xd6\xbe0', </Users/jstrube/Downloads/semantik-0.5.0/src/Prmza.cpp>: '-\xebz@(\xbc\x1b\x83Xw\xe0b\xec\x91\r\xea', </Users/jstrube/Downloads/semantik-0.5.0/util/ocaml+twt.ml>: '*\x87D\xa2\xc2\xdb\xdd\xa527\xa7p?\xb0\xfb\xca', </Users/jstrube/Downloads/semantik-0.5.0/src/IztKil.cpp>: '\xb1]}b \xbc\x98\x1f\x94w\x14\xeadRW\x04', </Users/jstrube/Downloads/semantik-0.5.0/src/Izlt.h>: "\xeeb\xd4v1\xc7'\x05\x8c\xda\xd1h\xe8\xd5\x84S", </Users/jstrube/Downloads/semantik-0.5.0/src/semantik_it.ts>: '@\xc5,\xaf\xf4\x95\xd2\x8b\x8bPSIL\xd6\xbe0', </Users/jstrube/Downloads/semantik-0.5.0/src/Szrt.cpp>: '@\x9c\x12\x86\x80\x9aV\xb9h"\xa8\x89ks~\xa2', </Users/jstrube/Downloads/semantik-0.5.0/src/Eldz.h>: '\x02\xd9!M\x9f\x1b\x14\xe1\x18n\x12?\xd2\xb8\xbb~', </Users/jstrube/Downloads/semantik-0.5.0/src/Szines.h>: '\xbf\x98\x11\x94\x0e\x8e\x17\xa0\xb8\xacOL\xa0\x03\n\x87', </Users/jstrube/Downloads/semantik-0.5.0/src/BnvzS.py>: '\xb0\x83\xbd\xd71\xd5Tr(\x9bQ\xebP_\xf6l', </Users/jstrube/Downloads/semantik-0.5.0/src/Sbln.h>: '\x1d\xec2 \xc0\xdb\xcf?0d\xd6\xce7\x98\xcb\x12', </Users/jstrube/Downloads/semantik-0.5.0/src/semantik_es.ts>: '@\xc5,\xaf\xf4\x95\xd2\x8b\x8bPSIL\xd6\xbe0', </Users/jstrube/Downloads/semantik-0.5.0/src/mozdulatlan.ml>: '\x83\xdb\t8\x11\xdcQ*GE\xecJE\xa9E\r', </Users/jstrube/Downloads/semantik-0.5.0/README>: 'L\x07\xefK\xbdw\x0c\xdb\xa9"/\x11o\xf3\xd0C', </Users/jstrube/Downloads/semantik-0.5.0/src/veg.ml>: "\xad#\x0eyi\x8f\xce'\xe0\xeb,\xe0g\x9aS\xf1", </Users/jstrube/Downloads/semantik-0.5.0/src/tslabels.h>: '\xc073=\xaa-8\\6I\xf0\xc3sDn\x17'}
default {<b:/Users/jstrube/Downloads/semantik-0.5.0/src/armtlkto.o>: '\x1f\xde()H\xa9"\t\xae\x87\x80\xfd\xda\xb4\xbc\xfe', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/Bnvzs_rc.cpp>: 'dA\x8bmD\xe3\xd5Q\xa9\x96QT\xd3$\x8b+', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/semantik_de.qm>: '\xbaN6?\xc1X\xc9|\x8b\xa8\xc3\xcd\xde\xa6+,', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/semantik_es.qm>: '\xbaN6?\xc1X\xc9|\x8b\xa8\xc3\xcd\xde\xa6+,', <b:/Users/jstrube/Downloads/semantik-0.5.0/tsts.qrc>: 'O\xe9ucD\xb0\xba+_@m\x07\x85\xe7L\r', <b:/Users/jstrube/Downloads/semantik-0.5.0/util/ocaml+twt>: '\x0e\xb5\xaa\x91\xa7G|\x82\xc5\x91\xa3\xa0d~M9', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/semantik_fr.qm>: '\x1a\xa5\xed\x02\x9b\x9f\x18b\xa8%\x94\x8fv\xc4\x05\xfd', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/azelott.cmi>: '2\xbaL\xf7\xfa\x16\xd9\xd7\x9e\xbf\xe6\x13k(\x17i', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/energia.cmi>: '\xfc\xecO\xf5\xe7J\xa1\xb5l0\x8c\x9d\xe6st\x18', <b:/Users/jstrube/Downloads/semantik-0.5.0/aux.h>: '\xea\xfa}\xa9\xb7<\xf0\xf1\xa1\xc2\xa4L\xef\x15]\x83', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/energia.cmx>: '\x87\x96T\x92#[\xf1\x18\x00\xf6\x9b\x8b\xf8\xe4\xe9\x98', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/mozdulatlan.cmi>: '\xc6\xba\x83.;\x95\x7f\xd7\xa5\x93\x00\xd4\xe0\xc4\xa2\x0c', <b:/Users/jstrube/Downloads/semantik-0.5.0/tsts_rc.cpp>: '{\xa99\x91P\xb8\xab:\xc1\x15\n*\xc3uk\xe1', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/mozdulatlan.cmx>: '1n\xednN>A)\x16\x06U\xf7;(s=', <b:/Users/jstrube/Downloads/semantik-0.5.0/util/ocaml+twt.cmx>: ':\xbbT\xe8\x16\xe6\xa3\xed\x01"\x04@C\xf1\xc1\xae', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/semantik_it.qm>: '\xbaN6?\xc1X\xc9|\x8b\xa8\xc3\xcd\xde\xa6+,', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/azelott.cmx>: "6\xb0w\xe6'\x07\xa8\xe7\xd1q\x853\xf3\xb5t\xc8", <b:/Users/jstrube/Downloads/semantik-0.5.0/src/semantik_ca.qm>: '9\x0f\xc1\x92d\xe2\xec\x02\xccb\xe2\xca){i\xec', <b:/Users/jstrube/Downloads/semantik-0.5.0/src/veg.cmx>: ' \xa8\x9e\xbf\xfa&\xb9\xa4IfE\x19\x1e\xd2\xdb\x88'}

Hope this helps.
Cheers,
Jan


Reply to this

-
.

 Re: Re: Re: Re: 0.4.

 
 by ak47surve on: Aug 5 2007
 
Score 50%

Hi any success on getting semantik to work on osx 10.4 ?

I am currently downloading qt-mac-opensource-4.3.0.dmg from trolltech and semantik-0.5.0.

python2.3 seem to be installed.

Will be following the procedure in README to get it work.

---
Please let me know of any alternate installation procedure. (?)
---

Any help will be appreciated.

I just love Kdissert and looking forward to use Semantik on my MacBook.

- Akshay Surve


Reply to this

-
.

 Re: Re: Re: Re: Re:

 
 by ak47surve on: Aug 5 2007
 
Score 50%

Update: I am also downloading ocaml-3.10.0 as ocaml compiler is also needed to compile from source.

- Akshay Surve


Reply to this

-
.

 Re: Re: Re: Re: Re:

 
 by ak47surve on: Aug 5 2007
 
Score 50%

I have sucessfull installed the above listed packages (see my comments above).

I get the following error in mac osx 10.4:

----
administrators-computer:/Applications/semantik-0.5.0 ak47surve$ sudo ./waf configure
Password:
Checking for program g++ : ok /usr/bin/g++
Checking for program cpp : ok /usr/bin/cpp
Checking for program ar : ok /usr/bin/ar
Checking for program ranlib : ok /usr/bin/ranlib
Checking for compiler could create pragramms : ok
Checking for compiler could create shared libs : ok
Checking for compiler could create static libs : ok
Checking for flags -Wall : ok
Checking for flags -O2 : ok
Checking for flags -g -DDEBUG : ok
Checking for flags -g3 -O0 -DDEBUG : ok
Checking for program qmake-qt4 : not found
Checking for program qmake4 : not found
Checking for program qmake : ok /usr/bin/qmake
Checking for header QtGui/QFont : not found
cannot find QtGui/QFont in ['/usr/include', '/usr/share/qt4/include/', '/opt/qt4/include', '/usr/include/', '/usr/local/include/']

----

Do i need to set the PATH variable with additional look-u areas? Currently it is:

PATH=/opt/local/bin:/opt/local/sbin:/opt/local/apache2/bin:$PATH


Any help will be appreciated.


- Akshay Surve

-

 Re: Re: Re: Re: Re:

 
 by ak47surve on: Aug 5 2007
 
Score 50%

update: qmake & qmake-4.3 are in /usr/bin and thus in the lookup path.


- Akshay Surve

-

 Re: Re: Re: Re: Re:

 
 by jstrube on: Aug 5 2007
 
Score 50%

The dmg from trolltech is probably not going to work, because I doubt they include the headers in that distribution (although I could be wrong). If a 'locate include/QtGui/QFont' on your system comes up empty, you will have to use the source installation.
But if that works it only means that you're going to be stuck at the same place as the rest of us, it seems.
Nevertheless, good luck and please report back if you get it to work.


Reply to this

-
.

 Re: Re: Re: Re: Re:

 
 by ak47surve on: Aug 5 2007
 
Score 50%

Thnks for replying 'jstrue'.

I tried locate. Though, i don't get entries when I search for /include/QtGui/QFont.

I do get some hear like files when I search them individually. eg: locate QtGui and locate QFont.

For QFont one of the listing has this:

/Library/Frameworks/QtGui.framework/Versions/4/Headers/QFont

For QtGui one of the listing has this:

/Library/Frameworks/QtGui.framework/Versions/4/Headers/qworkspace.h
(and many others in the Headers folder)


i also noticed that most of these libs/files are replicated in the Last.fm Application also which runs propoerly.


Thnks for replying.

Can we try a few more things? Is there something we are missing?

Help appreciated.



- Akshay Surve

-

 kubuntu & semantik

 
 by ita256 on: Aug 1 2007
 
Score 50%

Semantik 0.5.0 should run properly on Kubuntu with Qt 4.3.


Reply to this

-

 Re: kubuntu & semantik

 
 by GFD on: Aug 1 2007
 
Score 50%

OK thanks ! It works :) !


Reply to this

goto page: prev   1  2  3  4  5  6  7  8  9 

Add commentBack






-
-
How do you like Plasma 5?
 The best KDE Desktop ever.
 Definitely a nice improvement.
 Not decided yet. Haven't tried it yet.
 I do not like some of the changes.
 KDE is taking the wrong way.
 I am still sticking with KDE 3.5.
 I have no opinion, but wanted to vote anyway.

resultmore
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About KDE-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2003-2014 KDE-Apps.org Team  
All rights reserved. KDE-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
KDE and K Desktop Environment are trademarks of KDE e.V.